KAP 140 Autopilot Bugs

The default KAP 140 autopilot has a number of bugs. I have seen several discussions elsewhere about mods and corrections, but here, I’m hoping to compile a list of the issues as a bug. They should be relatively easy to fix, as most or all of them are not present in other autopilots that already exist, such as the G1000. There is a lot of attention devoted to improving the G1000, which is important, but I fear that this device is not getting the same focus. This autopilot is particularly important because it is used by a number of a third party planes, including my beloved Milviz 310.

These are the issues I personally confirmed today:

  1. When in alt hold mode, if a different altitude is selected, pressing either up or dn puts the aircraft into an aggressive climb or descent towards the new altitude. On the real system, doing that should change the assigned altitude slightly.

  2. Engaging the autopilot puts it into ROL and VS modes, but neither mode works properly when the autopilot is engaged. The ROL mode brings the wings level rather than holding the roll angle. The VS mode either goes to zero vertical speed or the previously set vertical speed, but that can be inconsistent. It should instead hold the vertical speed at the time of engagement. These bugs make the autopilot very difficult to engage during any type of climb or descent.

I’m aware that there are some mods that try to fix these and other issues, but this is a pretty basic piece of core functionality. Again, the default G1000, for all its faults, doesn’t have these issues specifically. A fairly quick pass on this system would go a long way to helping all the aircraft that use it.


Are you using Developer Mode or made changes in it?


Brief description of the issue:

The default KAP 140 autopilot used in several planes (and addon planes) has a number of issues, described above. Those issues are not present in other autopilots so the fix should be simple.

Provide Screenshot(s)/video(s) of the issue encountered:


Detailed steps to reproduce the issue encountered:

See descriptions above.

PC specs and/or peripheral set up if relevant:


Build Version # when you first started experiencing this issue:

Since the beginning of the sim.

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

That is because Asobo is not doing the G1000, another company (Working Title) re-did it and it was available as a mod / addon.

Now, in SU10 it will become the default.

You’re really better off just grabbing the PMS GTN to improve the KAP140.

I’m using the mod from this thread, and so far I’m happy with it. I can’t swear it works exactly like the actual autopilot, since I’ve never used one in RL,but it seems to have all the functionality: New KAP140 Autopilot MOD - fixes problems when using external controls or keyboard - #26 by Latka

1 Like

Another line of bugs with the default KAP 140 is that it engages in odd circumstances. For example, when it is disabled, but an altitude is set, it will engage when descending through that altitude.

I’ve also seen similar behavior when it is on approach mode. After landing with an instrument approach, I think it will engage after taking off in the autopilot is still in APR mode if I cross the approach path. I haven’t totally confirmed this one yet, though.

I did that and it did not work.

I agree with that.