Landmarks shifting up and down + Half of them not loading correctly (still not fixed in 1.13.16.0)

And El Cap…

Issue is not resolved in the latest patch. Objects still load poorly only when you get dangerously close to them and some of them still shift up and down.

I am about to give up on this game. Sorry Asobo. It’s one thing to not acknowledge the issue, but it’s another to mark something as solved and do nothing about it. I don’t think I’ll touch this game again, because each update you break more than you fix and I gave you lots and lots of passes on that one. This is the last straw.

I don’t think my PC configuration means anything but here it is:
Ryzen 5 1600 Stock Speeds
RTX2070 Super 8GB
32GB RAM 3000MHz
1TB Crucial MX500 SSD

Yeah… this is still broken. My findings after enabling dev mode:

In console it loads model and LOD only when I get closer:

It also has LOD 0/3 (highest LOD), regardless of distance, no matter how far I get away from it. LOD never changes. It’s as if LOD levels don’t work for this model.

This is after it spawned it and I moved away from it:


@Jummivana

Sorry for tagging you but this issue is 100% reproduction rate and I don’t think Asobo knows extent of this issue. I sent two Zendesk tickets and both tagged as solved 16 days ago and this issue was still not resolved…

is there a next update for Hotfix?

If they didn’t bother updating it now with new patch, I don’t think they will ever fix this issue… it should’ve been patched by now.

I am seriously considering dropping this game. This bug ruins immersion so much…and it pains me to say that because I love this game… but inability of Asobo to fix issues such as these is seriously making me regret ever purchasing this game.

Also I can confirm that moving game to my new SSD from HDD (executables and files) has no effect on this bug. It’s not hardware-releated. This is clearly sim’s issue.

It is disappointing and frustrating to report issues like these and not see them addressed in subsequent updates, I agree. I looked at Devil’s Tower after completing the update to see if some of the “little” problems or “bugs” were addressed and found it still has the same coding error. An error such as this only takes a short time for a programmer to correct and when they don’t take the time to do it after it’s been reported by many users it sort of dampens your enthusiasm for the sim a bit.

My local airport ( a major U.S. airport) has had no taxiway lights, ever, and I have submitted tickets many times since last March. As of today, still not fixed. All I can do is wait for a 3rd party to either put out a freeware or payware version, because it’s become painfully apparent that Asobo isn’t going to fix these small problems.

Quite disappointing, actually…

Indeed.

I don’t understand Asobo not fixing these issues… If they don’t fix it in January patch, I am dropping this game and never purchasing any DLC or additional content.

No point in playing a game that has immerion ruining issues like these.

You looked at the coding error, can you tell what the issue is with them not loading?

I’m having this popping terrain issue around the mountains of Innsbruck too.

@Jokabaku From the look of it there are 2 different issues in my opinion:

a) Some of these objects are 3D objects, not mesh (TIN or DEM), and this is most likely because they have steep cliffs and the terrain rendering engine is not capable of rendering slanted textures. If this is the case, which means they “drape” the textures horizontally, there is no other way than using 3D objects instead which you can texture like you want. The drawback is 3D objects don’t react to collisions in your examples (could they in FS2020?) and their view distance is governed by a different algorithm than terrain LOD rings.

b) Some of these objects being 3D objects, they are subject to varying level of details (LOD) depending on size/distance. The issue is if the lower resolution 3D object substituting the higher res one as you move away, is not perfectly having the same outside shape, it will show as something changing size/shape as it is changing LOD level as well.

This is the same problem you can see with photogrammetry and “melted” buildings, which are in fact the lower poly count versions of the higher poly count buildings which are not lowering the poly count while preserving the overall shape. Instead, they’re just removing polys by just be removing vertices affecting the shape in the end (think transforming a curve made of 5 points into a line from beginning to end only).

There are techniques to reduce the poly count in a way which is preserving the shape though. One I know of which is really working great (so it seems) is Simplygon:

Look at this illustrated documention for example

The irony to me is this company was bought by Microsoft a few years ago and their asset/IP is therefore available internally most likely but FS2020 doesn’t seem to use this tech. I believe it would be useful in this case and probably other things in the simulator.

2 Likes

Hello Jokabaku, yes you are right, there is also a problem with the Devil’s Tower. I was flying towards it and there was nothing on the horizon until I got near, so near that it suddenly spawned in front of me and I almost crashed into it. But then it remained there and I had no problems with the Devil’s Tower.!

Jokabaku, I haven’t “looked at” the coding error, but depending on how Asobo renders 3D objects in the sim there is a method or “setting” that determines how far away a 3D object is visible to the user. In FSX, there was a scenery complexity setting that made that determination, in FS2020 they may determine that distance in a different manner. The point is though that the programmer does set the distance when creating the object. In most of the POI’s, the objects are visible from long distances, as they should be. In a few, such as Devil’s Tower, the user doesn’t see the object until almost right on top of it. This is a mistake, obviously, and should have been caught by the programmer or someone else checking quality control. That it wasn’t, and hasn’t been corrected almost a month later, is rather disappointing, as I stated in the other post.

I love this sim, and give Asobo the benefit of the doubt on many things because of the sim’s complexity. And eventually I think most of these things will be corrected or sorted out as the sim matures. Still, from a personal perspective, I don’t think these types of errors should be allowed out the door. Someone is dropping the ball…

Asobo needs to stop dropping the ball and fix this…

Same is true for the free “Matterhorn” scenery mod. Shifts up and down. Flying by close, it’s too high.

Its another bug with the Freeware - Matterhorn scenery. There the Update before Christmas caused reducing of Ground Hight at the Matterhorn Ground model and so the “homebuild” Matterhorn Model is now(!) after this over the Ground. The Freeware Autthor is aware of and actualy working on a solution.

I had the exact same problem as previously mentioned regarding Devils Tower, I didn’t see it until I was 200m-300m away which totally broke the immersion and “thrill” of seeing the structure. This needs rectifying ASAP please as this is a Feature brought in to be viewed.

My settings as follows, no Community Mods installed:
VR:

  • Terrain Level Of Detail = 200
  • Terrain Vector Data = Medium
  • Buildings = Medium
  • Trees = Medium
  • Objects Level Of Detail = 100

Bumping this issue so @Jummivana can log it (after Interview)

I am not sure if this has been fixed for World Update: UK, but hopefully this will be acknowledged and fixed sometime in future.

Still not fixed in 1.13.16.0.

Add UK World Update to that list, cliffs of dover don’t load until you get very close. I am loosing hope of this ever being addressed.

1 Like

I have reopened this. I know it’s still not fixed.

1 Like

Thank you. Yes, considering that the POIs are one of THE highlight features of the World Updates, its fascinating for how long they are broken and that new broken ones get introduced as well. As if no one is aware of the issue. But I reported it to Zendesk at the beginning of December, right after the USA update was released.

This thread (and the “Votes”) needs to be merged with this thread which shows Asobo exactly how to fix their issues:

2 Likes