Laugh at the newbie who can't create his first polygon!

I live close to RAF valley on the Isle of Anglesey UK. As with most places, Blackshark thinks it has far more trees than it actually does so I’ve decided to clean up my home area to make it less jarring to fly around.

However, even after enabling Dev mode, installing the SDK, opening a new project and identifying the first clump of trees to remove, I’m stymied by my inability to create a polygon. Here’s a summary of what I’ve done:

Freshly installed 1.14.5.0, no community addons
Developer mode enabled
SDK 0.10.0.0 installed
New flight started from RAF valley

[DevMode] Open project. Selected a previously cleaned copy of the Scenery sample folder from the SDK. All file folder and XML entries modified to reflect my new project name by religiously following the steps in an excellent video by Flying Theston that I’m too new to link to. The YouTube video ID is 3K0XhAf0WYw

Tools > Scenery Editor. Developer mode camera activates automatically. Confirmed it’s active

Focus on the clump of trees I want to remove. NB keyboard and mouse controls do nothing to change the view, but an XBox controller is fine. Is this relevant? If i connect up my HOTAS and pedals, even the controller can’t move the view around

Select Polygon object type in the Objects window. Click Add. One-click placing is not ticked. As soon as I click Add a little coloured vertex indicator appears in the middle of the screen and a new polygon object appears in the scenery editor window, flagged as “unfinished edition”. As soon as the mouse pointer moves out of the Objects window, the vertex marker disappears and a tiny red cross attaches to the mouse pointer

Now, to the meat of the problem. I hold down Left-CTRL and left-click for my first polygon point but nothing happens. Still holding down Left-CTRL I click elsewhere and nothing continues to happen. If I CTRL+Double-click to finish, the error displayed against the polygon in the Scenery Editor window changes to “Point count < 3” and the coloured vertex marker reappears in the middle of the screen.

To my mind, this suggests that the polygon is being started but my single-clicks are being ignored. Although the editor recognises my double-click to finish, it doesn’t add this or any other points to the polygon, leaving it with zero or, at best, one point.

I think that is an accurate summary of the stages I’ve gone through to get where I am. So, which critical and blindingly obvious step have I missed? Be as harsh as you like. I can take it.

I do these things out of habit now, I believe you just left click for the first point then hold CTRL and left click for the rest of the points.

As for moving the camera I like using the xbox controller, not sure where you can see but there are keyboard short cuts for moving the camera. Only the keyboard and the xbox controller are setup for use with the sdk, no idea if you can add more.

Thanks Dorrager. I’d have been kicking myself if it had been that simple but luckily (for my peace of mind, I don’t like being kicked) starting with a simple left-click and continuing with ctrl+clicks is no different. No polygons.

I’ve been through every key on the keyboard with and without modifiers and nothing moves the view around. I don’t mind as the xbox controller is probably a much better way, but I do wonder if there is a connection.

1 Like

I’ve actually experienced the same problem once in a while. I’ve no idea what causes this and I’ve no idea why it goes away, but closing the project and getting out of the dev mode before going back into the dev mode and opening the project again solved it. Have you tried toi set up a completely new project? Maybe something is borked in the project set-up?

I think that’s the next thing I’ll try. Copying an existing project felt safer to start with but maybe I have to just bite the bullet. Thanks. I’m glad someone else has experienced the same thing.

Creating a new project doesn’t seem to have changed anything. I’ve uploaded a video of my process to Youtube in the hope that someone can point out my mistake but I’m still too new to post links. Searching for lC21dKEPHtI should turn it up though.

It looks like from video that you haven’t actually created a project which is probably why it won’t allow the placement of the polygon.

Made this guide when I was new to editing scenery, this is for a very basic scenery add-on
there are more steps if you wish to add models or materials but no need to worry about that yet if your just starting out.

To start a new project:

  1. Open MyFSProject folder

  2. Create a new folder with name of your creation.

  3. Within the created folder make a new file named scene.

IN THE SIM:

  1. Go into the sim load into the area to edit and enable dev mode.

  2. Click on dev mode select new project

  3. A create new project box should open

  4. Click on the 2 little dots to the right then select that first new folder you made.

  5. Where it says my project make the name for your project

  6. Leave the output section with the single dot in it then click ok

  7. Project editor box should open

  8. Click on the little plus icon at the bottom

  9. Add package box should open

  10. Name the package.

  11. In the type drop down box: select BGL

  12. Click create

  13. In the project editor box click on view and then on inspector from the drop down.

  14. In the inspector box fill out the title with the name of your project.
    and fill out creator with your name or gamertag.

  15. Below that you will see an edit click box next to the package name and BGL

  16. Click on edit

  17. Click on the dots next to AssetDIR

  18. When the folder opens select the scene folder you made earlier and click open.
    it should now say scene in the Assetdir box.

  19. Next click on Load in editor.

  20. You should now see the name of the file with BGL in green next to it on the project editor box.

  21. To start editing go to tools at the top of the screen and select scenery editor.

  22. When the Scenery editor box opens click on view then click objects

  23. A box named objects should open.

  24. Click on the first drop down and select simobject or make a scenery change.

  25. After placing your item in the scenery editor box to save the change click on Save scenery.

  26. This should open the scene folder you made at the very start

  27. Check it is in the scene folder make a name and click save.

  28. When you have finished making changes to the sim make sure to hit the save scenery box
    then go to next stage.

To create the Package that you put in the sims community folder:

  1. Go to the project editor box and left click on the file highlighted in blue
    click view at the top of that box and go into inspector.

  2. At the bottom of the inspector box you should click on Build package.
    -a save dialogue will pop up click yes.

  3. You have successfully built the package to add to your community folder.

To find the folder you want to move to the community folder to add the changes to the sim:

  1. Go to MyFSProjects folder open that first folder you created,
    within you will see other folders and files that have been added.

  2. Open the packages folder, drag the file folder within to the community folder for the sim.

Your changes should now show in the sim after a restart. well done.

Created this video a while back to create a simple scenery add-on.

Anyway nothing wrong with being a newbie we all start somewhere. I had someone help me at the start as I couldn’t work out how to do some things, keep at it and you will get the hang of it.

Wow, thanks a lot for the detailed guide. I’ll report back.

Still a failure I’m afraid. I can place simobjects and rectangles all day (I currently have a giraffe looking cold and confused beside a bright yellow A320) but polygons, it seems are off-limits.

I’m having the same problem with polygons. Have tried new projects and editing previously made. I can place objects, save and compile, but can not create polygons. I can start creating one with the left ctrl - click, but cannot get the double click to work to close it out. Running the latest MSFS update. Have tried SDK 10 and 11.

following

I’ve been through your steps above, Dorrager, and taken another video, available at https://www.youtube.com/watch?v=n_lSDvxJQ7U . It includes telltales for the CTRL, Shjift and ALT keys to hopefully prove I’m not mad. I’d be grateful if you could give it a quick view at some point and see if you would do it any differently. Appreciate you taking the time to help me (well, us now!).

I wonder if there is someothing possibly up with the SDK for some people as seen a few having issue’s with things not working now.

But watching your 2nd video when you make that first bgl:


Don’t worry about the company name box, oh and when you finish filling out the box hit enter so it saves what you wrote.
Don’t know what effect it has, but have a go after adding a title for the add-on in the title box
and your name in creator, then change the content type to scenery.
Might be the last point about changing the content type that is allowing you to add objects but not polygons.

No joy I’m afraid. I think I’m going to knock the idea on the head until the next version of the SDK comes out, or I can find an older version to try. Maybe I’ll spend a few minutes covering the beaches of Anglesey with bears instead. Thanks again.

In case its just a weird bug, could try deleting the two files i have highlighted in this screenshot and then reloading the sim will re-add them.
This has previously fixed a bug where the tree removal tool wouldn’t work after a polygon is placed.
Might be worth just re-installing the SDK see if that fixes it.

Still nothing I’m afraid. Thanks for all the efforts to help but I think this one is a lost cause. I’ll come back when the next SDK is released but until then I’ll just fly far from home.

I noticed in your video that when you expanded the polygon, the individual polygon points were displayed in red. So that tells me you are actually placing poly points, it’s just that there is something wrong with them. Just below that there is a Show Error button you can click on. Click on that and see what it tells you. Or just bring up the console and see if there are any error messages.

Thanks for looking. The red entries are actually one per polygon rather than one per point. Clicking the show errors button appears to do nothing but hovering over each red entry shows a brief description of the overall problem, normally “points < 3” if I remember to complete with a double click, or “unfinished edition” if I don’t. Those errors shows no matter how many points I have tried to add, so I don’t think the points are being added. I’ll try looking at the console though, if I can find it.

I found the console window like a pro but nothing is added to it when I try to add polygon points. Adding SimObjects (the giraffe is back on Anglesey!) generates console window lines accordingly.

I have had the same problem. I could place objects, but could not get an exclusion polygon to complete. These are some things that I tried today and could get the polygon to finally close. I have no idea which one or several things suddenly made it work.

I had been using the “Blank Project Creator V1.5” program to get the files started. I went back to copying the sample scenery directory from the SDK and using it. I then went back and re-looked at Flying Theston’s youtube on how to create a project and followed that (not including any Google Earth extracts this time). https://youtu.be/sP7oQaKPTlo

When I loaded the project in Dev mode I made sure my VR headset was unplugged and kept all of the dev module windows on the same screen as MSFS (I run a multi-monitor setup and usually had the dev modules on a second screen.

Again I am not sure what changed, but I can create exclusion polygons now. Hope this helps.

its been a while since i created my last airport, but to complete a polygon, don’t you click ENTER in the end , once you are done placing your points ? Then i think you open up the properties box and exclude stuff you dont want ( including vegetation. I think there are sliders in there that are slid to the left).

Thanks ArterialCard026. I haven’t tried using a project creator but it sounds like not using it might have helped you. Like you, I keep my headset unplugged while editing (and my HOTAS, just the XBox controller connected so I can move the view around) and all the windows are on my primary screen, with secondary kept for forum posts and youtube tutorials.