Left click working in cockpit but not menus

Hi, I’ve just started playing the game with my reverb g2.
When I select menus by pressing the default keybinds while flying (atc, map, etc.) left click on the mouse doesn’t do anything. Scrolling in the menu works just fine.

I’ve seen others having problems left clicking in general, but as the title says, left clicking in the actual cockpit works just fine. It’s making me wonder if there may be a keybind I haven’t seen? Tried binding the “interact primary”, but it didn’t have any effect. I can also see the mouse, and I can see the button being highlighted when the mouse hovers over it. E.g. when i try to close the menu by clicking the “x”, or try to select ATC messages, I can see the mouse being on the button and the button being highlighted, but nothing happens.

Help is very much appreciated!

Toolbar broken in VR - Bugs & Issues / Virtual Reality (VR) - Microsoft Flight Simulator Forums

Workarounds:

  1. Press Ctrl-0 (zero key above letter keys, not on numeric keypad).
  2. Go to MSFS beta.

Thanks! I tried doing the ctrl-0 but it didn’t work. Noticed my mouse setting wasn’t set to default profile. Changed it to the default profile and now the ctrl-0 workaround works!