Loading a saved replay into the Replay Tool breaks the Camera Track

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons?


Brief description of the issue:

Following the excellent guide by Olie I learned that you could add camera tracks by simply recording a new track. I can confirm that this worked in late November 2022 (so post SU11, but pre-SU12) because I used it at that time to record some videos.

Today however I tried to do the same, but now pressing the Camera Track Recording button does not add a new camera track, it’s unresponsive. After further testing I discovered that this bug appears after loading a saved replay. When starting with a new replay, the Camera Track Recording button works just fine. I am in the SU12 Beta, but not sure if it’s related to that, or if it was already there before.

Provide Screenshot(s)/video(s) of the issue encountered:


Detailed steps to reproduce the issue encountered:

Open the Replay Tool > start a recording > stop recording > save your recording. Exit the flight and spawn in again. Then load your saved replay try to add a new camera track pressing the button linked above. Normally the tool would create a $:TRACK 2, but in my case nothing happens.

PC specs and/or peripheral set up if relevant:

Not relevant

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video: