LOD problems - Trees, water

Not exactly true. Trees in alphas had self shadowing and casted shadows on the ground, which is not the case anymore, at least, since the beta. So some features of the trees rendering have been deteriorated.

Completey agree that the sim looks horrible now. More cartoonish than ever.

LOD is ridiculously low. I can visibly see the textures popping in about 5 miles from the sim, and im only flying GA, low level around 1500 fee.t I cant imagine how horrible it must look from higher airliner altitudes.

Water also looks childlish with those repeating wave things.

Trees always were too large, in fact i had posted a tree height fix on www.flightsim.to which i prefer using.

And whats with the mutliple multi storey buildings where there should be none ?

It almost seems like with each update they manage to break something else or roll back things that should have just been left alone. very disappointed

1 Like

I have higher than in-game settings in my config file. I have building LOD at 10.0 (1000 effectively) and terrain at 4.0 (400 effective) and that always stays the same. This isn’t about draw distance. There is something going on with their photogrammetry in the areas where they have enabled it.

Assuming that you can’t have the same LOD out to infinite range, at what distance would you consider a transition to a higher LOD be acceptable?

Please, tell me more.

They don’t cast very far, but they do have shadows at their feet. Even the grass has shadows, which is crazy!

You might want to try this fix:

1 Like

NO. Trees (big trees) don’t cast shadows (except palm trees for some reason), however, small bushes and grass do, which makes no sense at all. What your video is showing is a small bush, look at the trees behind, no shadows. Maybe a bug.

maxed settings, no trees shadows.

2 Likes

I see what you mean. It’s one of two things in that case.

  1. A performance improvement.
  2. A bug
2 Likes

You are right and is ridicullus that the best thing in this game is geting worse every update, What a shame

Decided to create a bug thread about this, in case you are interested:

Thanks, and voted.

I just hope we don’t get any more LOD complaints, that tree shadows either massively impact performance, or cannot be seen from space. You know it’s coming. :wink:

1 Like

Wow AWESOME! Asobo should be paying you and some of us for fixing their patch issues !
I have a tree fix also that i made myself which i use for my version of FS, to bring down the height of the ridiculous 'trees on growth hormone" effect.

It at www.flightsim.to in the scenery/ other category. i belive there is a link on these forums too for it .

But thanks for this building fix!

Now if only there was a fix for the LOD slider to actually work the way it should. The LOD radius in default seems way too close even at a setting of 200 ( at least on my rig), and i dont think the Objects LOD slider does anything at all.

2 Likes

Thank you for your kind words and the Tree Height Fix!

As for the LOD problem, I’ve started a discussion in order to factually assess the issue and help Asobo identifying the causes (if any):

1 Like

update: I’ve made a stunning discovery in tree rendering distance and I’ve created a new discussion for this here:

and a 2.bug can cause 1.performance improvement.

Long time no see fellas, is it fixed already?

I have a weird issue with patches of trees disappearing as I get CLOSER.
Would think the opposite would be the problem, but nope, not on my end.

Try to delete the rolling cache in the game and then turn it Off.

1 Like

Are you using any “Tree Fix” ? If so, this might be related:
LOD problems - Trees Fix Revisited

Not using any mods.

Really not sure whats going on.

I’m starting to have an idea what’s going on. I’m doing a few comparative tests in adjusting the values in the file I’ve made a community fix which I’m posting in the aforementioned discussion.

In short you’re not alone. It is too long to sum up here and I’ll probably add the information in this other discussion later.

update: if you’ve set your Tree LOD to HIGH, try ULTRA or MEDIUM instead and trees shouldn’t disappear…

Hello CptLucky8, I think you’re onto something there. I changed the Trees Rendering to ULTRA and the distance in which the trees were displayed seemed to have doubled from the HIGH setting. Then I changed it to MEDIUM and the distance was half of what it was at HIGH.