Log Book Not Recording Takeoffs

Please tag your post with #pc and/or #xbox.
#pc

Are you on Steam or Microsoft Store version?
Store

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
If I do not engage with ATC takeoffs are not logged in my logbook, landings are logged

Provide Screenshot(s)/video(s) of the issue encountered:
N/A

Detail steps to reproduce the issue encountered:
Do not start ATC or request takeoff clearance, fly to your destination, land, taxi and park. Leave the flight and look at your logbook. No take off is recorded.

PC specs and/or peripheral set up of relevant:
N/A

Build Version # when you first started experiencing this issue:
Latest SU7 from 06/01/2022 (dd/mm/yyyy)

@StevePer63
Hmmmm. I’ve not had that particular problem, even without ever opening anything ATC-related.
Just did another flight to confirm again (D-930).
Is this happening with all your aircraft, or a specific aircraft? I know the Icon had this issue early on with taking off from water, but that’s been a while, so not sure of that status anymore. I haven’t tried it with any other “water takeoffs” lately, so I’ll do one and see what happens.
Hope we can nail it down and report.
Regards
P.S. Just tried the Cessna floats, and it didn’t register a T/O from a custom water area, but did register a T/O from a seaplane port.

I follow these procedures to be certain that all my takeoffs are logged:

EDIT: Also, to see a taxi ribbon, it is not necessary to turn on Taxi Ribbons in Assistance options which will ruin immersion. You can leave Assistance Options at HARD and just for the short time you need to see a taxi ribbon, use the in-flight top menu bar Flight Assistant - Landing & Tax Guides to set the ribbons on and off as described here:

Been like this for a while. You have to announce on Unicom or interact with ATC depending on airport type for a takeoff to count.

I did notice a flight today that did not show a t/o. Cold/dark from phko with atc clearance.
However there was no taxi ribbon, which is set on in assistance options and I use the small arrow mod. So I knew something was amiss at the start.

I fly Kona regularly (patiently waiting for someone to make the grass roofed huts, cough-fsdreamteam-cough) with/without atc or the mod. First time for this non recorded at Kona.

The flights without t/o recorded are very very few and spread out over a year and by the time the log book pops, I don’t remember if I did something “different” setting up.

-something get crossed up during flight setup. It records dpt/arv airports correctly, but associates airborne start?
-lost byte or 2 of data, going to the cloud.
-Or the mod caused it but I’ve had a couple no t/o recorded, previous to using it.

Ditto on the float equipped H.

For others who may read this: Dev Mode ON will prevent proper log book entries as well.

I can reproduce it 100% of the time; dev mode off, not announcing on Unicom/not getting ATC clearance doesn’t log the takeoff. Announce or get “cleared for takeoff” it logs. I never use the taxi ribbon. Idk but it’s one of the sillier easy to fix bugs that should have been stamped out releases ago.

Perhaps I was not clear.

Since September 2020, I have reproduced 100% of the time that at uncontrolled airports such as O69 Petaluma Municipal Airport, if I do not taxi to the runway designated by the sim, I will not get the takeoff logged despite following all of these procedures with a Cessna 172, Beechcraft, or Diamond DA62X:

Confirm that Dev Mode is OFF
Start cold and dark at parking that was selected in the World Map
Start engine(s) and prepare plane to execute a flight plan
ATC dialog: Select runway for takeoff
ATC dialog: Announce taxi
Taxi to and hold at the selected runway
Prepare plane for takeoff
ATC dialog: Announce departure
Enter runway and take off

If I follow that procedure and the runway matches whatever the sim has designated as the correct runway for the current conditions, the takeoff will be logged 100 % of the time.

If I follow that exact same procedure and the runway does not match whatever the sim has designated as the correct runway for the current conditions, the takeoff will not be logged 100% of the time.

Adding the step of activating the taxi ribbon is the only way to tell for certain what the sim has decided is the correct runway. When the ribbon leads to some other runway than the runway I selected and announced, then if I want the takeoff logged I MUST taxi to the sim designated runway first before I continue to taxi to my selected runway 100% of the time. I do this stupid extra step every time the sim has incorrectly decided that the runway with a tailwind is the correct runway for takeoff and the opposite end of that runway that has a headwind is not the correct runway for takeoff.

I often use dev mode ON whenever I do not want a flight logged at all. With dev mode OFF, this described not logging a takeoff issue is only encountered at uncontrolled airports.

We are saying the same thing. If you go into the ATC dialog and talk on Unicom that’s what triggers it to log. It’s a silly 5 minute bug to fix - on runway, wheels up, log takeoff. it should not be considering announcing on Unicom or getting ATC clearance for logging the takeoff.

You are saying that the interaction with the ATC dialog triggers it to log. My experience is that the sim will only log the takeoff if I taxi to the sim designated takeoff runway and that selecting my actual takeoff runway and announcing taxi to that runway via the ATC dialog is not enough when the sim selected runway does not match my selected runway. And this is reproducible every single time, yet this has never been fixed.

I agree with you that the correct way the sim should be determining a takeoff is on the runway, wheels up, log takeoff.