Logbook gets deleted when quitting msfs on Xbox

This logbook problem is easy to replicate.

When existing msfs or it enters quick resume everything looks fine in the logbook the next time you open msfs. The problem accurs when you quit/shut down the game completely, then everything gets deleted except the first flight you did on a “fresh” loggin.

So you can do 1 flight long or short trip and quit msfs and the logbook stays correct, the flight is saved. This you can do after every trip and the logbook adds everything to the logg. Any more trips will get deleted every time the game quits, ctd’s or the Xbox has a os update.

This is not game breaking, but it’s a problem that needs fixing. Shutting down the game completely after every 1 flight to have a correct logbook takes alot off time that could have been used on flying.
Picture 1 is before quitting the game, pic 2 when i logged inn to check the logg.


#xbox

I’m definitely losing log entries as well. I know for sure I lost over an hour’s worth of logged flight time from yesterday.

I my case I have 2 flights from yesterday still there with logged time. There are three log entries if you count the time after you shutdown the plane’s engine and get that 0 hours entry.

I think these were both conducted during my first session of the day. I know certain other flights are gone because I’d flown them with different aircraft. What I can’t remember is if those flights were during the same session or if I’d quit MSFS in between them. I think they were during the same session and for certain they were with different aircraft: therefore, I think the loss of hours might have occurred for any aircraft after the first one I chose.

I have the SU8 mid-beta installed. I think I may have seen this with the original SU8 in retrospect and can’t say for sure if I saw this while using SU7 before the beta - but I see other people have reported logbook entries problems prior to SU8.

Same here for me and it is now stuck since February 12.2022 when I started to beta test . I tried everything from redoing the last flight , sign in sign out , install and uninstalled several times and nothing seems to be happening on my end just stuck with the same hours , same takeoffs and landings this was certainly as a result from the beta testing. No I don’t have developer mode on and never had on my Pc , and also on my Xbox platforms there is no developer mode as well . So all of my 3 systems now are stuck with no hours or movement and I tried everything under the sun and read all the topics in the forum I could find . Yes this is a very annoying bug and it’s more regressed since SU8 beta . Thanks for posting this . I’m with you as well . Restart and everything is not logged in . It logs in while in game but not after restart !

I’ve been some more experimenting and starting to believe this may be related in part to changing the time of day for the flight(s) that get lost after a restart.

I did several flights, using different a/c, at a couple of local airports where it was still daylight so I left the real time the flight planner wanted to use. The flights were logged and were still there after quitting / starting MSFS again. At one point I also quit, powered off, powered on and retstarted but the flights were still in my log book.

On my last flight I went to another airport on the other side of North America where it was now dark. So, like I often do when checking out other areas of the world, I slid the time slider to a daylight setting. After the flight ended it was in the logbook. However, this time, after quitting MSFS and restarting that last flight was gone.

In this first screenshot there are 3 flights for the AT-6B - the last one being the one with the altered time. It’s interesting how they all seem to be recorded with UTC:

After restarting the game that last flight was gone from my logbook:

One other thing I noted is the flights where I only set a departure point, do not record the landings I made. However, the flights I setup with a departure and an arrival do record the landings even though I set them both for the same airport.

EDIT: The flights I lost yesterday were flown in other areas of the world where I had altered the time.

1 Like

Yes thank s for the input it’s some kind of bug again but this time it’s introducing itself in the SU8 beta . I tried this same scenario and to no avail my hours won’t move anymore like they are frozen in time . This only began once I started the beta before that , no issues . It sure looks time related I agree with you there and this is something that needs to be addressed here as others are experiencing this same issue

This is very interesting, think your on to something here with the time.
This needs testing on my next login.
Tnx for the information.

I’m still losing lots of flights between sessions. I’m no longer thinking it’s just when I adjust the time of day within the flight planner. I tend to lose log entries for 3rd party aircraft more than stock aircraft but that’s not consistent either. Have lost log entries for both stock and 3rd party.

I often fly late at night my local time. I will also often start my flights where it’s still daylight in the world unless I specifically want to do some night flying. I’m still suspicious that somehow it relates to date & time.

So, more thinking out loud, in case someone else has been thinking / observing the same thing, could it be something like skipping ahead a calendar day or going backwards a calendar day relative to where you are physically in the real world vs where you choose to fly in relation to the UTC or international date line? It does seem as if logged flight times are based on UTC.

Edit: Similar question, could it be in relation to the servers recording your flight times and back windows / losing some data during server synchronization?

My hours and flights are not recorded since over a week now . I tried it all and nothing on the logbooks . This is server side issue and a cloud issue on the Asobo / Microsoft side . I have uninstalled , reinstalled too many times, tried everything on both the pc and Xbox imaginable and nothing logs

Providing a couple more screen shots in the hopes it helps Asobo with clues. At the end of MSFS activity yesterday afternoon I had these entries:

I quit the game and shutdown the console. When I started MSFS this morning I had these entries:

So I lost the last 6 entries overnight.

I don’t know if there is a way I can tell which MSFS servers I’m connected to (it sounds like PC users can do that). For reference, my closest physical international airport is CYYJ (in real life) and my internet service is provided by Shaw Cable. I experience good internet speed and reliability. Among other things related to this problem, I’m wondering if there is something about the entries which disappear after a game and/or console shutdown relating to where I fly vs where I’m physically located.

PS. I’m on SU8 Beta version 1.23.11

“* Always save user data when closing the game on PC, including closing the window or using Alt+F4 (local profile, logbook and data usage)”

This above is from the release notes of the SU8 Beta release. I don’t think I was losing log book entries prior to SU8 so I’m wondering if we have a regression issue on XBox caused by the above fix for PC?

Were other XBox users losing log book entries prior to SU8?

Has anyone found a fix for this yet?
It’s driving me nuts while trying to get the “Jack of all Planes” achievement.
To keep losing hours worth of flying is crazy.
Is the only answer to just load up, do one flight, then quit (and repeat)?

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Xbox.

Are you using Developer Mode or made changes in it?
Xbox.

Brief description of the issue:
Logbook records flights including takeoff & landing but when software is closed (or crashed) some of the latest entries are nowhere to be found, aka. lost. Flight hours are lower according to lost entries but inner stats (flight seconds) seem unaffected.

Provide Screenshot(s)/video(s) of the issue encountered:
N/A.

Detail steps to reproduce the issue encountered:
Do a flight. Check logbook. While back at the menu, close the game. Relaunch et check logbook again. Sometimes last flight will be lost.

PC specs for those who want to assist (if not entered in your profile)
Xbox Series X.

Build Version # when you first started experiencing this issue:
1.18.15.0.

Are you on the Steam or Microsoft Store version?
Xbox.

Did you submit this to Zendesk? If so, what is your ticket #?
No.

Please tag your post with #pc and/or #xbox.

#xbox

Are you on Steam or Microsoft Store version?

Xbox

Are you using Developer Mode or made changes in it?

Xbox

Brief description of the issue: today I noticed my hours reset. Last month I had over 50 hours heading towards 100. When I checked today, now I have 15. It also says 0/36 completed on training when I have done 90% of it. Is my progress gone forever? Has anyone else seen this?

Build Version # when you first started experiencing this issue:

Latest update from January 2022

Hi, yes I lost 200+ hours when the sim updated a couple of months ago, I wasn’t able to find a way to recover. Funny thing is all my achievements are still in place, not that I care about those.

Well that sucks. At least it’s not just me though. Yeah I care more about my hours then anything else too. Hopefully they can figure it out. Thanks for responding.

I experienced the same stoppage of Flight Hours. Several days later I read about checking the Developer Mode… It was On, so I turned it OFF, and Hours picked up where I left them, but lost the ones logged while Developer Mode was On. Hope that helps some.

I was on Xbox, no developer mode :slightly_frowning_face:

Xbox for me. No developer mode. Thanks anyway.

Hope this is the problem as I had 594 flight hours logged and flew another 80 plus hours and it was still on 594 I do remember about two weeks back I was playing with the developer’s mode for the flight replay. {it was on but was turned off the next day} I Going to do about a 2-hour flight and see if changes, not my long flights I have been flying PC MS

1 Like

I have the problem that my hours won’t go up anymore. They just stick at 102h and when I finish a flight, the flight summary shows the last correctly recorded flight from the 21th january. Weird.