Logbook gets deleted when quitting msfs on Xbox

I lost all my hours a long time ago after an update too. I had almost 800, but that was from having my system clock back a month for some reason, then gong forward while in the game. Turns out that adds to your flight time. So in my case I didn’t mind that it reset haha

Please tag your post with #pc and/or #xbox.


Are you on Steam or Microsoft Store version?


Are you using Developer Mode or made changes in it?


Brief description of the issue: today I noticed my hours reset. Last month I had over 50 hours heading towards 100. When I checked today, now I have 15. It also says 0/36 completed on training when I have done 90% of it. Is my progress gone forever? Has anyone else seen this?

Build Version # when you first started experiencing this issue:

Latest update from January 2022

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

Are you using Developer Mode or made changes in it?

Brief description of the issue:
Individual activity and inner stats are OK, but logbook is empty and total hours is zero.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
No idea, happened after I was doing some flyover of an airport. I did not get any specific message. Just the logbook is now empty (besides the last flight).

PC specs for those who want to assist (if not entered in your profile)

Build Version # when you first started experiencing this issue:

Are you on the Steam or Microsoft Store version?

Did you submit this to Zendesk? If so, what is your ticket #?

Of course most of achievement progress is gone (except unlocked ones basically).

This has happened to me twice in Xbox. It was twice, one right after hotfix 1, and second right after hotfix 2. I’m hoping it doesn’t happen when world update 6 launches.

there is a huge topic about:

( not special for xbox )

Except I got no such message and there was no package release or hotfix or anything. I was minding my own business and everyone is on vacation and voilà. I very much doubt this is an issue specific to content manager glitches. There’s probably something broken deep within the logbook mechanism that can be triggered by the brutal reset of a “packages out of date” error but can also happen randomly.

Before that I got random last flight logs deletions but never the whole logbook. And being on Xbox there’s hardly any mod to blame.

yes… the topic is huge and its not only about the message package out of… :slight_smile:

One example is the latest entry in that topic: ( a simple re-login )

1 Like

■■■■, browsed that topic quickly yesterday but didn’t realize there were so many different situations where this happens. Sucks. I freakin love the game otherwise!


I open previously a Zendesk ticket #118094 for this issue, and also describe it in this topic.

I also lost twice my logbook and my progression.
But, not totally: I flew three bush trips, and was awarded of a success. In my xbox live account, all is fine, not erased. In FS2020, the progression show 100%, but the total say (for bush trips) : 0/10
To overide that, I reflew the las leg of each bush trip, and miracle , the counter now say 3/10 as expected. But of course, I’m far to the 50 hours of flight because this one is based on the logbook.

This bug make quite unplayable the Xbox version, as we are unsure if the logbook will no be lost one more time, soon or later :rage: :rage: :rage:

I also notice that the logbook record wrong things, especially when flying the bush trips. I have the Alaska bush trip in progress, and sometimes, it record nosense datas. Very weird!
When I finish a leg, the screen display the correct result (departure/arrival/fligh time as expected) - but , if i return to the main menu and take a look at the logbook, I see 00:00:00 as flighttime, and arrival airport is replaced by the departure.

There is defintely something very buggy in the logbook.

For the learning flights, I also get a counter of 0… but if I reflew the same lesson, and even get a “C”, it is recorded again as a “A” and counted.

Edit: don’t forget to VOTE for bugs (at the top of the page/topic) if you wan’t a chance to them solved.

1 Like

There are terrible bugs in the way the logbook works on the Xbox version. I’m not the only one complaining about it, and it can have consequences on the number of hours of flights, the successes and it makes the gaming experience really deplorable :broken_heart:.

During bush trips the records are totally corrupted, sometimes it’s good, but often it records a flight with a duration of 00:00:00 and confuses the departure and arrival airports. It’s complete rubbish!

I want a reward :1st_place_medal: for having fly an UFO :alien:
Yes! my logbook contain an entry with an empty aircraft (should be the Xcub - I don’t install any other aircraft than the original premium edition). How is it possible ? :upside_down_face:

Yes what’s annoying is that the main flight hours stat and some achievements are based on the logbook (even though there’s a total flight seconds which seem to be working as intended). That makes some of these achievements basically unobtainable.

Same problem!!! , I went offline with my account and logged in again, to see if it would solve the azure atc bug. Then when back in the sim all my hours and logbook entries were gone,
"hello Asobo when are you going to address this problem of instability of the logbook and propose a backup / recovery ???

This problem seems to be quite common and affects both Xbox and PC. All the more reason to take this into consideration, but it doesn’t seem to bother Asobo too much.

:point_right: Take a look here, for others threads about this issue.

For my part, I decided not to put a dime more in add-ons or DLCs until the fundamental MSFS bugs are fixed, and this one is on my list (just like those relating to joystick and mouse on Xbox).

1 Like

Logged out someone else could log in, logged back in and everything was gone. Logbook empty (300+ hours), bushtrips (75%), landing challenges was at 98%) etc.
Did everything to try to get it back but it’s gone. Also from the cloud which is worrying.

New content and features are useless if the basic reliability can’t be trusted. I love everything that this game (genius moneymaker for them) could be but so far it’s been 80% frustration if I take the zillion times the game crashed at first.

I have also just created an (already “SOLVED” :grimacing: ) Zendesk ticket for this.

Just for the record, PC - Win 10 here - Steam version, fully up to date (non beta).

I have no idea what caused it but I can only guess that it was when I logged out and back in (in game) recently to try and solve another issue, which turned out to be an issue with the servers although I didn’t see the announcement until afterwards.

All log book entries are gone. Flying hours are now at 2. Awards on STEAM are retained but I really don’t care about “Awards” it is just the logbook which had a lot of flights that I liked to repeat and examine etc.

I am guessing no one has a fix for this as I have searched many places for it. So just wanted to add my info to the list.


1 Like

Happened to me 3 times on xbox series x and marketplace is broken. All I got was a tutorial on how to quit msfs properly and a "oops sorry for the inconvenience ". 400+ hours gone


Would Just like to vent that this just happened to me. I had over 250Hrs flight time as well as a few bush trips and now what seems to be all progress on non unlocked achieves, all gone. I now have only 3 hours flight.

1 Like

I have same issue which I reported.
Here is the reply:

Thank you for contacting Microsoft Flight Simulator Support.

The logbook information is automatically uploaded to the Xbox Cloud Save when you quit the sim which is why we are unable to restore your game progression and logbook if your cloud save data is corrupted, overwritten or coudn’t save correctly.

To reduce the risk of corruption, make sure to quit the game by pressing the ESC key until prompted “Are you sure you want to exit Flight Simulator”? then click “Yes” to upload your save.

Please also ensure that Xbox Services such as “Xbox Live Game Save” are running automatically.

  • In the Windows search bar, type “Services”

  • Select “Services”

  • Scroll down to the bottom. Double-click on each entry for Xbox and make sure none of those services are disabled or set to manual. Set everything to “Automatic”.

Just watch your progress and you’ll see that you’re losing flight hours every single day. Especially on a ctd the whole day gets wiped out. Have the same problem and Microsoft has been trying to figure out how to make it right for me since november.
Data is not saved correctly and what is being saved is everything but safe.