Logitech Hotas x-56

The Hotas X. 56 Joystick was ordered in January. With drivers installed, it is available in MSFS 2020 with the default settings.
But it does what it wants. In the interior sight, the throttle lever does not work, in the exterior sight it does. Pitch and roll do not move, although they are connected. If you press the rudder, the interior will move. As if the assignments were completely wrong.
However, setting up my own profile did not bring any success. I have to mention that keystrokes are only accepted sporadically.
Also the reinstallation of MSFS did not work!
I need help!
The Logitech Hotas X-56 is recommended for MSFS.

Regards UPK
Sorry for my English

Well mine worked with very little trouble, though I have changed quite a few assignments to meet my preferences. Does it work properly in the Logitech utility, i.e. if you go in to Settings in the utility can you see all the Axes moving properly? Similarly type Joystick in to the W10 search and open ‘Set Up USB game controllers’ and make sure its working in there I.e. select Stick and Properties and you should be able to see all axes working. If it doesn’t work in the logitech or windows tools its not going to work in MSFS.

1 Like

It works fine in Win 10, even in MSFS settings it works fine!
Every axis is moving correctly. But on the planes it doesn’t work. I have no explanation for this phenomena!!!

I forget to mention the usb is fit directly to the PC, not to a usb hub!

Is there a duplicate key bind somewhere, like the mouse? I would check to make sure only the X-56 has control of the axis. Otherwise, I can’t think of why it would only work sporadically. Mine has no problem in MSFS.

No, after your message I checked it and looked for former stick installations. Nothing.
It’s remarkable, the keybord doesn’t work properly too.

It’s crazy. It works in Logitech utility, in Win utility and in MSFS utility! But it doesn’t work with the planes. No pitch no roll just acceleration! Crazy!
I’m thinking to reinsatll WIn 10. May something with the usb congfiguration?!?

check this out, shows profile settings

or download it here

Only thing that comes to mind is maybe the X56 isn’t getting enough power from the USB port. Maybe your power supply is reaching it’s limit. You could try using a powered USB Hub.

When the GPU kicks in, it does use a lot more power than when idle. And it your test, bit the CPU and GPU are mostly idle.

I have a X56 and haven’t had any of the problems you mention. I have ran it both off a direct USB port and a powered hub and they work equally fine on both.

I have a 500 watts power supply and I’m not coming close to using it all.

That’s exactly my problem.
Everything seems to be alright! My powersupply also has 500 W and I tried usb right on the PC and second, on a powered usb hub.
Don’t know what else to do!

By the way! did I mention that everythings works fine with Hotas X-56 in X_PLANE? It does!!!

Could you have some other USB devices connected that could be interfering? Try disconnecting everything else but the X56 and see if that makes a difference.

Seems that MSFS is somehow confused with something else confusing it.

It could also be some other driver that is installed that is causing the problem.

I also thought about this and removed every USB device, former driver of aThrustmaster was deinstalled before.
Problem remains.
Funny things happen. If I move the stick to roll seats an instruments are going around etc.
It seems as if all the assignments are exchanged!

I also have this joystick and mine does have the ghost presses issue on the throttle quadrant. As for the power supply, that is not what causes the problem. It probably is the VRMs of the motherboard (Voltage Regulator Modules). As the game kicks in, the CPU starts draining power from the VRMs and if they are not beefy enough, they may starve the USB ports.

As to your specific problem, that’s a new one for me. I would guess it was another issue this stick has: that it turns on irresponsive from time to time and needs to be recalibrated from Logitech’s app. Since you say the stick is working on the app and on other games, It seems there is definitely something wrong with your FS installation. If it is the Steam version, try the “check local files” option.

My last guess would be to reinstall FS, but you said you already did that.

Sorry, I’m really at a loss here.

PS: Did you try to remove all mods?

Uff, yes it is recalibrated, no, no steam version, yes, I reinstalled MSFS already!
Logitech support doesn’t answer!
It seems hopeless!

Please publish screen shot(s) of all your throttle and joystick mappings for the X56. Maybe that will show us something you’ve overlooked and we can then try to help you.

Hi all where can I download a custom profile for x56?
Thank you

Thank you for the GitHub link, this will be a big time saver in configuring my X56 controllers when I buy FS2024.