Logitech Saitek Flight Yoke Systems Unresponsive

Is anyone else having any issues with the Saitek Yoke System in Flight Simulator? (Logitech Flight Yoke System, Model: J-U0004. S/N1817KK002779). I have had issues with it on X-Plane 11, FSX and now FS2020. It would run fine for 5-10 minutes and then it would become unresponsive. I would have to unplug the USB, plug it back in then the performance would repeat itself. Has anyone else experienced the same thing?

Another thing that I’ll add. On FSX, the controls would still get to a point where it is unresponsive, but after about an hour or 2 into the flight. No biggy. On X-Plane 11 and FS2020, I can only fly for 5-10 minutes before it becomes unresponsive.

I have the same problem. Not only the Yoke system, but also with Saitek X52 Pro.
It is also difficult to assign functions to.
Hope it can be fixed, soon, since flying with your keyboard only is no fun at all.

Interesting. I’ve tried updating the drivers (last driver is dated in 2018). I reached out to Logitech about a year and a half ago to see if they know, but weren’t much help. I’m really thinking about moving over to honeycomb. I’m hoping someone can try and help here.

I have a ~2014 Saitek Cessna Pro Yoke. FS2020 recognizes my rudder pedals, but not my Yoke. However, when I click the “SENSITIVITY” button, I can see the inputs when I push or turn the yoke. so, the signal is working, it’s just not being used by the sim. I’m going to update my WIndows machine and see if that makes any difference.

Just in case, even though you can see movement of the axis in the “sensitivity” tab you may find actual bindings to aircraft surface controls like elevators etc… not actually mapped.

In my case, CH Flight Sim Yoke, all yoke levers were showing movement in the sensitivities tab but there was no mapping of anything to actual elevators/ailerons, thrust/mixture and pitch.

Yeah, I’ll update mine too. I have the Logitech application for the Yoke System open right now and the controls have been responsive w/o the game running for over 20-30 minutes now. I may have that run at the same time as the game to see if that helps. My Yoke system is a 2017 I believe.

how do you see if it’s mapped? You think that could be the issue?

Sorry on my mobile /cell phone now…
The movement of you’r controller should show movement in the Controls setup tab which is not the sensitivity tab. If you change the option to “Assigned” and then move one of your device controls it should appear in the relevant window.
Look at the YouTube video by Squirrel for a better guide then what I’m saying now.

1 Like

Do you guys have the Saitek drivers installed? If not go to Logitech G Flight Simulator Yoke System and you will find it there. Can’t put link in forums sorry.

Yes. The latest one is from 2018. I just re-downloaded it today.

and does it works for you with that? I downloaded those drivers few months ago for P3D and didn’t work, and now I get the same with MSFS2020. So disgusting…

It’s comforting to know that other people are having the same issue. lol


I’ll be trying the drivers again tonight.

1 Like

Tonight, I updated the re-downloaded the driver for the Yoke System. Downloaded the updated USB driver for the mother board. Even plugged in the yoke system into the 3.0 USB port to see if that would do anything and got the same results. This time after 2-3 minutes, the yoke system including throttle would become unresponsive.

Mine works fine for hours.
Modded the Logitech/Saitek Yoke with an extra Joystick Controller as shown on youtube.

Before the mod, was it becoming unresponsive after a certain amount of time?

Update: Will be trying a USB Powered Hub tonight to see if that helps.

It does NOT appear when I try to assign a control movement.

Have you tried to create a new profile?

Dave - please let us know how the powered USB hub goes.

I’m experiencing pretty much the same issues. The Logitech/Saitek pro yolk is only occasionally responding to input. The yolk appears in the FS2020 control menu but doesn’t respond to mapping attempts.

It does in the Logitech yolk app. So does the throttle quadrant…

The throttle quadrant is completely unrecognized and does nothing in FS2020.

Pedals seem fine.

Latter two are plugged into the yolk.

Also something to note, all lights light up, but LED on the yolk is lit up, but the digital display does not.
Power issue maybe…

I’ve got a powered usb showing up tomorrow.

This is driving me nuts!

1 Like