Logitech/Saitek Radios not working

Logitech/Saitek Radios not working. They appear in the computer Device Manager as ok and in Devices and Printers. But after selecting an aircraft or any aircraft in MSFS neither of my two radios work. I’ve uploaded the latest plugin from Logitech but they both remain off.

They have a habit of going to sleep if they are turned on too long before the sim starts. You could try power-cycling them with the sim running, an risk a CTD, or power cycle them all just before you launch the sim.

The other way is to disable the advanced power management for them, though this doesn’t always work, and for me I still have an occasion where only the multi panel display doesn’t come on. SPAD can do this for you, as can editing the registry keys for each device to disable it.

There is also a standalone program so this, that I mention in the post above, but the site it used to be hosted on has since died. I’ll dig the program out, and upload it to my OneDrive account later.

I re-ran the program on my computer, and this was the output:

The original Uraster link to “USBEnhancedPowerManagementDisabler” is dead:

http://uraster.com/en-us/products/usbenhancedpowermanagerdisabler.aspx

So I uploaded it to my OneDrive:

Hi how are things. Now I will give you a video to make it activate when you start the Simulator. I’m sorry but I don’t speak English, I won’t be able to explain myself. sorry for the inconvenience.

Photo

Video

Thank you Toni, but the problem isn’t getting the Auto pilot to light up it’s the radio’s that are not lighting up when an aircraft is loaded up and running. The lights are on until you load a plane then they go out. It’s the sim thats at fault with the last big update.

David

Download microsoft flight simulator plugin.
Downloads - Flight Radio Panel – Logitech Support + Download

Launch msfs and go to controls options.
Assign key or joystick button to Toggle Avionics Master

apply and save

Go to world map and select departure > fly.

Pre-Flight Checks (example below).

  • before starting engine
  • starting engine/s
  • press toggle avionics master key or button

If you finally get fed up with this, there are two payware solutions. Spad.Next (which I use), and Axis and Ohs.

I can’t speak for AandO, but Spad.Next took the pain out of owning logitech flight panels and also let’s me do some very cool things with all of my flight sim gear.

1 Like

Try using the back pc USB ports or a usb hub that can route power also there is the Logitech plug in found under downloads on the Logitech website if you have not already done so good day

Did you download and install the application from Logitech. You need to double-click the shortcut is the panels do not light up after launch. They worked fine for me up to the point that I was grounded with a crash and now I am unable to reinstall the sim. :frowning:

Downloads - Flight Radio Panel – Logitech Support + Download