Losing mouse control on Xbox Series S/X

This isnt just a XBOX issue, its on PC too. I am super angry that this isnt fixed! Along with many other weird bugs.!

Also, when in external cam and you pan the camera with right click hold the controls dont freeze! What is this stupid logic! What are these devs doing, plus now when you toggle the free look with the middle mouse it resets zoom which bugs everyone off completely!

1 Like

I can confirm this is still happening on Xbox after SU7. I’ve just had a CTD after loading the flight, and after restarting the sim and loading the flight again mouse cursor was lost, the only way to recover it was reloading the sim (again) could not make it work by leaving the sim nor opening another game. I’ve been trying to fly for about 15 minutes without success :joy:


It does happen on PC but it manifests differently. On XBox the cursor is still visible and right and middle mouse clicks still work, the cursor itself is unmovable and the left click doesn’t work. On PC the mouse cursor just disappears in the cockpit and no amount of moving the mouse brings it back, but it was easily retrievable by hitting ‘ESC’ key on KB to go back to the ‘pause/options’ menu, then back in to cockpit and mouse cursor/control is back. This ‘fix’ doesn’t work on XBox, you either have to reboot the sim or soft close/suspend it and open another game that has mouse control in it then go back into FS which is a highly frustrating process! It could be the exact same issue just manifesting itself in different ways, but who knows for sure. Seems to happen way more frequently on XBox than on PC though from my experience.

Still happening on the odd occasion, seriously how this not been fixed!!!

It happens most often for me when im in the world map, my mouse cursor will just stop dead on screen.

I have to restart that game to get connectivity back.

This is on series x.

Im amazed this is still not fixed after it being reported ages ago.

1 Like

Since SU7 I cannot use the mouse for more than 10 minutes in the aircraft. Makes the sim unusable. Disappointed in an understatement.


Hi Folks,
Mouse issue in MSFS Xbox X|S solved.
I know that lots of people have had issues with the mouse problem on Xbox X|S and here is what I have done to resolve it. I can replicate the fault and fix it again every time with these simple steps.

  1. Start MSFS and log out.
  2. Take wired mouse out of USB (if it is wireless you could take the batteries out)
  3. Go to Xbox home screen and then settings, General/sleep mode/restart now
  4. When Xbox restarts Do Not Switch the controller on and remove the USB Connector
  5. Using your keypad go to MSFS tile using tab or arrow keys when selected hit enter
  6. Let MSFS start by hitting any key I use delete. Sign in to your user name by hitting enter key let the game start and when it gets to the welcome screen plug in your mouse USB and left key world map the mouse will work
  7. Now you can plug in you controller and that will work with the mouse.
  8. Very important: IN FUTURE DO NOT DO A FULL SHUTDOWN, AS THIS CAUSES THE PROBLEM, HOLD IN Xbox KEY AND SELECT TURN OFF CONSOLE and when you switch back on again your mouse will work with controller. You must always shut down in this way or your mouse will not work again and you will have to restart from the beginning.
    Hope this help you.
1 Like

Thank you very much for the additional work around. Just to be clear, in case the right folks are reading this thread, the issue hasn’t really been “solved;” the community has just managed to find another (somewhat onerous) way of managing the problem. I remain hopeful that this issue will be more permanently fixed through a patch of some sort so no gymnastics are required to have a working mouse.


This is unacceptable that they have not fixed this issue yet? How can it be almost 5 months now? Are these guys all idiots that work there? Can’t figure it out ? Or just lazy? It ruins the experience


Its just getting completely ignored, they dont seem to care about the Xbox customers anymore, even the community manager @Jummivana doesnt respond in here with an update so going by that alone tells me and others that its not taken seriously!


I appreciate the effort of some who found workarounds but honestly it is rediculus that Asobo/Microsoft didn’t find a solution for this mouse disappearing issue.

Same off topic here but also mentioned the huge increase of CTD since SU7.

No reaction nothing from them.

I really don’t want to wait till February for next SU - if they solve these bugs. I really have no hope.

Asobo/Microsoft bring msfs to xbox to make money and know they leave xbox Users completely alone with all these bugs.

Thanks for that.


Could not duplicate this workaround.

1 Like

Sorry. It worked for me on lots of occassions. Another thing I investigated was my USB hub, my peripherals are plugged into USB3 and I did think of trying USB2 type but the other process worked for me.

Which hub do you have? Cheap?

This what I do as well. I called Microsoft Xbox support and they told me to a complete power off and then unplug power cord. Unplug usb keyboard or usb w/l adapter (thumb drive). Power up Xbox (I leave my hotas one plugged in) . My mouse works once I’m in flight simulator. And then I connect the USB keyboard. This seems to work but then in a day or two it will stop working. I’m not sure if that’s because I turn my console off at night or if it falls asleep or just has a mind of its own. Lol

I know I’ve said this before, but I think it’s part of wider mouse/cursor issue in FS. I’m running FS on my laptop now having now sold my series X, but I have lost count of the number of times my mouse control disappears mainly in the cockpit (A320NX). Now you can get mouse cursor back on PC by hitting ESC or indeed ALT-TAB switching back to windows, where I’m guessing the mouse control UI just gets an ‘auto refresh’ in this process, but it gets quite annoying if you are having to do it twice every fight. Also worthy of note is that the bit of the UI that caused most hangs on XBox - the flight planner can IMO be quite glitchy from a mouse perspective on PC especially all the drop down menus, which look windows esque but are definitely not as smooth in function as windows dropdowns.
What I’m trying to say is that as glitchy and painful as it is to get XBox mouse cursor to recover it could be related to the more fundamental sim UI cursor issues. Maybe it’s not a critical issue on PC as users can just deal with it easily, but without having a shortcut to refresh the cursor UI during the game on XBox it manifests into a more serious bug/bad experience. In my opinion it would be a good idea if such a setting as ‘refresh UI’ option was selectable on a prominent XBox menu until such time that wider UI issues can be addressed.

Hi, I have a 4 port USB 3.0 Superspeed but it wasn’t expensive, probably bought it from Ebay. I have also used my USB 2 hub (also a cheap one) when I lost mouse control and managed to use my work around to get it back, I then changed back to my USB 3 hub.
I lost mouse control again the other day but that day I had backed up my Xbox series S settings to an external drive so when the mouse would not work I restored my settings and that too fixed the problem without using the work around.

Moderator Edit:
Hi all
I also have this problem, but not having used my console for 1 week, wanting to use it today, already I had to make an update of the console unexpected … then now, I can no longer interact with the buttons in the cockpit with my mouse, regardless of the aircraft, while it works very well in the menu, I am lost, I have already cleared the cache, put the mouse on default setting, exit the sim and turn off the console etc … It drives me crazy to look for topics with the topic, I also ask for help on all the groups on which I am subscribed but nothing. Do you have a solution?

bonjour à tous,
j’ai aussi ce problème, mais n’ayant pas utilisé ma console depuis 1 semaine, voulant l’utiliser aujourd’hui, déjà j’ai eu à faire une mise à jour de la console inattendu… puis maintenant, je n’arrive plus à interagir avec les boutons dans le cockpit avec ma souris, ce peu importe l’aéronef, alors qu’elle fonctionne très bien dans le menu, je suis perdu, j’ai déjà vidé le cache, mis la souris sur paramètre par défaut, quitter la sim et éteint la console etc… Ça me rend fou de chercher des topics avec le sujet, je demande aussi de l’aide sur tous les groupes sur lesquels je suis abonné mais rien. Auriez-vous une solution ?

Unreal that we are now 4 months further after i first started the topic and reported the issue and still no FIX and not even a worth from Asobo or even a worth from the community manager @Jummivana why are we being ignored ??? Why can we not get a straight answer as to when this will be fixed ?? It’s not even on their todo list for crying out loud!


We should be getting weekly, if not daily updates on this. Instead it’s the complete opposite: complete radio silence. Unbelievable.

Even Easier

When on MSFS Home screen unplug mouse Press Xbox Key on controller to go to Xbox home screen.
Tab along to profile and sign out it will log out of Xbox and MSFS
Long press Xbox key and select restart it will restart with controller turned off so unplug it.
Using the keypad open MSFS Hit Any Key and sign in.
Let the game load all the way to the home screen then plug in mouse and click on world map it should go to the globe.
If that worked you can now plug in the controller.
Very important: IN FUTURE DO NOT DO A FULL SHUTDOWN, AS THIS CAUSES THE PROBLEM, HOLD IN Xbox KEY AND SELECT TURN OFF CONSOLE and when you switch back on again your mouse will work with controller. You must always shut down in this way or your mouse will not work again and you will have to restart from the beginning.