Losing mouse control on Xbox Series S/X

On the xbox series X when using keyboard and mouse along side Xbox Series X Controller then when flying you lose mouse control option after a couple minutes in the air. Only way to get your mouse movement back is restart the sim.

Already filed a support ticket for it but wanted to post it here too

im on pc and im losing it when im using my joystick too! It wasnt like this before!


exactly when you use the joystick tool then it happens, wasnt like that before on pc either


its a big mess up. It takes ages to get used to this now but we want it like it was back then!


Also happens when you hold de LB modfier key and use freecam then when you stop using freecam poof no more mouse control. This is very annoying for those of us that like to also use the mouse to control instruments in the cockpit. Hope this gets fixed and fast.


Also happens when you only move the cam around in the cockpit with the left stick, really annoying this issue. So we cant move the cam inside the cockpit and we cant use free cam and we cant use the icon lock or we lose mouse control. This is crazy.


Really hope we see a fix for this soon, it looks like it simply happens after a couple minutes of flying even if you dont use any other controls like I previously mentioned.


I have a same bug.

I lose control of the camera with the mouse in cockpit view, (it’s ok in exterior view), if my controller is plugged into a PC.

It’s really very annoying: '(


Same here… startet on XBOX zoom out with my mouse (I dont like the cockpit view), after a couple of minutes in the air i want to correct the view… nothing happens with my mouse, but battery was not empty because in other games the mouse still works.

I played it only xbox yesterday, not pc.

Also I´am missing the other pilots airplanes on the VFR Map (on xbox)… before release on 27/05/2021 that problem didn´t occured on pc. (but thats another problem that does nothing have to do with that one)

1 Like

Just puzzled.

What would you actually use a keyboard/mouse for?

I’m running an Xbox Controller and HOTAS (on XSX), and I’m unclear when you’d use it? :thinking:

Same here, I’m on PC, few minutes in the air and then mouse is gone.
Has someone found at least temporary solution to avoid this problem until the fix? Because for me it’s unplayable for now.

Because it’s for a lot of simmers easier to use the mouse to control instruments in the cockpit then to click the left stick and lose control of the plane. With using the mouse we can adjust instruments and still keep control ourselfs instead of having to give it to the AI


Got it. Harder on a sofa, but yes, the stick push isn’t perfect. :thinking:

:white_check_mark: Resolved with : Game unplayable with Xbox controller on PC since SU5! - #31 by danzio56


Tried it out and that also works for the mouse problem on xbox series x, makes me wonder why Microsoft / Asobo didnt do this by default it would have saved so much frustration for many

Gues I spoke too soon it still happens but not as often anymore


And back to it happening everytime, after like 3 minutes the mouse is frozen stuck on the screen. The scroll wheel still work but you cant move the mouse anymore. The fix worked last night and I could play for a couple hours with no issue but now back to the same problem. Also it keeps resetting the deadzone to 9% after every startup so annoying hole this gets fixed and fast


Whatever is causing it no idea but looks like MSFS doesnt want us to use the mouse on Xbox, it works for 10 minutes max and then the mouse gets frozen stuck on the screen only way to get mouse control back is restart the sim only to get it stuck again after like 10 min or so. Hope this gets looked at.


I gues this issue wont be getting fixed with the hotfix patch tomorrow, I sure hope a fix will come soon though as now you cant use a mouse on Xbox

1 Like

Unfortunatly this issue was not fixed with the update today. Was hoping it would be fixed but no. Still mouse freezing up after couple minutes in flight, scrollwheel keeps working and buttons too just cant move the mouse anymore