Low FPS with RTX 3090 and AMD 5950x

Hi fellow flight simmers!

I’m having a strange issue on a very high-end machine. My system is a 5950x with 3090, and I am limited by the main thread. Also, using 3440x1440 resolution. 850 Watt PSU is more than enough for this system according to PC Part Picker.

Earlier this year I was able to use maximum settings in New York City and get 40 to 60 fps consistently.

Now, I am getting 20 to 40 fps with the same settings. Something odd is going on here…after a series of updates my FPS has dropped significantly.

I see others’ videos with the same CPU and GPU setups pushing 40 to 60 fps in demanding scenery and airports areas - even after the updates. So, seeing 20 to 30 fps is a letdown compared to where i was early in the year.

I had to lower TLOD to 200 and Objects to 100 just to experience 30 FPS at KFJK - it used to be maxed though…

My 5950x rarely boosts to 5GHz, and the temps are only at 70 C under sim conditions (so it has more room to boost at those temps)

GPU temp is around 68 - so its not a hardware heating/cooling issue.

I’ve also experimented with DX11 and 12 - there’s no difference in FPS.

Any ideas for how this issue can be fixed? Or, if you had the same issue and fixed it?

Edit: I want to add that aside from my 3090 system, I also have a 12950HX and 3080ti laptop that performs better. Around 29 FPS mininum at 4K max settings, TLOD 400, in high density areas.

How much power is your 5950X pulling? I am power limited on my 5900X.

Ive got a Corsair 850w gold power supply. The 5950x has a TDP of 105W.

once my video processes ill show yall whats going on with my setup… its a EVGA FTW3 Ultra 3090ti with a 5900x and a seasonic Titanium 1000watt PSU and 64GB of DDR4 3200. What you’ll see is the DX11 version. As the DX12 version is so broken i couldnt even fly it.

do not use dx12 ,my laptop dx12 :10 fps , dx11:40 fps

Thanks! I dont see a difference in FPS from DX 11 to DX 12.

Previously when the Top Gun DLC came out, I switched to DX 12 and got bad frames. I switched to DX 11 and frames were normal again.

Now I’m getting the same FPS no matter which version I use (20 to 30 fps)

Are you using Vsync (either in game or via Nvidia control panel)?
If so have you changed/checked your monitors refresh rate?

Here are my performances in DX11 right now… FS2020 UW after update 10 Direct X 11 3090ti performance - YouTube

1 Like

Thats exactly the same thing that’s happening with me. No matter what the sliders are set to, the frames are averaging 20 to 30 fps. Do you have any ideas about what’s causing it?

Ive just heard that the latest windows 11 update causes issues with the Nvidia cards. So postpone updating windows for right now. If not you’ll start to get worse studdering in your games. Performances may vary so update at your own risk.

Which could be the reason why I’m having issues because I’m on the insider edition.

Last I played I was on a release edition and didn’t even think about that before I posted.

I have the same exact issue.

My Configuration is :

RTX 3090
5900X
64 GB RAM
750 W PSU

With the Fenix I start flights at above 30fps but when I’m landing the FPS is down to 22fps

For example : LIRF to EDLP both with the custom scenery mods.

This framerate drop also happens with the PMDG 738

Even the GPU is never pushed to 100% and CPU temperature maxes around 70 to 64°C

Please help me

Yeah, glad to hear I’m not the only one seeing this problem.

I haven’t had a chance to update to the new NVIDIA studio driver - apparently people with 30 series cards are getting much better FPS than before when using it with SU 10.

Is your power supply enough wattage? My 3090 recommends 850w (but it’s the Asus Strix OC version)

I find it odd almost like our AMD CPUs arent throttling in this game.

I play other games and my PC destroys them - 125 FPS in Hell Let Loose on max settings. It doesn’t seem like a hardware issue.

I’m going to run the new graphics driver and report back.

This post was flagged by the community and is temporarily hidden.

Do you have any of the World Updates installed?

Have you tried a complete reinstall of the sim and/or Windows?

I have a 6900XT and 5900X and recently reinstalled Windows and running with only one or two WU’s installed now, and performance is significantly improved.

I’ll add my 2 cents here - may or may not make a difference. I watched your video and noticed you had DLSS turned on and your MSFS full screen resolution was set very high - I suspect it matches the native resolution of your monitor?

If this is the case, I believe you’re not getting the performance benefits of DLSS. DLSS as I understand it upscales your resolution very efficiently, however, you have your MSFS resolution equal to the native resolution so no upscaling is happening. MSFS is rendering the screen to the full resolution of your monitor so essentially eliminating any performance help DLSS could provide.

What I recommend you try is set the MSFS full screen resolution to something less than your monitors native resolution and let DLSS do the upscaling. The result should be less GPU % usage such that now you can turn things like TLOD up a little higher.

Edit: I also recommend that you turn hyperthreading off in your bios if you have not done so already. Doing this with my 5900x helped reduce the micro stutters. Your processor test scores on the artificial stress tests will score a little lower in the multitasking areas but your single core tests will be a little better (and that helps MSFS).

Did you run the new graphics studio driver yet ? Did you have any performance improvement ?

This isn’t how DLSS works. DLSS will render the sim at a resolution lower than your monitor resolution, then use AI to upscale the resolution to the same as your monitor. You can see this in the FPS counter on the Dev Mode. With DLSS enabled, your render resolution (which is what the GPU renders at) will be lower than the screen resolution. There’s nothing special you have to do regarding resolution.

Another user asked something similar awhile back, perhaps this can be useful.

1 Like

Ok - good stuff. So it looks like this is a difference between AMD’s RSR and Nvidia’s DLSS implementation as with RSR you have to manually set the in-game resolution lower than the native resolution of your monitor. The enhanced FidelityFX Super Resolution looks like the game itself requires some changes to support it.

Hey Y’all - the NVIDIA Game Ready Driver for MSFS 2020 just released today. I downloaded it and tested the results.

My Test Results are with all graphics sliders MAX and using TAA anti aliasing (DLSS surprisingly didn’t improve performance). TLOD = 400 | OLOD = 200

Aircraft is the PMDG 737-800 (which I hear can be quite demanding on your PC)

At KJFK in New York:

Before New Driver
FPS Avg - 19

After New Driver
FPS Avg - 29

10 FPS Improvement with better settings - keep in mind that MSFS has been increasing the TLOD and OLOD from where it was in the beginning when it released.

When MSFS released TLOD was capped at 100 - they’ve been increasing it up to 400 now. This greatly affects performance.

Ok…with that in mind here is my FPS with settings at TLOD 200 and OLOD 100 (which is still much better than what MSFS originally released with)

At KJFK results

Before Driver - 20-25 FPS

After Driver - 35-40 FPS

This is flying in the most demanding scenery in the game. I tested at Chicago O’Hare (KORD) and Charlotte Douglas Intl (KCLT) as well - very demanding airports - and received the same FPS gains as KJFK.

Added bonus - the stuttering and freezing when panning the views is 99% gone. Much smoother gameplay.

Overall, a nice improvement over the previous update.

Cheers!

Hi there. My setup is similar-ish to yours - 5950x, 3070 OC, 64Gb @ 3600, 2Tb NVMe, and 850W power supply. I am running 5120x1440 (or something like that) and i was getting 9-12 FPS at KJFK with med to high settings, lods at 200 and 100 with airport traffic at 25-50 settings.

I turned on HAGS (Hardware accelerated gpu scheduling) and that shot up to 30 FPS steady.

I then cranked up the settings to high to (mostly) ultra, leaving lods the same, and setting airport traffic to 50 on all three, and now see 25-30 FPS.

Haven’t installed the new video driver yet, but have had historically worse performance with DX12.

Check your HAGS setting and see if that does anything for you. I had it off as I noticed that was recommended more often but switched it to on just to see. Glad I did.

Best of luck!