Mandatory update on Microsoft store but no update

i started up the latest msfs trying to install hot fix but it says a mandatory update on Microsoft store when i went to the store to check for updates the sim did not appear in the available updates

see screen shot in link

https://prnt.sc/1qe8o5q

There was a gps update a few days ago.Only a few megs worth.

1 Like

I am experiencing the same problem. At startup MSFS2020 insists an update needs to be installed from store. But in the store there is no update.
I already tried the following things:
reinstall Gaming services
Signed out and in from the store
Deleted MSFS from my system, also removing the filed at AppData and removing any other folders

After a fresh install the problem persists. I managed to start it up once disconnecting the internet while starting. But it only worked twice, now MSFS demands me to enter die game disc.

Any ideas?

3 Likes

Ok today I went to Microsoft store it updated all of a sudden like magic I updated my navida graphics driver that was probably the issue

It didn’t solve the problem for me. But I followed the steps here and that helped:

https://forums.flightsimulator.com/t/you-are-missing-packages-that-are-essential-to-run-microsoft-flight-simulator-please-update-the-application-and-try-again/427269/267?u=s0k0ban

I was not using the XBox App before. After I started it, it immidiately found and update for MSFS.

Same here. NVidia Drivers were up to date, Windows was up to date.
I tried moving the launcher from one DD to the other, nothing.
In the end, I had to uninstall and re-install MSFS. Which means I lost all the settings.
I did not have to re-download the whole game, because most files were already on the computer.
For some reason, the uninstallation did not delete most of the files, only the settings… Which is exactly the opposite of what a normal uninstallation program does.

2021 : Microsoft does not know how to update a game on a Microsoft system.

Three hours after trying to launch the game for the first time, I am giving up because I do not really want to go through rebinding my peripherals and tweaking my graphics again right now.

The sim is awesome, but updating should not be a complicated thing in 2021.

5 Likes

It’s the Xbox app. Re-install it.

3 Likes

Running through the Xbox app and the update from the store installed. Then on restart of the sim I am able to install the latest update.

But why do I need to run Xbox on my PC to get an update? For that matter why do I need to get part of the update from the MS store and then the biggest part from the simulation? There’s likely a dumber, more complicated, and nonsensical way to complicate the process - but darned if I can think of it.

BTW over an hour to figure out just how to get the download. But at least they fixed the inside cockpit scanning with the joystick hat. [CORRECTION - the hat always worked, it’s the right mouse button which stopped working for the cockpit scan and they still haven’t fixed it.]

3 Likes

yes, update works for me now.

1 Like

I had the same problem, after an update of both the video drivers and FS 2020. FS was demanding an update where none were listed in the store. However, ended up getting the updates (3) without reinstalling FS 2020. As follows for PC:

  1. disconnect the internet connection
  2. Start FS 2020
  3. press OK through the error reports, until FS say’s it can’t verify the license. Stop at that prompt!
  4. reconnect the network
  5. Press OK through the license prompt.
  6. FS 2020 re-checked and came up with a list of 3 updates.
1 Like

Had to uninstall from the app settings in windows. Then reinstall from my orders in Windows Store. then run it and install 127GB of updates to run. Not happy. Apparently my version, the Deluxe upgrade, is no longer sold, so I imagine that causes issues with testing updates.

It started here but just to go straight to an 127GB “Update”. :angry:

Same problem after not using for several weeks. I purchased the Standard disk version (runs from store with CD1 in Drive D:). Behaves differently. Ran 1. & 2. above then got demand to go to store for update. Back to square one!

Same issue - on WIndows 11 insider preview edition. Stumbled on a solution (for me at least) maybe it’ll work for others.
Go to the Microsoft store. Find flight simulator in your library (bottom left store icon). Expand it. For me when I expanded it there was an “Update” button (not on the library list display). That took me to the xbox app which then miraculously also had an Update button. I clicked that and then when back to the app store library view and clicked “get updates” amazingly MSFS was now showing up with an update.

This is entirely unacceptable from my point of view and needs to be fixed. That said at least it worked and isn’t as nuts as the uninstall/reinstall of all the gaming subsystems that I saw in another post.

3 Likes

Thanks, this worked for me! (Windows 11 InSider too)
What a mess, getting updates

Guys, that’s bad, period.

The mandatory update from the store never showed up, app repair did nothing, uninstalling and reinstalling re-downloaded all the packages.

This is unacceptable from a small player company, it’s even less so from Microsoft.

You guys have work to do.

Edit 1: Although it did show a progress bar for a volume of 100 GB of downloads (for a package folder of 103 GB), it actually downloaded only 40 GB - which could well be the missing updates volume, much better than what it displayed initially. It would be better for our temper to have a proper estimation of the download volume…

Edit 2: Nope, after that it declared world updates 1 to 5 were no longer installed nor downloaded, and to reinstall them I ended up downloading an additional 80 GBs (so 40+80=120 GB of the now 163 GB packages folder). Geez.

Great way to reduce energy consumption in climate crisis times, Microsoft !
Come on guys, surely you can and should do better than this !

Just went through the entire process of updating windows, syncing clock, all that jazz, and after every step, tested the process.

For me it was the Xbox app. I had the old Companion app which I uninstalled, then used Windows Store to install the new Xbox app. I signed in on that, used it to start FS20 and got that same ‘mandatory update’ message. Used that dialogue to open Windows Store, top RHS 3 dots, ‘Downloads and Updates’, ‘Get Updates’ and bang; there it is.

Hope this helps someone else. All the other stuff was seemingly pointless.

1 Like

Worked for me ! Thanks, the XBox App thing was the solution !

Same problem here…raw launch of my desktop shortcut of MSFS gave me “Mandatory game update required from windows store”…no update found in store…downloaded the Xbox app and it immediately found an update… Whatever Microsoft?!

Hi! After reinstalling I’m into my 16th hour of mandatory update after starting msfs yesterday as normal. it has reached 74% and at this rate I expect to be able to use the sim round about 10 pm this evening. Everything was working fine and I was about to install my own liveries, or so I thought. 134 GiB to load Standard Content and Delux Upgrade and I purchased the Delux model through game pass. Am I doing something wrong, seems heck of a long download. Steve.