Manual Cache catastrophe.. Now un useable

Made 4
1 meg custom cache files, made one 340 meg one. After that the feature is now dead, When I select it to view manual cache, it brings my system to it’s knees and only a CTRL+ALT+DEL with end it. Any ideas?

1 Like

None yet. I set 100gig
After an hour I terminated. It set it or had only done 64 gig

I set a Manual Cache of 100GiB, and interrupted/End-Tasked MSFS after about 10 minutes thinking it had hung (Screen said do not restart PC or end program). When I got to mapping my areas, the Cache had only built to about 64 GiB.

Unfortunately, the program builds the cache files slowly. Hint to Devs - a Progress Bar would have been useful here.

The good news is once the Cache file and allocation is MOSTLY built - as in my case above, being in-Program and dynamically increasing from 64 GiB to the full 100GiB went much faster.

Patience is the key I suppose.

I downloaded my area but yes same problem frame rates went to 1 or 2 had to wait for ages to click in the box and delete it from system then the computer came good again. My cache was also set to 100gb. I will be waiting to do this again once ms update.

Manual Cache is unworkable. Perhaps remove this function until it can be redesigned?

I downloaded my area but yes same problem frame rates went to 1 or 2 had to wait for ages to click in the box and delete it from system then the computer came good again. My cache was also set to 100gb. I will be waiting to do this again once ms update.

I removed the cache file from it’s folder, left the folder empty then while in the options menu I was able to put the file back in the folder. I got into manual cache and I was able to have the program rebuild the cache file, My file is 50 GIG, the data is only 345 MEG. Yet it took 30 minutes to rebuild the file, Even after it had done that the mouse lagging so bad I was barely able to get out of the menu. Back to the main screen where I could now select OPTIONS my mouse now moving as it should and I went back into the manual cache and it started up slow and the went to directly updating the cache file. HAD TO ALT+CTRL+DEL to get out. MANUAL CACHE IS BROKEN.

How is it unworkable? I mapped most of the scenic areas of my state, Large Low, Scenic Areas at Medium, Airports at High, all showed up. Looked pretty good, taking into account my individual graphics settings (which are mostly low).

A plus - if you map the Sedona and Flagstaff areas before taking the Training Lessons, you’ll probably see a boost around your performance (i.e., framerates) as it’s loading directly from the cache versus pulling down from the servers.

I mapped Calgary in high detail. Manual Cache is broken. At least for me it is. That’s the 345 meg file.

Not tried manual cache for a while but I rememvber it taking a long time to generate the cache file and I have a really fast HD. Did you try with a smaller amount. Sorry I can’t try at the moment as I’m still installing the sim.

I tried the “manual Cache” and it seems to help. My home area is KPNS (Pensacola, FL) and I selected numerous tiles covering the entire area. I don’t remember what I set my cache size to but I think it was about 20 GB. After selecting and saving the area I started a flight. It appears to load much faster than earlier flights in the same area. The manual cache is a great idea. It may still have a few bugs. We will do more testing tomorrow. It appears that a 20GB size is enough to store numerous areas.

I have a 1.8 GB file for my state capital, which is the largest so far of all the High Quality map caches I’ve created. Surprisingly Boston which is bigger than my state capital, only came in about 745 MB taking in mostly Logan’s layout.

I think a lot of folks are having trouble depending upon their disk drive setup. If I had the money and the luxury, this would all be sitting on a separate SSD just for the manual caches. However, I’ve moved mine to a 1TB HDD and set it for about 100GB. The rolling cache stays on a separate NVME SSD along with the FS program. Notably, my OS sits on yet a third SSD. Some folks may be seeing disk performance go down if FS, the OS and their caches are all sitting on the same physical drive.

I agree, u have good points. Having a SSD and/or NVMe is definitely the “only” was to run this puppy. The next mandatory item is a “Powerful” graphics card. FS has always placed a HEAVY demand on graphics capability including graphics card clock and memory size. Sadly, the graphics cards we need often cost as much as the entire system…

I moved mine to a SSD, much like your setup Pursued I took it off the m.2 drive. Nevertheless it was able to create the cache but exiting afterwards was very choppy and slow. I was lucky to get out without “Killing the process” in the task manager. I’m afraid to even go back there.

There is NO NEED to create a huge manual cache from the outset. It can be resized at any time, so start off with 10GB and try a test area.

The cache data is surprisingly small, even for the high def areas.

Thank you. I was wondering why the cache be 50 GIG in this case has to be used up “so to speak” when rendering the cache, yet only less than 350 was really being used? I will resize and see if that helps. Thanks for the response.


You need to delete the old file as resizing only works “UP”. :crazy_face:

I kept the same file. nothing got corrupted. It rendered the cache be it not without issues exiting the menu.


It can be resized indeed dynamically. However, you run into the same challenges as when creating the file from the outset - i.e., warning box, no idea if the application or process hung. Better to get it over once.

Manual Cache works great - so far, after having no major install or run issues, its the coolest feature. Yay High level details of your town and airport!