Many, many issues

Although this sim has such great potential i feel it has a long way to go and it almost seems to be going in reverse, instead of forward. When I first purchased the sim (premium deluxe) i was quite amazed at how it was. As a pilot myself I was quite pleased at how the the Cessna 172 performed. Then I decided to hop in the King Air (which I have quite a few flight hours in) and although not entirely blown away since I wasn’t expecting a study level aircraft, I was still thinking “not bad for a generic aircraft.” As the updates continued to roll out I found things seemed to be getting more unstable with each update. The aircraft controls seemed to deteriorate to the point now where they are nearly impossible to hand fly anymore. Again, I believe this sim has such great potential and I believe it will be a superior flight simulator once the bugs are worked out and study level aircraft become available, but for now I think this sim needs a lot of work and I will be going back to Xplane. At least until the major bugs with the aircraft are worked out. I do, however, look forward to the potential developments in this sim and am excited for the progression of it.


Please take your time to search for existing threads and participate in discussions before opening a new thread talking about the same topics.


Do you mean they feel more twitchy and sensitive now after the latest update? If that’s the case, set all control sensitivity to 0 and work your way up from there slowly. Start from 0 percent for elevator, test. If not happy, set it to -10, and so on. With the latest update, some more options were added to the Sensitivity part alone.


adding to the post above about double checking your sensitivity options, also please make sure your flight model is set to ‘modern’.


You appear to be missing a forum moderator tag…


Hi guys,

I am starting to get the same sense. Not really noticing much the benefits of the updates, but things like performance in general are suffering, at least in my case.
After latest update I am getting an often beeping noise (like something reconnecting to my PC) and the simulator freezes. As I go it gets more and more frequent. Very annoying and makes it unflyable.
Not sure if it has to do with it, but my GPU seems to be working almost at 100% (GTX1080FTW), but it wasn’t behaving like that before. FPS are around 35, which is what I had before. and I am getting those numbers at the times when it freezes, which is weird.
I have my graphic settings at Medium and currently avoiding heavily loaded sceneries and it doesn’t help.
Does anyone have an idea of what that could be?

Thanks guys !!!


All - Don’t know if this should be here, purchased the IFR Training, FS Academy. They start you out in C152, and the first flight module, I could not keep plane heading correct, altitude, nada, constantly fighting it. So after that one I went into controls/joystick/sensitivities and changed the sensitivities on all the sliders to -30% (except throttle) I increased the dead zone to 25% and those changes seemed to get the AC flying much better. All the neutral zones are zero. Much better, Logitech 3D Pro, long in the tooth.
Now, if Asobo could just get the trim buttons working better, it would be good at least in GA. I still think whatever trim setting you make, it’s slowly reverts back to null.

1 Like

That seems like a hardware issue on your side. Perhaps an issue with one of your USB devices ?
The only moment where the simulator can freeze is when loading large amounts of data in the vicinity of a photogrammetric town or 3D assets. But the beeping noise might indicate more like a USB device disconnecting and reconnecting intermitently, or something else.

Thanks I’ll give it a try!

I have a forum moderator tag.

I’m quoting this message because it contains useful information.


That could be posted in 99% of the topics on this forum, and then there would be nothing to moderate. :thinking:


Sounds good to me

In order to lighten the forum I suggest a new fixed section:

“Why I return to X-plane”

So people can be comfortable with their frustrations in only one thread.

A major issue is controls being reset with each patch.
Lack of adequate patch notes also.

Why is there more than one control scheme for the controllers, it’s just odd and once again poor documentation.

1 Like

Before I got my Saitek rudders back from storage, I needed to use my Xbox One controller with USB cable. For some reason (probably either a bad cable or connector) the controller keeps disconnecting. I move the cable or controller slightly and it reconnects. But at that time my sim freezes completely (sounds keep playing though…?) and the unfreezes and continues on as if nothing happened.

So perhaps, as Lolilol1975 indicated above, it is caused by one of your USB devices dis- and reconnecting.

Feel free to not read any threads you feel are duplicates.

It’s not returning to zero. It’s just that the planes in this sim are actually pitch-unstable. and this makes it quite difficult to trim for level flight. The planes in the sim would not get certified to fly IRL like this.

1 Like

@MeridianSquid71 I’ve not had any issues with trimming the GA airplanes at all. Trim doesn’t return to 0 either.

Please doublecheck that you’re on the ‘Modern’ flight model setting, and doublecheck your bindings for trimming. It’s something on your end.

1 Like

You can say that again. However, I reset my JS a bit, and it seems more stable in lesson 3 of the IFR Training program. Aint like FSX, could trim them out perfectly, and it affects all of then as well. In 787, If you go to outside view, and then lower or raise trim, the plane is not affected one bit, and if you watch the trim needle, it slowly returns to null position. I think this has something to do with the FBW system, as explained by another person to me herein. I think they expect the pilot to actually let the computer fly the plane after he/she pilot inputs all the various settings into the FMC. Where is the fun in that. You can fly it, but any radical change in altitude/heading can result in crash, as I think even when not enabled, computer try’s to fly the plane anyway.

No problems here, but the I’m using the trim wheel on the Logitech multi panel.

Do you have any videos showing this issue? I flew over 100 miles with just my feet in a Savage Cub, and it had no issues with trim. I think I gained around 300ft over that 100nm.