Marketplace Airport Map Is Blank and Not Showing Anything

Not seeing anything on the map in the marketplace, regardless what part of the world I’m in or filter settings.

Same. Interestingly, if I turn on DX12 in graphics settings, I can see the airports on the marketplace map. Weird.

Same issue here running DX11

Same issue with me. Running DX11. Version

Same with me. Marketplace Map shows nothing no matter what filter I use. DX 11.

PC VERSION USING OS WINDOWS 11. Liquid cooled NVIDIA 3080 and Liquid cooled 3950 processor and a bunch of other stuff. System top notch. Network up and down speeds very good considered above normal.

Same here no airports are displayed.

Plus when using the flight planning world map ((—-the new airport update which provides the “sales offer”)) freezes the simulator soon after you select to view the offer. Unfortunately I have close the sim via Task Manager by using End Process. States the sim is not responding. I let it sit for 5 minutes and still not responding. I am forced to end the process. I tried three times got the same result after selecting an offer. The Offer appears after I click it but the sim freezes. Strange. I have to restart the sim in Safe Mode. After it fully opens in Safe Mode I Exit the sim

It opens normally

I go to the flight planning World Map

Find an airport with an sales offer

Click on the offer

The offer summary pops up

The sim freezes.

Note I also replied to the problem where the airport world map doesn’t display the airports like others mentioned above this post. Like the others the airports don’t display. I have DX11 selected in Graphics settings.

In the new layout of Marketplace, when selecting Airports, you get to see a worldmap. However, this worldmap does not show airports. Not even, when you type a name in the searchbalk. So, what is the use of this worldmap?

it would be nice if this worked, but mine doesn’t either!

Some are saying they are having no problems with this while others are. Hmmm, Sounds like it is choking on something. I tried switching to DX12, removing everything from my Community folder, and a few other things. All to no avail. It did work the first time I updated the sim and then ran it, but “borked” ever since. It’s not a deal-breaker for me but it would be nice if it worked as designed.


Please tag your post with #pc and/or #xbox.

Are you on Xbox, Steam or Microsoft Store version?
MS Store

Are you using Developer Mode or made changes in it?

Brief description of the issue:
I downloaded sim update 8 and immediately went to check out the new globe update in the store – list view works fine and shows me all the airports for sale, but the cool world view just shows a blank globe. I filed this feedback in windows feedback hub as well.
Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

Apologies if I haven’t quite got the right terminology here but under the latest update you should be able to see which airfields are available in a map in the MarketPlace.

Instead all I see is a blank map.

Has anyone found a cure, please?



Same problem here. Blank map in the Marketplace.
Tried everything, disabled Nvidia Experience Experimental Features an Overlays with no effect…

Edit: returned on Marketplace map after some fligthts with the Nvidia Experience Features disabled, and now the airports appear!! Will try to reproduce this.

Mine’s also blank

Had to restart MSFS in Safe mode and the map worked correctly. Next time I started in normal mode and just the map appeared. Not sure if this will help if the engineers are reading these comments.

Same issue for me…

The same issue at me after the Sim Update 8.
No Idea to solve this. Must be a Asobo caused bug?

1 Like

The same for me (PC version). The marketplace map is empty (shows the earth but no scenery or airport marks) from the first time of use, no matter if I use a filter or no.

Same here. Nothing in my community folder. It did work one time but nothing since then and unable to reproduce success

same for me, steam edition.

if I start Simulator in safe mode, the marketplace airport map show the airport and all it’s ok… in normal mode the issue it’s here again.
there’s something outside of community folder that interfere with this map. But it’s very difficult to find it. Airport? Airplane? there is more in the principal folder installed from marketplace… sorry my bad English.