Marketplace Airport Map Is Blank and Not Showing Anything

Please only post bugs that are new in this build, and tag your post with #pc and/or #xbox.

Are you on Xbox, Steam or Microsoft Store version?

Are you using Developer Mode or made changes in it?
Developer Mode, but haven’t made any changes (only keep it open to bring the icing scalar to zero when picking up ice for no reason)

Brief description of the issue:
The World Map for the Marketplace worked great the first time. However, after reloading the sim, the map is empty…:

Provide Screenshot(s)/video(s) of the issue encountered:
See above

Detailed steps to reproduce the issue encountered:
Restart the sim?

PC specs and/or peripheral set up if relevant:
RTX 2070 Super
Ryzen 7 3700X

Same here - nothing shown on the Marketplace map.


The same happened to me. At first use I thought: Now this is useful! But when I opened the Marketplace map the next day, the content wasn’t showing up anymore.

1 Like

Not seeing anything in the marketplace map either on newest build

1 Like

Same here. I installed the beta today, and the map has been empty on every (so far 3) launches of the sim. Anyone has any tips on getting it going - was so looking forward to this map-view in the Marketplace :pleading_face:

The update to fixed it for me.

Removed everything from my Community folder, and now the map works. I guess I’ll now try to figure out which expansion is the culprit…

Still mystified. Marketplace Map stopped working again, even with empty Community folder.

No such luck here. Running 1.2311.0 and problem persists

Marketplace airport map seem to be bugged, it doesn’t show anything. Can someone else confirm?

1 Like

Same for me.

Anyone else?

Nothing here. Blank.

Same for me, nothing to see on the very nice worldmap.

Ok, thanks. Guess we need to report this bug so they can fix it.

1 Like

This is one of the type of things that’s so disheartening. How do THEY not know that there’s nothin but nuthin there?


Probably because almost no one uses that map, so they didn’t get any report about this before releasing SU8.

I have this problem also, but if I turn on DX12 for whatever reason, it works. Lol

No problem for me here. Just to report, that there are circumstances for it working correctly.
What it should Do for most of the users hopefully.

And of course I’ll say “So they crafted a new feature and NOBODY even peeked once to see if visually, the code was producing what they thought it would based on their best coding guess?” You know what I’m saying? It’s not really obscure when it’s your new feature that doesn’t work.

Sorry… the “update” literally destroyed Mugz beautiful TBM mod. Like a bomb blew it to pieces. He’ll fix it fast enough but it’s always something major like this airport thing. It’s like every “update” I can’t get my expectations low enough.