Marketplace Airport Map Is Blank and Not Showing Anything

Nice finding!!

Do you know if AIG addon can work with that folder installed elsewhere?

I use MSFS Addon Linker to create the symbolic link to the AIG folder which is stored elsewhere. So for me having it installed in a different location to the community folder isn’t sufficient.

Not fixed in SU9 Beta, despite mentioned as fixed

I’ve had this issue since the feature was launched. I’ve now installed SU9 Beta, since the changelog mentions this issue specifically, and lists it as solved.

Unfortunately, it’s not. I continue to not see any airports on the map.

Removing all items from the Community folder, then loading MSFS fixed the store issue. Then closing MSFS and restoring the Community folder retained a properly working store. I had a couple crashes as well previous to all of this, so possibly seems like MSFS wants to see at least one empty Community foder startup especially if you have had crashes at some point, or if you have purchased anything recently, clean out the folder and do at least one clearn startup?

I started using the Modern UI 2.0 recently and the map now show airports in the Marketplace. Unfortunately, clicking on them does nothing. They don’t open or allow purchasing.

Issue still not fixed in SU9 :roll_eyes:

2 Likes

Emptied Community folder - did the update. They said it would be fixed. Nothing on map in marketplace. Emptied the community folder again and restarted the game and nothing. Why do I even try. Lol.

1 Like

MODERATOR EDIT:
Ref: https://forums.flightsimulator.com/t/marketplace-airport-map-is-blank-and-not-showing-anything/497289

Is it fixed as stated?
[ ] Yes
[X] No
[ ] Partial

If no or partial, please give details below on your findings:
This bug happens to some users, including me. In the latest Beta changelog, it’s listed as solved. However, when I use the latest beta build the bug is there and unchanged for me: The airport map in Marketplace is empty (showing just the globe, with no airports). This has been the case since the feature was launched in SU8, and has never worked for me, including in this latest beta-build. If the devs think the issue it solved, I can at least say that it’s not the case for me.

Launch sim, go to marketplace, go to Airports. Observe that the globe shows without any airports.


:loudspeaker: For anyone who wants to contribute on this release note item, Click on the button below to use this template:

Is this fixed as stated?
[ ] Yes
[ ] No
[ ] Partial

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Hi @Hester40MT , thanks for keeping things organized :slight_smile:
However, I don’t think this is the appropriate bug. To be clear, I was referring to #09 in this update:

It says that this issue is fixed in SU9. However, when using the SU9 beta, I continue to experience the issue.

1 Like

If anyone else can confirm that this isn’t fixed, that would be great :+1:

Can confirm. Still blank

1 Like

I did some further testing yesterday, and can say for sure that the bug occurs/disappears depending on what Marketplace airports I have installed. Other than that, the behavior of this bug is very strange to me:

Even though I can find a specific airports that triggers the bug (bug not there before install, install the airport, restart the sim, bug is there), the odd thing is that just uninstalling that specific airport again doesn’t make the bug go away (which you would think it would, as it triggered the issue when installed), even after restarting the sim. Instead, I find I need to uninstall additional airports as well for the bug to go away. I can then reinstall these airports with no issue.

All in all, it’s impossible for me to install all the airports I have purchased through Marketplace without triggering this bug.

Is this fixed as stated?
[ ] Yes
[x] No
[ ] Partial

Provide extra information to complete the original description of the issue:

Same here, empty map in market place.

If relevant, provide additional screenshots/video:

Not a single marketplace item bought or installed other than the free WUs and G1000NXi.

@anon50268670 Is your community folder also empty? As I mentioned, for me, I can make this bug go away depending on which Marketplace airports I choose to install through the Content Manager. Very interesting that you experience this bug with NO marketplace add-ons…

I will try with empty community folder next.

This worked for a few times after the hotfix, but now it’s empty again. At least the map is back, earlier I only had a black background with stars - and a CTD to get out of Marketplace.

This was not fixed during todays updates. Could’ve sworn I had read it would be

For me this issue seems to be fixed since yesterdays update.
My Advice: Delete the rolling cache, perform all pending updates in your profile and restart the sim.
I hope that marketplace world map problem does not reoccur.

Not fixed for me after SU9.

2 Likes

The marketplace map is working for me now since SU9. I just wish it showed my freeware community add on airports too, but I’m all set for now.