Massive Delay / not detecting movement sometimes w/ Thrustmaster T.Flight Hotas X Throttle / Joystick

Good Evening Everyone,

Recently I’ve come back off my little break from MSFS2020 when Sim Update 5 came out. I’ve constantly been running into an issue with my Throttle / Rudders where sometimes I try and move my throttle up and down or rudders left to right and the Sim either doesn’t detect the movement at all or it will move a few seconds later. Sometimes I even have to move my throttle multiple times for it to go into the right detent and my rudders will just get stuck in the direction I’m turning. Through my time of playing this sim I’ve never once encountered this issue till recently.

Running latest update put out the other day.

Specs

CPU I7-9700K @ 3.6 Ghz
GPU GTX 1070 8 GB vram
PSU 750w
Ram 32 GBs 3200 MHz
1 TB SSD
2 TB HDD
500 GB M.2 NVMe

I’d try unplugging the controllers, rebooting without them, and “hot plugging” them back in once you’ve rebooted.

Just guessing here, but I do know that some USB drivers can be finicky.

EDIT: One more thing to try - get into the Control Options menu and cycle through the choices. I’ve had to do that a time or two. It cleared things up for me.

Yeah, I’ve tried unplugging and plugging back in my system but that didn’t work. I’ll try the other method you mentioned and hopefully that works. Thank you for the help!

1 Like

USB going to sleep / powering down ??

I’ve shut down my PC and allowed the joystick/throttle to shut down with it and then I unplugged it and started my system without it and booted all the way up and then power down again and plugged back in my joystick/throttle.

After going through and remapping all my buttons and just deleting prior profiles that seemed to fix my issue for the most part.

1 Like

Having similar issue with thrustmaster systems. Seems to fit description exactly.
“Remapping all my buttons and deleting prior profiles” doesn’t sound like a logical solution… Especially considering how long it took to setup everything to begin with.

Definitely appears to be a performance issue of MSFS to me.

This seems to be same issue as reported before at Flight controls sticking or not responding momentarily requiring 2-3 seconds of pushing pedals and joystick in all directions

I’m experiencing the same delayed stick problem on my Store version of MSFS;the Steam version does not experience this problem with stick delay.
Chas

With the recent SU10, my Thrustmaster HOTAS X discontinued to let my “throttle” & “rudder” axis work! I read your feedback and advice to “re-map” & also tried unpluging it in the same USB (it has always worked in), then plugging it back in (Plug-n-Play), but it still didn’t work.

I have the same problem but with TWCS Throttle and Rudder Pedals. I noticed it happens on the ground mostly when i taxi with the rudder pedals and they get stuck in one position can happen with the throttle too. I have tried multiple things like removing all other controls from throttle rudder and brakes including keyboard. Removing the power saving from usb in power profile and on all usb hid devices i found that it is on has no effect. Reassigning controls, unplugging the usb have no effect.
What makes me think this is a bug is the fact that this does not happen on Xplane11 and also they always work in the sensitivity window in MSFS and in the game controller calibration window in windows.
The controls get stuck only inside the plane in MSFS…

Same sort of thing for me as well. Since Update 10 my Thrustmaster joystick twist no nonger works correctly with the rudder. It jumps from full left rudder to right, then bounces back to full left. I thought my joystick was broken as it happened with all aircraft. Tried in a different sim & it works fine. Removed software, re-calibrated but it still persists.

I can confirm that if i don’t use mouse to look around during taxi and hand flying the problem does not occur. It is still very annoying since i can’t zoom with the joystick view hat.
And what is still more annoying is that Microsoft doesn’t fix this for such a long period.