Microsoft Flight Simulator - Clean Install - Only two planes in hangar, almost no handcrafted airports?

Well, this is awkward.

I’ve had MSFS since launch and I recently bought a bigger SSD. So, I moved the sim over to the new SSD using Windows’ move app feature, since this is the Microsoft Store edition of the title.

After moving it, I loaded it up to verify everything was in order and that was the case. However, after restarting my computer later on in the day, I launched the sim once again to find that it somehow now registered the base data as being uninstalled; as if this was the first time it was being ran. I pointed the installer to the main folder, which already had 100GB+ of data, but it still went ahead and redownloaded everything. After that was done, it loaded once again, and to my confusion, only two planes were in the hangar: the TBM and Cessna 172.

I checked the data folder and every plane that’s included in the base game and Premium Deluxe edition is present, but none are showing up in the sim. Also, there are almost no handcrafted airports showing on the World Map.

I decided to just start over: uninstall, delete the main folder, restart the computer and try again. I did that and left the sim downloading once more overnight. I just came back and same thing: only two aircraft (and even in the main folder there’s only two) and almost no handcrafted airports.

What’s the matter? I had zero problems when I installed the sim the very first time. I originally even had it on a hard drive and moved it to my main SSD after the first day with no issues. So, I don’t know what’s the matter now.

Once installed, go into your ingame profile, go to content manager and click all the boxes, and let them download.

Content Manager - Install them all.

It doesn’t automatically do it as it did on launch. This happened to me yesterday.

1 Like

Any maybe look at known issues. It would fix many peoples problems here a lot quicker.


Please search/read the forum before creating a new thread. Thx

Thanks a lot!

Unfortunately, my content manager only has two aircraft, the TBM and the C152. There is no other content to select. Anyone experience this and any solutions?

You’re not seeing the extra 14GB download in the Content Manager after install?

I have the same problem. Please advise if you find a solution.
Raleigh, NC

1 Like

Check to see if Online Functionality is turned off or that you have reached the Data limit cap you have set up.

To turn Online Functionality back on, go to Options > General > Data > Turn Online Functionality on > Apply & Save . If Online Functionality appears on already, turn it off and click Apply & Save then turn it back on and click Apply & Save to reset it.

You can increase the data limit or remove it entirely from the same screen.

This worked for me.

It worked for me also…thanks for the tip