Misselonghi - Rijeka Santorini Bush Flight

Flying the above Bush Flight and I get to Misselonghi (LGMS) which is supposed to have a concrete runway but it’s just a square field. Land on the field and mission won’t end. Using Little Nav map make sure I’m where the runway is supposed to be but just grass field and mission won’t end. Drive all around it trying to find a hidden sweet spot it needs and mission won’t end. Re-fly same thing. I can’t move on…HELP

Hi, have you tried flying there from the World Map? Curious to know if there’s a runway there when not in a bush trip.

I did and that airport did not even show up on the map or a search. The map shows the buildings, the service road but then farm land where the landstrip should be. Not even the open field as in the Bush trip. Weird.

Indeed. I have noticed this airfield that exists in the Bush Trip but doesn’t actually exist as a selectable airfield in the actual world map.

It has been a while since I flew those bush trips but I opened a ticket about the odd air strip I think. It seems nothing has been done about it.

Oddly I got mine to trigger on first attempt, did not need to fly the leg again, I may have taken off and tried a couple of times from different directions. Try that.

Same here, now is even worse since last WU6 update, Little Nav map does not shows this airport.

But now the airport seems not to exixst in MSFS.

As far as I know it’s never existed in MSFS2020 outside of the Bush Trip itself.
I did the Balkans bush trip quite a while ago. It didn’t exist then.

But Little Nav MAP recognized it when importing MSFS scenery library prior to WU6.
Now LGMS Mesolongi Airport has dissapeared in Little Nav Map.
In fact I think previous library had over 39000 and now about 38112. I think this could be a reason.
I am also stuck in this leg. :frowning_face:

HELP! :slightly_smiling_face:

I think the airport doesn’t exist in the game anymore so I doubt it will recognize it as a landing site, the bush trip is broken till that is fixed I guess

I have just been having same issue on Xbox. Flew legs 1-11 pre WU6 with no issues. Flew leg 12 today and landed at the grass strip by the 3 buildings but the end of leg did not trigger. Moved around still no luck. Reflew previous leg and that triggered on completion then tried leg 12 again and still no luck. As mentioned the runway is wrong as it mentions a concrete strip. Google earth shows a runway at this location but airport reference does not show up in sky vector. Really frustrating. Any ideas. I Enjoy the Bush trips but they just seem to let you down at times. Cheers.

1 Like

ARRRRGGGGGGHHHHH!!!

Hope it will be able to be picked back up if they fix.

The runway doesn’t appear on the Garmin screens either, like it does when you land anywhere else.
I really hope they fix it :frowning:

Same situation here. Can’t finish leg 12


You got more than me mine is just a grass field.

Same for me no runway just a wide grass strip.

I am also stuck there, so how to complete the leg??!

Also having this issue. Playing on Xbox so the workarounds suggested for PC won’t work. I note the airport has been included on the ‘missing’ list thread. Hoping for a fix soon, as it’s stopped me in my tracks on this bush trip.

I’m having the same problem. I found the airstrip next to the swamp and the geography from the photo in the navlog matches the spot I landed. I’ve scooted my way up and down the air strip stopping every couple feet, including the little road that leads to the parking area and the three little buildings. Hoping Microsoft patches this because I really enjoy these bush flights. I did the Utah trip first and encountered one airstrip that requires parking in a particular area instead of anywhere on the runway. I was hoping this was the same type of issue but I guess not.

Haven’t found a workaround for the PC bush trip. Since this airport is part of one of the bush trips I would hope they prioritize it on the list. I too like the Bush trips and the poi’s and challenging landings they can present.

Same here. On Xbox. Frustrating.