Missing main menu page

Please tag your post with #pc and/or #xbox.
Are you on Steam or Microsoft Store version?
Microsoft Store version
Are you using Developer Mode or made changes in it?
Brief description of the issue:
I am completelly missing the main menu page with flight planning, marketplace and everything else. This is without any mods in community folder. The only way to get to the flight is through logbook. Also, the world map is not spinning once in that page.
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Once the game is loaded there is no main menu items. This menu is also missing after the flight.
PC specs and/or peripheral set up of relevant:
Ryzen 7 3700, 32 GB RAM, GTX 970 with newest nvidia driver
Build Version # when you first started experiencing this issue:
Newest build

Try this…

Or disable third-party addon’s and once you have discovered the culprit by an elimination process, post your findings on the thread below to help other people. One known third-party app is known to cause your problem, there may be others too!


1 Like

Thanks for the suggestion, but the problem appeared with the sim in vanilla state. Empty community folder and no addons or 3rd party marketplace items.

Also, I didn’t mention that during the update I had 2 or 3 times where the sim stopped the download process, so I had to restart. Is there a way to verify the file integrity of the sim?

1 Like

That’s such a weird bug.

If you’re using the Steam version don’t verify integrity of game cache as it’ll delete everything.

Well, I managed to fix the issue. I deleted folders fs-base and fs-base-ui-pages from the OneStore folder. That forced the app to re-download them and once it finished and started the game, main menu was fine.

1 Like

I will try it out. Thx.

Have the same problem with the missing main menu. I have tried the solution mentioned here, but the problem returns. Also tried with empty community folder, no difference.

Moved to Tech Talk which is more appropriate whilst others help you troubleshoot :+1:

Any body have a fix for this?
Having it happen to me