Mouse and Joystick Issues SU7

Please tag your post with #pc and/or #xbox.
Are you on Steam or Microsoft Store version?
Are you using Developer Mode or made changes in it?
Brief description of the issue:
During flight, mouse and Joystick become unusable. Flying in VR mode. It’s possible that mouse is moving to other monitor, not positive. Have to fight to get mouse to reappear by randomly left, right, and center clicking, and then joystick becomes usable again.
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

PC specs and/or peripheral set up of relevant:

Build Version # when you first started experiencing this issue:

Yep…I get a similar issue. Mouse disappears and the throttle is unresponsive. This is in VR.

I have MSFS downloaded from Microsoft store. After SU7 my Joystick G940 Trottle bahave like crazy. Despite the fact that when calibrating everything is right, when a take off the throttle lever go forward and backward by himself and don’t reach the maximum power with le lever all on the max. Instead, as said, the throttle lever goes by himself forth and back. Before SU7 everything was fine. Very disappointing , It is an old Joystick but with other games however run perfectly, not a single problems before MSFS.

Specs : 3 years old PC with I7 processor 4,3 , all Asus Rog Strix, 750w, water cooled, GeForce 1080, OS run on a 500 gb SSD and MSFS content and community on a new 1Tb high speed samsung SSD.
I don’t use devloper mode and there are no add ons on the community folder.

Same issue.
I can’t play anymore, not even with a Cessna.

I assume I have to reconfigure the whole game again, joysticks doesn’t work anymore, thrust are misconfigured, VR menues don’t work, etc etc…
I believe Asobo needs to leave this game as it is, leave people play the Flight Simulator and start working on a NEW SIMULATOR if they want to add more features.

It’s really frustrating not being able to play it because of the constant changes, issues, bugs, configuration changes, VR issues and endless problems.
Are the graphics awesome? YESS, they are, but it’s frustrating not being able to play after each update.

Please STOP updating this game. That is my opinion.


They have screwed this game up.

Now in order to slew the map, you have to put the mouse in the “Default” profile setting, but that reverses the camera slewing for me. But if you put it in the “Mouse” profile setting, vice “Default” you can’t slew the map when everything worked before.

I was gonna fly the snot out of this sim with 9 days off, now it isn’t even flyable without what seems to be completely remapping all controllers. And I’m not doing that because MS screwed it all up.

Also, where did that stupid HUD come from in external view? I disabled that last year as it looked like garbage, but now it’s back–Sim setting is at “True to Life”–which is where I thought it was last time and that removed the HUD.

They have destroyed what could have been a great sim. Every other update it just gets worse it seems. Really thinking about uninstalling it.

Why you do this MS/Asobo??? You ruin perfectly good sim!!! Also, people are too sensitive around here. I understand 4 letter words, but can’t use all caps? Really? You just want it all soft and fluffy with rounded edges, huh? That’s fine, but you probably should concentrate fixing a jacked up product rather than feelings in regards to all caps. You suck.

Me, too! I have experienced problems with my Logitech Extreme 3D Pro ever since this last release, Controls always seem fine at the beginning of the flight, but upon landing three different aircraft pull me off the runway to the right, and I can’t redirect it. Tried this with both manual flight and autopilot- all I can do it stop the aircraft wherever it is and end the flight without taxiing further.

I was having these issues as well. Throttle works at first but on the take-off roll and onwards it becomes unusable. I have a Logitech Yoke and Joystick, both showing the same behaviour. I solved it by switching off as much co-pilot assistance features as possible - which I don’t recall switching on in the first place.

This is another bug of SU7, that all assistence systems are turned on every time.

Whumms, you are right; the weirdest thing I found was that the Autopilot and the Co-pilot AI were fighting each other for throttle control! And the AI co-pilot notified me that it was taking over a landing. Turning off all AI assists except COMMs cleared the symptoms for me.