Mouse pointer jumping to the top left corner of the screen (after SU5)

I assigned the arrows of the keyboard to move around in the cockpit (im sure like many others)…it seems that after the update everytime i press the UP key the mouse pointer jumps to the top left corner of the screen and i have to bring it back to where i want it…very very annoying…

I recorded a short video so you can understand what i mean…https://www.youtube.com/watch?v=fARUy_1HXR8

Anyone else experiencing this ???

I have the same phenomenon!

See also: Mouse pointer teleporting

2 Likes

Yup, plenty of reports on the Bugs and Issues sub-forums as well.

Known by a lot of people (including myself) now. Hope they do something about it soon :confused:

Same when using the controller.
D-pad down, stick down move the cursor to the top left.
Any other controller buttons overrule the mouse completely anyway.

Overall it’s far worse now compared to before to the point where I am not playing.

I already oppened this issue in Zendesk and open a forum topic to talk about it 3 days ago. Use the search function in the forum in order to maximize the votes related to one bug in one topic instead of dispersing them in various please.

Voted both and replied in both threads since I’m not sure which one is the main one. Shrug

1 Like

Same problem for me when I push button 2 of my T-16000M

Same problem here. Using Thrustmaster airbus. Everytim i want to trim with the hat switch, the mouse is teleporting to the upper left. How could this go unnoticed???

This is a really annoying bug. I hope it will not be ignored. Please consider this in your upcoming hotfixes.

Kind regards.

1 Like

I have the same issue when using my coolie hat (assigned to COCKPIT LOOK commands).

It works when I use the mouse to rotate the view by holding the right mouse button (assigned to TOGGLE COCKPIT VIEW FREELOCK (HOLD)). The axis of the mouse are assigned to COCKPIT LOOK UP, RIGHT, LEFT; DOWN (LOCKABLE) respectively.

I have the same issue :

I use my joystick’s hat switch to look around the cockpit while using the mouse to interact with the instruments.
Every time I move the camera, the mouse pointer teleports to the top left corner of the screen.
Sometimes, the mouse pointer stays hidden, and not reappear until I move the camera again (but it spawns in the top left corner)
Sometimes, the mouse pointer reappears automatically when i move the mouse.

Hello, I have the same bug