Mouse Stops Interacting with the Virtual Cockpit

There is an ongoing issue that may affect you when using your mouse during flight. When the issue occurs you are unable to interact with buttons, switches, dials and levers in the cockpit or zoom using your scroll wheel.

Restarting your flight will fix the issue.

Possible Workarounds:
These workarounds may solve your issue, but they may not. If you find any other workarounds please reply to @Nyx1819 below so I can update this post.

  • Click the ‘Reset Camera’ button in the camera menu
  • Disable the co-pilot assists
  • Undock and then close the various menu UIs (ATC, Camera, VFR Map, etc)
  • Move any undocked windows that are on separate monitors back to your simulation monitor
  • Double click on one of the menu windows (such as ATC) - this seems to force the mouse to function again

If you have this error please file a ticket on Zendesk, along with a description of what you were doing immediately before the bug occurred. This will help the developers resolve this issue.

15 Likes

On 2 flights today, after some time, I cannot use the mouse to click anything in the cockpit. Everything else works, but I just cant interact with anything in the cockpit. Seems to happen after 20 mins or so of flying.
Anyone else getting the same issue?

11 Likes

Yes, have had this happen to me.

1 Like

I had this before and what helped was backing out of the Nearest Airports dialogue of the ATC menu all the way to the top level of the menu. After doing so the clickspots came back.

1 Like

I have this problem and I get it on nearly every time I play now. For example, loaded in the Cessna Skyhawk. Had a look outside, used the drone camera (Xbox Controller) but once back in the cockpit not able to zoom in/out with mouse or click on any buttons or switches.

Have the Saitek X56 plugged in for normal flight controls - Just use the Xbox controller for drone camera movement.

Same problem here using Win 10 and mouse. After some flying I will loose all possibility to zoom in on virtual panels and click on any of the dials etc.
Have not been able to solve it with any of the suggestions here.

Had this issue a couple of times. To solve this issue, just drag some not undocked menu UIs (ATC etc.) on the same screen. Works for me every time. If it’s not working the first time, try moving a different menu UI.

13 Likes

Please remember to file bug reports on this issue!

Happened to me as well…

Hi, im flying ifr with the diamond da40ng and all of a sudden i cant click anything in the cockpit. The atc have requested me to decend but i cant do anything about it. Any answes to this?

1 Like

Just had the same in the 787, so think this is a core FS bug, and not related to a specific airplane.

1 Like

I had the same issue. I guess this happened shortly after you changed the camera views? I had to open the camera toolbox, click on „Cockpit“ and „Reset position“, or play with the views somehow. Then it worked again. May be random, i don‘t know.

I had the same issue, was flying Cub Crafter. Seems out of no where I coudnt click on anything. Also didnt get it to work by resetting views.

Yep happened just about when i changed views, got it fixed now somehow but now there is something else that is acting wonky. Is it just me or do you guys find it very annoying that some buttons are mapped to do very different things but all on the same button press?

now something else appeared, whenever i right click to get free look it zooms in, and when i right click again it zooms out. Tried to change the button mapping in the settings but it wouldnt let me…

Same happened to me over Phoenix in the Savage Cub. I thought I may have activated the center click (wheel) on my mouse. I’ll be watching more closely next time to try and trace

1 Like

Same thing happened to me. Restarting the flight in a different aircraft did not fix the issue.

Seems as though after clicking on some of the menus, ATC, NavLog, VFR Map it will suddenly take away my ability to click on the instruments in the cabin. Anyone having this issue? How do I fix?

1 Like

Yeah also had this issue had to restart the sim for it to work again.

Just had this issue too, I was flying on Autopilot and when I was getting close to where I was going nothing worked for me either