Movement of on screen yoke does not match real controller

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting. no

Are you using Developer Mode or made changes in it? no

Feedback/Bug Description: The movement of the in cockpit yoke/controller on screen does not match the movement of a physical controller. This is especially evident with yokes, for example the Fulcrum One and Honeycomb yokes. If the controller axes are set up completely linear then any movement of the physical yoke should match the in cockpit one as per other simulators.

You can get the yoke movement to match up by increasing the ±response curves by 50 but this means it is no longer linear. The current best fix is to leave it linear and ignore the incorrect movement or hide the in cockpit yoke. This is not good for VR users though as it breaks immersion.

Provide Screenshot(s)/video(s) of the issue encountered: n/a

Detail steps to reproduce the issue encountered: Make sure controller response curves are linear and move yoke 90 degrees each way and watch the on screen yoke not move in a linear manner.

PC specs for those who want to assist (if not entered in your profile) i7600k 1080ti 32GB ram Windows 10

Build Version # when you first started experiencing this issue: All builds from the start

Are you on the Steam or Microsoft Store version? MS store

Did you submit this to Zendesk? If so, what is your ticket #? #110485

Others noticed something like this, but it seems a bit scattered in the forum:

Yes I have experienced too and found a fix online. This has to do with your Windows Joystick/hardware configuration settings. Reset everything there, recalibrate and it should work like a charm again.

Moderator Edit: Merged from another topic:

When I bought my Honeycomb yoke I set the sensitivity curves to linear but when I turn the yoke 90 degrees to one direction the yoke/stick in the sim first turns a little bit and in the end makes a massive jump to max input. I checked the ailerons and they seem to work in a linear fashion so nothing wrong there.

Does anybody know why it’s like this? I have to hide the yoke because it bothers me too much.

Moderator Edit: Merged from another topic:

That’s a sloppy yoke/stick animation on all aircraft.
Luckily it doesn’t reflect the actual joystick and/or flight control deflections.

If you look at your aircraft from the external view, you will notice that the flight controls movement matches your joystick/yoke movement.

That animation bug unfortunately exists since day one.

1 Like

Yes I agree, I removed all curves and now the ailerons and elevator move perfectly smoothly in line with the full range of motion on the Fulcrum yoke. However the cockpit animation is so far from being linear I too have to remove the yoke from view. I don’t get it, all others sims seem to get this right.

Hi guys !

I experience an issue where my curve for ailerons is flat :

The sim reads the inputs correctly as you can see here :

But in the cockpit, it looks like that (which is not flat at all) :

Here I mapped the RPM and the roll to the same axis :

And as far as I can remember, i always had this issue, even a year ago with another stick.

Anyone have an ide about how to fix this ?

Thank you !

Is it the same in all aircraft?
The Arrow III in particular I fly with linear controls, whereas I use pretty heavy adjustment on most stock planes, so it seems to work rather different. I would not at all be surprised if the Arrow itself adds nonlinearity.

Yes same with all aircrafts, the first two vids are in the 172

Some of the above posts were merged into the topic.

See the above posts. It’s a yoke animation problem only and it doesn’t affect the actual flight controls movement.

Noted. Thank you for your time and sorry for useless post. Couldn’t find the original one by searching the internet.

1 Like

No need to be sorry!
It was only easy to find after the threads have been merged :wink:

Also, it is not a useless post, this has been bugging me since launch so the more complaints the better! I raised it on zendesk too.

1 Like

I believe this affects users of yokes with 90 degrees of roll as well.

Yes, 90deg jokes also impacted.

Very irritating…

This has nothing to do with the hardware.
100% deflection with the virtual stick/yoke matches 100% joystick deflection in all cases.
It’s simply the weird non-linear stick/yoke animation which creates this problem.


What I meant was the animation still accelerates when hardware with the same degree of movement is used. My Yoko only has around 45 degrees, so it would make sense there, but even then the acceleration is not spread across the entire range, only at the extremity of movement.

On a yoke with 90 degrees of roll there should be no acceleration whatsoever but its exactly the same from what I’ve read.

1 Like

I hate to bump such an old topic, but it’s been brought up in the Milviz 310 thread and it’s something I’ve seen in other aircraft recently as well such as the Globe Swift by AH. It’s very annoying and I’m wondering if it’s been determined that this is a problem that Asobo needs to solve, or if there’s a way for developers to adjust the animation somehow? It’s distracting enough for me that I’ve taken to moving my view up enough to hide the yoke or remove the yoke (when possible by the addon) by clicking it.

To be clear since this thread is old and has a few different types of complaints, the issue I see is that while my hardware is set up correctly with no curve, and I can confirm smooth movement across the axis in the calibration settings (in Windows) and axis settings (in MSFS), the yoke/stick in the VC will very slowly move, then suddenly accelerate to its full deflection in a way that does not match the hardware. It’s also true and very important to note that the physical control surfaces all deflect correctly. This means it’s purely an animation problem with the virtual controls.


Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons?


Brief description of the issue:

Even with sensitivity at the default when turning the yoke controller (I use Honeycomb Alpha) the animation of the yoke in the virtual cockpit doesn’t move enough to begin with but moves way too much at the extremities to make up for it.

It seems like this happens for all aircraft but I haven’t tested every single one. Screenshots are from the 172.

It seems like when my yoke it turned 10% in game it is only moved by 5%, when I move it 30% it is only 15% in game, at 50% in game it is only 30%, etc, but for the last ~10% the animation rapidly catches up so at 100% it is also at 100% in game.

Not that this only affects how the yoke looks in the cockpit. Looking at the control surfaces themselves, the movement is linear as it should be, and feeling the effect of the control while flying it also seems to be correct. The only issue is the amount of rotation shown on the yoke in the virtual cockpit.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Simply load into the game in the C172 and turn your yoke and look at the difference between how much you have turned the controller vs how much it is turned in the virtual cockpit in the sim.

PC specs and/or peripheral set up if relevant:


Build Version # when you first started experiencing this issue:

As far as I remember this has been an issue since the sim first released in 2020.

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video: