Moving FS to another PC

Whilst waiting for the download to complete I was wondering how I move FS to my new machine when it arrives in a few weeks time… or will i have to download everything again? Please tell me that will not be the case.

Thanks in advance

See the answer below :slight_smile:

I was able to zip up the content directory (the one you choose to download the 90GB files to) and copy it to another machine.

I started the game on the second machine, set the content install and let it start the download. Then I closed the game, deleted what it had downloaded, and extracted the files from the zip into the directory.

Once the files were restored everything was detected on startup, no download was needed.


Brilliant. Thank you both for replying. Now all I have to do is find the download folder… I just accepted the default and only remember it being ridiculously long and complicated. Oh the joys of reaching ancient years… it’s no fun getting old, but at least I made it to see this new sim (hopefully)

I did exactly as you said and its still trying to download the files? any help?

Did you do EXACTLY what Diverg31549 suggested? I haven’t tried it yet myself… just finished zipping everything

I didnt compress the files. I cant see how that would achieve anything different but I’ll go try…

I have no advice to give other than good luck you crazy swine.

Theres no way I want to even LOOK at my install directory after all that XD

I put the files into a zip because transferring one large file over the network is faster than thousands of small ones, and it is easier to back up.

Make sure you are starting the game on the second computer, configuring the content directory and *starting* the download process. Once it starts, you should see files and directories being created in the content directory. At that point you can close FS and move the files to that directory.

Does it matter that I am trying to install on a new hard drive on my 2nd computer?

I’ve compressed the files. Transferred to my new computer’s empty 256GB SSD. Started FS, pointed to the F:\ drive, created a new folder (because it needs a folder) and let it start the download. Then closed it out, unzipped the files into the same directory, and its still wanting to download the full 90GB

Did you download from Windows Store?

got it from steam

Does it matter that I am trying to install on a new hard drive on my 2nd computer?

It should not matter. It sounds like you may be extracting to the wrong location, possibly putting the files under the wrong directory.

If you look in the "\Official\Steam", or “\Official\OneStore” directory you should see a bunch of “asobo” folders, about 155 of them for premium deluxe, slightly less for other editions. Try these steps:

Content location:
* If using Steam the directory is X\Official\Steam
* If using MS store, the director is X\Offical\OneStore
(X being the disk and FS directory, ie D:\games\fs2020\Official\Steam)

- Make sure MSFS is *not* running.
- Take the ZIP file and copy it to a safe location where it won’t be deleted.
- Delete all directories under the content location for your store (above). There should be a bunch of “asobo-xxx” and “fs-xxx” directories (along with a few others). Make sure the ZIP file is not included.
- The content directory should now be empty.
- Take the ZIP file and extract the contents to the install location.
- In the content directory, verify that you see directories that start with “asobo-xxx” and others.
- Start MSFS

After the ZIP extraction if you see only one directory, then find all the asobo, etc directories and move them to the content install directory.

I just did this process to copy them to a second computer without error. Also, a 7-zip created archive with ultra compression brings the file size down to about 74GB, but takes about 1.5 hours to compress. Now I have an instant backup!

1 Like

Okay thank you. I have discovered that on my own. I was trying to copy the entire “Microsoft Flight Sim” folder, but as you have said, all it wants to see is Official\Steam and I just copied that directory and it works. Thank you

was reading this explanation and went to check that I don’t have any zipped files. I only have asobo-xxx and fs.I bought Premium Deluxo, downloaded this package and I didn’t download anything anymore because nothing else appeared for me to download. Did I do something wrong? If you know and want to explain I would appreciate it. I bought it at the Microsoft store.

You should not have a zip file in your content directory from the game itself, that is something you create. It is not really required in order to move the files to another computer, but there are tens of thousands of small files in the content directory. Copying lots of small files is sometimes slower, especially over a network.

Zipping up all of the files into one file makes the network transfer faster.

For my move I used 7-zip and created an archive of my “Steam” directory. Then I copied that zip file to the second machine and then extracted the files to the “Steam” directory.

The exact same thing can be accomplished by just copying all of the files manually.

Thank you very much for the information. I am more rested.

I’ve zipped everything including the Microsoft Flight Simulator folder. Haven’t tried it yet (new pc arrives next week) but can’t see it should make any difference.


So I have found the asobo and fs- files. 7zip is making an archive. Where is the “Install Location” referenced in your instructions?

Do I extract with admin permissions or ordinary user permissions. I have two users one with admin permissions and another lesser permissions.

The installer is not very clear. I’m thinking I should just start over again. My prefered location for MS2020 is a SSD I purchased for the program. However it already has three folders Program Files, WindowsApps, and WpSystem. Yet the absobo and fs files are under C:\user\admin\AppData\local\Packages\MSFSblah blah\localCache\Packages\Offical\Onestore

Totally confusing. Thanks MS and Absobo.

BTW My compressed absobo and fs file zip is 72,178,036,293 bytes , different than other users. Maybe I am compressing a different version?