MSFS Application Error - memory could not be read

So, tried it and just got an “memory could not be read” error anyways. So it might be helping with the memory leak, I don’t know, but it doesn’t prevent the memory read error.

How did you confirm/identify a ‘memory leak’?

of all the issues I’ve had with MSFS2020, ‘memory leaks’ isn’t one. It seems pretty Frugal with it’s RAM allocation and usage.

because this clickbait video, million times mention within the forum, have nothing to do with " memory could not be read". These error-message is also not a memory-leak… Users mentioned system-configuration issues ( sound ), RAM issues like XMP mode, or there is realy an issue with the game ( but then still not clarified why only some rare user get this ).

Don´t forget to subscribe, tick the little bell, and SMASH! the vote button.

1 Like

That video didn’t claim it would fix that memory read bug and I didn’t believe it would. I just wanted to make sure. I think pretty much all supposedly solutions people have posted here are voodoo and mean nothing since the error is very random and erratic and can disappear for a number of flights only to return 3 days later for 3 flights in a row.

I also wouldn’t say that a thread with almost 650 postings indicates that “only a few user get this”. It is very much a heavy problem a lot of users have. It is very much a problem of the sim, especially since people seem to have it in all kinds of circumstances like mid-flight, just starting the game, browsing the in-game shop etc. with all kinds of addons and hardware configs.

I not think that all are vodoo, in special the sound-device solution ( and I may be xmp too, as some users reported )… But yes, the final reason seems not found / determined. It can be random that the problem comes more on top with SU9, just because there are also lots of e.g windows updates in that time, but of course we not know it.

Ah… and, the votes is what count, not the amount of postings ( the conversation )…

1 Like

Sound yes
Xmp , no
Ram , maybe as it seems to be using a lot more ram looking in task manager
But who knows, it’s as you say the votes that count

Might be a long shot but in ain’t gonna fix itself right? Although I didn’t encounter this error myself I came upon this announcement from Microsoft regarding memory leaks and crashes. They offer a cumulative update (fix?) that addresses “memory leaks and crashes”.

  • I suggest you only try it if you know how to roll-back an update / patch like this one.

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Brief description of the issue:

2 flights in a row in different areas of the map, a CTD with error code 0x00007FF6D1980328 appeard

Provide Screenshot(s)/video(s) of the issue encountered:


Detailed steps to reproduce the issue encountered:

starting descend into airport:

  1. CTD: Descend into LFSB
  2. CTD: Descend into EDDP

PC specs and/or peripheral set up if relevant:

  • Intel i9 10900k, RTX 2080TI, 32GB RAM
  • Thrustmaster T1600 joystick
  • Logitech Saitek Rudder Paddels
  • Fenix A320 Aircraft
  • LFSB & EDDP Payware addons

Build Version # when you first started experiencing this issue:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Would report back if something happen in the meantime since the XMP change I wrote earlier. (see post 612) Nothing did happen and the issue did not return since I’ve adjusted XMP profile and deinstalling Aerosoft Simple Traffic. Although it did work for me, I don´t see why the fix does work for me as it currently doing. As it does not make sense and MSFS is the only program that acts up like it does.

Since changing it is now already the 3rd day without memory errors sessions. Probably gamed this friday as I was free and past weekend for something around 8hrs+ per session.

1 Like

it affects users with Windows10 and Windows 11 so that is probably not the problem
but anyway thanks for the hint

1 Like

It is happening on 22h2 also however I haven’t had this error for couple of days
Was flying the FBWA320 and memory was high but it was using 16gb of my 32gb
Interestingly I flew a short flight on the PMDG 737 , at times resource monitor went up to 98% of my ram , but then it slid back down thankfully to around 9gb then it would rise up again and just at the point I thought it’s going to CTD it fell back again
Landed fine and taxied to gate , then memory was at about 10gb
Never before have I had it ever go up this far and virtually max out 32gb so it’s obviously a msfs /Asobo issue

That’s good to hear
I too have had no crashes either but it’s using a massive amount of ram
I have 32gb 3600mhz xmp ram, don’t really want to go back to 2666mhz of ram

So to get no issues you have downgraded your ram and uninstalled AI traffic
Hmmmm, I don’t use that as I use AIG and have kept using it in my tests, but why should we have to uninstall stuff, downgrade hardware to get this sim to work, well as I said I’m not
But it’s getting ridiculous and shouldn’t be the case of doing this even as a workaround

Are you checking resource monitor at all, be interested to see how much ram you are consuming?

at first a test only would be fine, just to be sure whether this helps or not :slight_smile: … I think its not hard to disable in BIOS xmp mode and fly some days with it. The ( may me ) 5fps lost ( if any ) is for these short time period ok, or not ? Its only to narrow down possible reasons… if you run again into an issue, we know that xmp mode isnt the solution for you :slight_smile:

1 Like

Will try it out , like you said it’s easy to do and nothing to lose

1 Like

Okay, so now I had the error mid-flight, but the sim just kept running. So I dragged the error window off screen and just continued flying for another hour, landed, rolled to the gate, turned off the aircraft and only when I wanted to quit to the main menu did it finally freeze.

In my opinion, the lack of any of the previous updates causes this problem. it worked normally for me before reinstalling. Installing the sim on a fresh system causes no continuity of updates. I replaced the motherboard, but was able to use the sim normally. However, I preferred to reinstall which turned out to be a big mistake. Crash after crash for the past week. The error appears and sometimes it does not, but always ctd.

Ok so just flying the PMDG after disabling xmp
Now at 2666mhz, ram in use is about 7700mb
But standby is at 19gb and free ram 5.5gb

Using AIG too, no degradation of fps so looks like it doesn’t play well with xmp now, but my cached ram is high

Just reporting back ,will keep testing

Edit: 25% used physical memory

1 Like

It is not normal to have to do all this kind of voodoo to make this simulator work well. If it were a car, it would have already broken the bussiness. It annoys me. Because I also use other programs and I have never, ever had this egyptian scroll of problems.
DCS, IL2 Sturmovik, Metro, CoD. All in ultra settings and on a 55" 4K monitor.
I was excited about this simulator and bought many addons. But I already feel like I’m throwing money away. It demotivates. I can’t show it to anyone because it’s likely to look bad. I can’t stream for fear of embarrassment. Upset. Angry.


SOLUTION for me - update FSbase.cgl content from sim menu 58GB. Ctd’s are gone.