Msfs crashing half way through startup

I followed these steps and it seems to be stable now. That fact that the CTD at about 75% (progress bar) seems to be such a pervasive issue would warrant more attention from Asobo. It looks like WU13 is supposed to implement a crash file that may provide usable diagnostic info.

Provide extra information to complete the original description of the issue:

I encountered this problem today after running fine for many days. After a CTD during a flight, I was not able to restart, even in SAFE mode. I have never installed any 3rd party mods or anything not Microsoft/Asobo. The startup never got past the initial splash screen before crashing out.
The following had no effect:

  1. Disabled firewall/anti-virus
  2. Installed latest version of GPU driver.
  3. Went through all the steps of logging out / stopping Xbox, updating MSStore, rebooting etc.

The one thing that got me running was:

  1. Deleted the ROLLINGCACHE.CCC file of size 8GB. This immediately got me going. I noticed that MSFS recreated the file but I’m still able to run. I have disabled the Rolling Cache option for now, hopefully to prevent this from happening again.

If relevant, provide additional screenshots/video:

The 80000003 error is not specific to a graphics card unless the application log entry specifically points it. It is a generic breakpoint meaning the code encountered an exception and terminated. The Msfs crash log for this has generally pointed to a fiber exception or fault. This could be caused by corrupt or incorrect executable, a corrupt data file that the code doesn’t handle, faulty memory, a race condition amongst the threads/fibers, etc. I had to eliminate these one by one. Once I was sure my hardware and operating system were ok, that just left the Msfs app itself. After trying all the steps to return Msfs to “vanilla” state did not work, the option I had left was uninstall and reinstall Msfs so I had all new clean exes and data. This did the trick. Others have luck with other changes which may work somehow to eliminate an OS factor that could exacerbate the Msfs issue. Lots of fun!

Fully aware of that. I mentioned the GFX card error because that is what the sim does as well

Excellent. Thanks.

Hi Everyone, important update again:

After I did a fresh install of Win11 on a clean disk and installed MSFS from steam again, the game was working flawlessly again.

I have absolutely not installed any programs other than MSFS. I have not even opened a browser! Just boot into windows and fly!

Until this morning. Exact same crash to desktop starts happening again. Latest MSFS release. The only difference is when I flew some last night, and this morning when I booted again, Windows was in the process of installing some updates. As best as I can tell, it started happening after some kind of windows update. This makes sense also from my first install experience. Everything fine until after a couple of windows updates.

Fortunately I backed up the entire disk after installation and finding everything working. So I’ll just restore this copy again.

But boy, this is sure starting to get very annoying!!

Ok - now even my clean copy starts CTD’ing.

Incredible. I splurged so much money on this game, new rig, everything… but its unplayable.

Getting this issue, and I tried everything in this thread and still nothing is working for me. Any more ideas?

Haven’t been able to launch the sim all the way to the home screen for a few months, very frustrating. Re installed Windows, tried the latest and older drivers, launched with default settings, tried different combinations of system settings, nothing helps. All my other games work fine.
518 hours sunk into the sim and I am stopped dead in my tracks.

Update: I am now able to fly but only after launching the sim with “Enable Steam Cloud synchronization for applications that support it” unchecked in MSFS Steam settings. I then noticed that the sim launches (all the way!) with default values including DirectX 11. After a few flights I was able to slowly reconfigure all my settings back to the way they were including DirectX 12, now with MSFS game saves in the cloud checked as by default in Steam.

So far so good.

Yes it did. I had to factory reset my entire computer though. ■■■■■■

I had to do the same, what a shame MSFS is getting a bad name due to 3 companies getting involved in one product. Obviously no Testing or communication between the 3 companies otherwise simple testing would alleviate these issues. To download MSFS time and time after a new releases is not on due to download costs and time that it takes to get back up and running. All of us that have had to put up with this disastrous situation should be given free access to the New Version MSFS2024. I run a gaming PC lots of storage and 5G networking. I have now deleted my MSFS2020 version and will now look further afield for a better product.

That’s annoying. In first time I installed the game everything worked fine. In the second one, I had problems to complete the packages installation and then, now, on the startup. After loading 75%, close to open the main menu, it crashes. None of the solutions suggested on forums and videos worked for me, although I’m talking to the customer support.

I could move the game folder and ask Steam to check integrity. After this, move the folder back. I mean the big folder that stores all packages, not the one in steamapps – to avoid total deletion. ■■■■!

Are we talking all the time about only DX12 or DX11 or both, the crashes. Because I only get them under DX12.

Provide extra information to complete the original description of the issue:

My FS has started crashing on loading screen since yesterday after working without hitch since its launch. Once after many tries it launched and the content manager showed 0 content. Immediately after that it again crashed, I have restored to vanilla state step by step, checked integrity of files, and tried everything suggested without success.
If relevant, provide additional screenshots/video:


I found the solution to my problem. I had to delete files older than September 23, 2021 in the Official Folder. As soon as i did that and started the SIM, it started downloading the latest update and has been working fine since.

2 Likes

Hey just to ask is it normal if all of the folder’s are older than today date and will it change anything if I installe everything in my official folder.
Thanks

I’ve been pulling my hair out, over last few days everything was suddenly freezing. The system was fine but it would just not load. This has at least got it loaded again. Will see if I can get into a flight once it has finished doing all the updates again

Spoke too soon. Crashed half way through updating. I’m at a loss with this game. It’s just way too flakey. Now attempting a full reinstall in the hope it recovers

I have been getting CTDs and can never figure out why. I finally tried a simple method that might have been mentioned somewhere before. I went to the apps menu in windows, located msfs, and then clicked the RESET option. Then re-booted. It worked.