Msfs crashing half way through startup

Correct. It is specifically a Breakpoint error. I mentioned the GFX error for reference if they wanted to check the threads (if they were not already aware)

1 Like

Yeah, my gpu driver was always updated, and I hadn’t updated it during the re-install as it was already on the latest version, therefore I don’t think it was an issue with the GPU.

I did exactly the same steps you posted and I got stuck on the installation manager. It shows 127.57GB/127.57GB, 100% completed, but only 17/525 items done. Whenever I exit the sim and load it again it’ll repeat the same step.

Provide extra information to complete the original description of the issue:

It’s 04/16/23. I’m trying to run MSFS v1.31.22.0, windowed, in Safe Mode, on an Omen 17t laptop. In Content Manager I’ve uninstalled everything not labeled Asobo or Microsoft, and removed all 3rd party scenery packages. It always gets through the credits, thereafter it crashes at any time. One time it asked for a game disk, then froze. On one try I was able to access Options & Content Manager. Then when the Select Departure Airport screen came up, the window froze, became unresponsive, and after maybe 15 seconds closed.
I’ve been running MSFS on this same machine from March 2022 until 04/14/23, with no crash problems. There have been no SW updates since then.
Is this a recently new MSFS version? If so, when was it released?
Machine details: W11 home 64b v21H2, Intel i7-11800H CPU, 32GB RAM, Nvidia RTX 3070 GPU v30.0.14.7247 driver v531.61.

If relevant, provide additional screenshots/video:

none Everything looked normal until the freeze/crash.

I started getting msfs crashes on 04/16/23; no problems before then. Once I got to opening Options, then after some changes, when I got to selecting the departure airport it crashed. Now it crashes during the screen right after I hit Safe Mode, apparently loading something. Microsoft Windows tells me that all my drivers are current, the same microsoft as in MSFS. I just installed the latest Nvidia driver (released 04/12!). I deleted rollingcache.ccc. Still crashing.
Did a factory reset fix the problem for you?

1 Like

i have the same problem since yesterday- CTD, very frustrating …

Go through each of the following steps one at a time. Copy each line, one at a time , paste it into the Dos window (crtl + V) and press return (run using admin rights)

and it will then run. Wait until each runs and finishes before you move on to the next one.

When you are completely finished, Restart your computer and then try to see in MS2020 will start and run properly

Dism.exe /online /Cleanup-Image /checkhealth

Dism.exe /online /Cleanup-Image /scanhealth

Dism.exe /online /Cleanup-Image /Restorehealth

sfc /scannow

Dism.exe /Online /Cleanup-Image /AnalyzeComponentStore

Dism.exe /Online /Cleanup-Image /StartComponentCleanup

RESTART your computer as the last step. Then go for a test flight

Thanks for the suggestions
Before I saw this post, I had used System Restore to reset my machine to its state on 4/11, before I saw the first crash. Then I did the steps suggested. Unfortunately it crashed again in exactly yhe same place as before: 3/4 of the way through the load screen.

Create a msinfo file and all the way down at the bottom will be Windows Error Reporting - what is the faulting module for any Flightsimulator.exe crashes?

  1. Open a Run command box. To do so, press the Windows key and R key at the same time.
  • Alternatively, search “Run” in your Start menu’s search bar.
  1. In the Run window’s dialog box, type msinfo32 and click OK.

Depending upon the fault, we may be able to help you here quickly, but if it is more complex it would be best to submit a Zendesk request:

What is in your community folder?

Nothing. It’s empty.

In this thread, there seems to be an implicit assumption that the cause(s) of these crashes are in user systems. I asume that different user systems have different HW and/or SW setups: different apps etc… The obvious question is: what’s common to everyone experiencing crashes at exactly the same place during MSFS startup? There’s Windows of course, but also MSFS itself.

Did you run all the commands using admin rights? Then reboot PC?

I logged into my admin account only, went to Start > Terminal (Admin), got a window labeled Administrator: Windows Powershell, & ran the commands from C:/Users/Admin >. Then restarted the machine. Still no joy - MSFS crashed in the same place as before.

I ran msinfo32. I’ve attached a text version of the Windows Error Reporting file. The many errors for FlightSimulator are my attempts to run the program, on and since 04/16/23

Windows Error Reporting 041923.txt (560.0 KB)
. Forum does not allow me to send the original .inf file. Hopefully this will help you tell me what to do next. Thanks for your help.

The FlightSimulator.exe fault that you are receiving is generally caused by outdated add on mods or third party software (GSX Pro, FSRealistic, overclocking/process management software, GPU software/drivers, etc.) running alongside MSFS. Start by removing/uninstalling these and it may resolve the crashes. Even after some third party software is uninstalled, it can still leave remnant files that cause conflict with MSFS. This could also be caused by corruption within the MSFS application itself and a repair/reinstall may be needed.

Feel free to submit a support request if you need further assistance:

What is the full OS version build number?

Push comes to shove give the following a try…

Just want to chime in. Have the same problem!

MSFS crashes to desktop during the loading screen, almost always at ~75% of the way.

I got a clean disk, purchased Windows 11 just to run MSFS. Nothing else on the machine. It was working flawlessly when I installed everything early march.

Since early april, after the latest MSFS update, first signs of instability, with an occasional crash during flying.

Now, unable to even start the game. I did a complete reinstall, complete content re-download, removed all Steam Cloud files, went through clean MSFS installations a couple of times, fiddled countless times with the virtual memory page size (I’ve got a 12700F, 64GB RAM, RTX3090ti), but nothing helps.

CTD without any message. Crash report shows MSG=FibreError. Always error code 0x8000003

I really need help with this one. Opened a ZENDESK ticket.

Right now completely unusable, and I already wasted 8 hours and a full night downloading everything again getting it to work.

I had been having the same MSFS crashes during startup as other posters. I was doing a report for Zendesk, came across an article: “How to restore the sim to its vanilla state to get back in game” ( I followed the instructions as best I could (I am not that computer savvy), started MSFS, & it ran!!! Some of my custom settings were gone, but it’s nice to report some good news for a change. Others have tried the same thing, didn’t work for them. Go figure. The Zendesk folks do deserve credit for helping me get back to flying. So far, so good.

Awesome to hear that solved it for you!! Happy flying :wink:

I’m now doing a full windows reinstall… let’s hope for the best.