Msfs crashing half way through startup

I had to completely factory reset my PC. So annoying

Hey, I tried deleting my rollingchace.ccc file several times but it keeps regenerating as if it was never deleted. It has a file size of 8,388,608 KB (or 8gb) and when I delete it, it deletes strangely quickly - instantly, usually for larger files it takes a few seconds. I then clear the recycle bin. When I launch the game, it crashes around halfway loading (with no error messages) and when I come back to the app-data folder, the rollingcache file is there as if it never was deleted. Furthermore, I tried everything you mentioned, deleting DCE, scenerycache and scenery indixes.

Hi… the reason why deletion of rolling.cache is recommended is, that you get a clean / fresh rolling.cache file - without possible data issues. If you have in-game the rolling.cache enabled, then MSFS automaticly re-create a new ‘clean’ cache file if you removed the rolling.cache manually :slight_smile:

Dont !! remove the file while the game is running. Stop MSFS, remove the file, start MSFS - then test whether the issue goes away. Or alternative, do all the rolling.cahe stuff only from the in-game settings menu, where you can enable/disable and also remove the cache.

If you still get issue after you removed one-time the rolling-cache file, then the reason for your problem is not the rolling.cache.

Regarding Cloud-Save ( I missed your post ):
You own also the Steam version and not the MS-Store version, Right ? If so, then you pickup the wrong FAQ regarding cleanup cloud-save.

The newest post I wrote about Steam-Cloud-Data is here, may be its more helpfull

PS:: and to be sure… you never had installed e.g. the google-map-replacement mod ?

Thanks for your reply. So I have tried your suggested steam cloud methods last week and they didn’t fully solve my issue. This was the outcome - I was able to load into the main menu! But when I click “world map” the game crashed to desktop. Sometimes I could click on “world map” but when selecting a departure airport it would crash to desktop. After that, I tried resetting the game to vanilla state, and then the crashes to desktop began midway through the loading screen.

BTW: I realized out that the cloud stuff I tried to do in terminal was for MSFS only (whoops). And I have never used the google map replacement mod, nor anything similar to it.

Its been around two weeks now and I’m considering doing a complete reset of my PC. I am however scared that the issue will persist and I would have reset my PC for nothing.

if that helps, its in my opinion then usually a cleanup / setting / etc. we forgot to do / to check. I reinstall windows only if I get a new PC. But some users it helped.

I asked about the google map-mod, because issues in world map comes often from that mod. It changes the windows hosts file and that can cause trouble in world map, but also while startup.

But there are other reasons for both symptoms ( ctd in world map, ctd in 50 % blue bar ). Often it was also caused from mods, but if you removed all folders and did a complete reinstalling… hmmm…

Which kind of Anti-Virus tool you own ? This causeing sometimes also trouble…

Have you checked the windows event viewer for the message ? May be we get a hint from the error code.

Also , next days the SU12 will arive… may be the new version change some things related to the ctd you get ( but I fear … ).

hello I have the same problem… can someone help me fix this please
Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Hey, so I waited for the update. I updated without any problems, straight after the update MSFS was working perfectly, I hopped in a cessna 152 to a random spot and the game ran perfectly. BUT I then went to the main menu and it crashed to dekstop. Now it is crashing to desktop upon loading at around the 75% bar everytime.

I use malware bytes, turned all antivirus off and it still crashes.
Event viewer has this exception code: 0x80000003

Any ideas?

Any ideas?

hmmm… the 0x80000003 after a crash… for some users invalid files caused that, may be from the crash. So may be again cleanup the user-files might help. You can also try to disconnect all devices ( joystick, etc. ) and start the game. If then MSFS start fine, that might also indicate the problem.
For other users it was caused allways from the antivirus tool, some users need to completly uninstall that because the AV-tool was never really “off”.

But its more or less all a guess. CTD while jumping into menu , what the problem caused, was often because of a system problem ( may be also wrong windows pagefile setting, or less free disc space as the causes ).But list with possible reasons is long…

I unplugged my joysticks, cleared cache again, turned VRAM management to managed by system, and the crashes have continued. I checked the msfs crash report, and this is the error OnCrash:

Msg=FiberError

Any Idea’s?

hmmm… can you post the complet error entry ?

And with VRAM you meant windows pagefile ? :slight_smile: … set it on System Managed or a forced value of minimum 16GB max 32GB for a test-case. Can you also share some system infos about existing RAM and free disc space ?

CrashReport.txt (17.2 KB)

Heres the crash report. As for the VRAM, I set all of my drives to system managed, then tried a forced value of min 16gb and max 32 gb, and the game still crashes. Here are my specs: RTX 3060ti, Ryzen 5 5600, I have a 500gb m2 slot ssd for windows, and two HDD, I installed msfs on my 4tb HDD drive. I have 16gb of ram. (2x 8gb)

intressting, thats the crash file from MSFS folder, or ?..

I meant more the error message from the “windows event viewer”.

But its really intressting… I think about the meaning of “fiber”. I know ‘fibers’ from Ruby, but not realy familiar with that. So may be its a kind of script that fails with concurrent handling. The community folder is still empty ?

I also haven’t heard of fiber, did some research but couldn’t find anything on it… Maybe some devs can help? Attatched is a screenshot of the event viewer. And yes the community folder has been empty since the begging. Furthemore, I used another forum’s suggestion of reinstalling in this method: Microsoft Flight Simulator | Re-Install MSFS2020 in Seconds - YouTube and what happened was I got to the end of the loading bar, and the animation to display the main menu started, a couple of frames processed and then it froze and crashed.

the video is about ms-store installion. Its basicly same as I described above for your steam install, just the folders are on different locations. Most important to know is: if users want a clean local reinstall, then the app-data folder needs to be removed manually after un-installing the game. That will of course not help, if the cloud-data is corrupt.

The “new” crash (0x80000003) while enter the menu…hmmmm… that can still come from cloud-data, connected joysticks, etc, but can be also different reasons. Did you tried already to limit the Max-FPS to a low value ( e.g. 30 ) in nvidia control center ?

And related to “developers”: dont forget to ‘inform’ the developers about with open a ZenDesk ticket (support link in forums header ) and attach the crashreport. ( and dont wonder about the state “solved” :wink: ).

PS: I know, lots of guesses, but its not easy to narry it down remotly :slight_smile:

I have another question…

Can you check the message before the “0x80000003” ?.. is somewhat mentioned with a “nvlddmkm” crash ?

Alright so I’ve submitted a report on zendesk, lets see what they have to say. So the error 0x80000003 doesn’t actually show up as a notification on crash, I just see it in windows event viewer. No notification is present after the crash. As for the “nvlddmkm”, I can’t see it anywhere on the event viewer.

I also did your suggestion of limiting FPS to 30 via nvidia control panel - no difference.
I also deleted the user data once more to see if it would help - No difference either, crashes at 75% again.

Tonight I am going to do another clean reinstall of the game, this time with SU12, lets see if that will help at all.

PS: I appreciate your patience and help with this :slight_smile: Please let me know if there’s any other information I can give you to help.

I had the same problem! But after two reboots,my System suddenly offered me Windows updates. After I had done these, my sim started running.

Scott

I have good news! My game is now up and running again. I just did a full flight with no crashes, no bugs, it ran perfectly. So what I think fixed it was the second clean reboot (similar to @ScottMDA). However I did a few extra steps. I don’t know wether these had any effect, but for the sake of sharing here’s what I did:

  1. Uninstall MSFS through steam (right click on game, uninstall)

  2. Went to %appdata%, and deleted the MicrosoftFlightSimulator folder.

  3. I then went to programfiles(x86), then steam, userdata, my profile number, then deleted folder 1250410 (I have tried this several times before, but as an extra precaution I did it anyways)

  4. I went to where MSFS was installed through steam for me: (E:\SteamLibrary\steamapps\common\MicrosoftFlightSimulator) and deleted that folder too.

  5. As another precautionary measure, I went to change my VRAM paging options (just type performance into the search box on windows, then adjust appearance… advanced, and its there) I set them all to automatic (again) and after all this I restarted my computer.

  6. I reinstalled MSFS on the same drive as before, and after the install, I got to the main menu, exited the game, and restarted my computer again.

My joysticks were unplugged for this entire process, I only re-plugged them after step 6.

After all of that the game finally started running normally. Here is what I think fixed it. So my issues began around three weeks ago which was within SU11 and AAU1. During this time I did a clean reinstall of MSFS, and the crashes persisted. With the help of @MichaMMA I troubleshooted a bunch of stuff, but to no avail. I waited for SU12. Where the game launched to the main menu for the first time since the crashes, but then crashed again anyway. However, after doing this clean reinstall of the game after SU12, It has been running well, therefore my theory is that my bug was fixed in SU12, but wasn’t fully in effect until I fully reinstalled the game after SU12.

Zen desk didn’t really help, they just suggested I restore the game to vanilla state, which I had tried several times earlier. So as for the Fiber Error message, Still have no clue what it meant.

1 Like

In computing ‘Fibres’ are just lightweight threads.

The 0x80000003 error is a breakpoint error that is mentioned in other threads (GFX Card has encountered a problem)

but 0x80000003 stand not generally for a GFX card error, its just a “somewhat happend” error :slight_smile:

the fibres, yes… I also know that from ruby as “lightweight threads”, but we are not sure about the relation and the meaning in MSFS. May be they use same semantics. Problem was, that these error-message gave us no hints about the reason ( in contrast to the other topic, where the CrasReport message is ‘clear’ : “Msg=GPU Device Removed” ). But at least I’am happy, that we have now basic CrashReport file :slight_smile: