New constant sim crash. Not seen here before 1.30.12

Thanks. Not one I’ve come across in the UK.

1 Like

I have mentioned it elsewhere but even on a high end PC do not disable the pagefile as advised by some websites on the drive MSFS is installed on.
Your PC may well run better without a pagefile but if you game or video edit etc it certainly will not. Without a pagefile it cant even provide a proper crash log.


Yup I’ll even recommend what I have, a single 15GB fixed virtual cache on C:, all others disabled. MSFS content on D: which is my only drive that gets accesed while flying and I’m 99% certain this is only scenery loading. As I see it the core MSFS workings and the aircraft you fly are preloaded into ram before you hit fly and they then run from there… I recommend 15gb as I once had a paging error with only 10 set.
PS. I have 32GB ram, for 16 or 64 you may need a little more or less. Otherwise just let Windows decide.

hmmm… at least we tried it :slight_smile:

Without the crash of windows, I had also the idea about the xbox login ( just logout, restart win, login ) ( or xbox services )… but that your pc totaly freeze sounds not like that problem. The mentioned cloud-data can possible also cause issues in some cases. You can try to clean this - assumed ms-store : , steam is different and you can try this in a way without loosing the real-cloud-data.

Thanks for the tip, but my MSFS is Steam version. So, not much about to do cleaning those files. :frowning:

be happy, in Steam is much easier to do that , and much less issues with Steam installs in general.

Cleanup of ALL cloud files is easy:

Tricky will be if you not want to remove all files.

You can as example backup all your steam-cloud-files (Playtime gone missing [Packages out of date] - #31 by MichaMMA) .

Manually from these steam website:

or per backup the local cache folder :

C:\Program Files (x86)\Steam\userdata\xxx_your_steam_id_xxxx\1250410
( note: 1250410 stands for MSFS app-id )

In this way, you can later also stepwise restore files. E.g. for some users the logook file becomes corrupt, but not the input_ files ( joystick settings ). So you can later restore e.g. the joystick settings and only loose the logbook.

What you need to do for testing is then , after the backup of the files, to disable in Steam the Cloud-Save for the Game. Then remove the local cache folder for MSFS. In best, just to be sure, clean app also the folder %AppData%\Microsoft Flight Simulator. Simple remove all files/folder except ! the Packages folder ( if you have the packages installed in default, these folder contains all of the content ! ). Result is a clean start of MSFS.

If that works you can decide to enable Steam-cloud again and use the “clean start”-data. Or you can do future tests with the old data. In each case Steam ask you which files should be used when you then re-enable the cloud-sync again.

1 Like

Well new update from Nvidea and MSFS, still the same crash:
Bucket de falhas 1616234286692192645, tipo 5
Nome do Evento: MoAppCrash
Resposta: Não disponível
ID do Cab: 0

Assinatura do problema:
P1: Microsoft.FlightSimulator_1.30.12.0_x64__8wekyb3d8bbwe
P2: praid:App
P4: 63c56d8f
P5: FlightSimulator.exe
P7: 63c56d8f
P8: 80000003
P9: 0000000001da7645

also having this error:
Nome da aplicação com falha: FlightSimulator.exe, versão:, carimbo de data/hora: 0x63c56d8f
Nome do módulo com falha: FlightSimulator.exe, versão:, carimbo de data/hora: 0x63c56d8f
Código de exceção: 0x80000003
Desvio de falha: 0x0000000001da7645
ID do processo com falha: 0x0x51F0
Hora de início da aplicação com falha: 0x0x1D9581DD66CB779
Caminho da aplicação com falha: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.30.12.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Caminho do módulo com falha: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.30.12.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
ID do Relatório: 295ce061-bff9-42bf-ac0a-9272734f7e94
Nome completo do pacote com falha: Microsoft.FlightSimulator_1.30.12.0_x64__8wekyb3d8bbwe
ID da aplicação relativa ao pacote com falha: App

i am very dissapointed at this game, the only update working well in my pc was 10, now again with the CTD… hope Microsoft/asobo fixes this next days, Xplane is not as good but is just arround the corner…

Do you get these crashes even without any Community mods installed? A common cause of crashes, usually seen soon after a new update is released, are old Community mods that don’t work well with the new version. There is a period where TPD are scrambling to check if their existing addons work well with the new version.

Trying without any Community mods is a quick way of finding out where the problem may lie.

I even reinstalled FS again without success

Good day. Using an empty Community folder was the first thing I tried.
Then I went on the support page and found a series of options to follow.
Did all what was suggested, with no result
I even tried the empty cloud solution. In that case the sim went to the accessibility options page, then went on to continue loading - it has been the only case where the blue loading line almost reached the end - then it CTD like before

I’ll wait for the next update with fingers crossed

Check your content manager for any updates, if not that and you get the try safe-mode pop up then do so with no other apps running. You will be to restricted default aircraft and scenery but if then all is well it will indicate a marketplace addon or an outside app was/is the cause.

Ok, I did every step indicated. MSFS started as if it was freshly installed. When starting it without any controller connected (I have one from Microsoft and a Saitek), the simulator works, but when restarted it with any of the 2 controllers, when starting the flight, the black screen appears with the total crash of windows.

Remembering the first black screens, when entering the folder with MSFS screenshots, Windows took time to display them. I THINK there must be some conflict in how Windows and MSFS understand certain types of bitmaps.

I waited for the last update (done without anything in the Community folder), hoping it will change something in the simulator, but the problem remains the same. The last card I have left to play is to format, install windows (go to Windows 11) and the simulator from scratch, to see if that ends this nightmare that does not allow me to fly.

And therein probably lies your answer.

Check for updated drivers and Windows updates, xbox updates, plug straight into the PC back panel or use a powered hub, switch to a power profile that doesn’t let usb sleep etc. … the list is long

1 Like

It’s just that that doesn’t make sense, because I haven’t changed my hardware, nor have I changed any preferences. The only thing that was updated and stopped working is the flight simulator, which worked perfectly until a certain update. Before that, it worked without any problem.

But those MSFS updates actually change things and Windows updates actually change things and drivers sometimes have to be updated to keep up e.g. graphics. In worst case scenarios a PC would even stop booting.

1 Like

does it works with SU12 ?

Issues with connecting a controller is why we cleaned the cloud files, where the input files are located. Had you removed all input_* files, localy and from cloud ? I remember rare case where these caused similar issue.

If all was clean and still crash, then may be a driver issue for the controllers can be the reason. But its more like a guess. The controllers are connected via USB Hub ? As @DensestSnail693 mentioned… “the list is long”.

1 Like

So I installed the new update, everything now work, but all my profile, hardware presets and flight hours are missing, like if I installed the sim anew…

thats the side-effect of cleanup cloud files, but for some users the only solution ( one of the file was corrupt ).

My recommendation for steam users: backup from time to time at least the “input_***” files ( see mentioned link ) , so that you can easy restore your controller settings. Flight-hours, etc is’nt much important for me.

Just an update on my progress with this wretched problem.


To recap, I had hardly been able to fly since beta in December, getting almost constant load CTDs or lockups before I even got into the sim.Reinstalling the GFX drivers (nVidia GTX) would often get me one session without a crash, only to return to the same crash on the very next session load. You can see hos many things I had tried by looking at my previous posts in this thread. I’d tried everything.

And then there was SU12.

So I updated, and tried to load the sim and got the exact same crash. Oh dear.

But I remembered Jorg saying several times in the SU12 Dev Q&A this week - “Do update your nVidia drivers - there has been a problem with them for a while now which is now fixed”.

So I looked and there was a second new Game driver release this moth recently, so I clean installed nVidia GTX Game Driver 531.41.

There are also comments about MalwareBytes and MSAV damaging files. Now I had always been pedantic about removing every folder connected with MSFS from both of those protection softwares, but there was one more folder I recently discovered which may need to be removed from MalwareBytes, namely…

C:\Users[user name]\AppData\Local\Packages\Microsoft.GamingServices_8wekyb3d8bbwe
…so I added that to the list opf exclusions.

Since then, I have had perfect simming. Best it’s ever been. Sim starts reliably every time since these two changes + SU12 update. GFX are smooth. CPU scheduling is consistent over long flights. No more FPS dropping as the CPU spikes after a few hours.

As a test, I have just completed 21 hours in the sim without leaving a FLY session. I have done four Longitude flights from Thailand to Central Australia, then to Melbourne, then across the Atlantic to Bora Bora, then on to the Central USA.

Everything has worked perfectly so far, including Live Weather.

And all this with 397 addons active in my Community Folder and all my Marketplace purchases active too.

The only thing I am not running is AI traffic or real world traffic as my system is not up to doing those at a smooth FPS.

So after months of frustration, I now seem to have a really good sim. I can only hope this lasts.

Maybe this information will help someone else to get going again.

Fingers crossed, touch wood etc etc.

1 Like

it more like that the latest 531.41 cause huge problems. Latest stable for me was 531.29…

But in generally yes… install latest updates is usually that what have to tried first :slight_smile: