MSFS doesn't launch - opens MS store with Gaming Services instead

As described in the topic line: all of a sudden i am no longer able to launch MSFS. It worked fine some days ago. Now it takes me to the MS store automatically each time i try to launch it. I already tried the solution described in this old thread - without success: https://forums.flightsimulator.com/t/game-doesnt-start-opens-microsoft-store/202716/2

I also tried to logout and login again in the xbox app. No success. So I am now stuck in a MS store Gaming Service loop instead of flying around the globe… so much fun…issues over and over again with this game. Seems the MS store version is especially sensitive…

Does anyone of you have an idea what else I could try (except for installing the whole simulator again).

Have you updated the sim? An update was released on the 19th.
You possibly need to updated via the MS Store first, then when you run the sim it should find the latest update.

The problem is the last Gaming services update from MS Store, once it is installed FS2020 does not start more even it disappear from program files and you can´t uninstall it or install it from MS Store that says uninstalled and if you want install it again, that is without any uninstallation of FS2020 performed by you, then you press install and they stay doing nothing for ever till it ask you again if you want install it, in a loop.

Solution for me is, to restore a full OS backup from Wednesday, set MS Store to not update automatically, and when you check for updates and you observe that Gaming Services is updating cancel immediately as fast you can. I had other updates from MS Store at the same time that did not affect MSFS, and finally is starting well.

Edit: I have the disaster again, I had unchecked in MS Store the auto update apps, and anyway Gaming Services is updated again and FS2020 does not start :/. Maybe in the firewall block MS Store and maybe some of its services if that helps…

2 Likes

I have the same probleme, impossible to play or install the game, i have this message.
I specify, my pc is up to date with the latest windows 10 update.


Capture2

Me too, I am ultra updated and W10.

I’ve done everything but the same mistake remains

Same issues. Now am trying to re-install entire sim, and it just hangs on a 10.1MB download in the Xbox app. It’s frankly amazing how screwed up the update pipeline for this game is. I work as a software engineering director, and I still cannot imagine how this can be implemented so poorly. Fix this!!

5 Likes

Same here. So frustrating. I can’t reset or update xbox app, Gaming services is completely missing from the registry so i am unable to update it or reset in microsoft store. MSFS is just in a constant loading status even after reboot.

1 Like

I have conteacted MSFS support…they gave me the standard troubleshooting guide (reset MS store, update everything etc.) nothing helped. Windows and all apps are up to date. MSFS keeps sending me to the MS store Gaming Services page. My last restore point is from yesterday because i updated davinci resolve…i have no earlier OS restore point so this won’t help most probably…
As I was thinking about upgrading to Win 11 … maybe this is the right time … perhaps this also solves the Gaming Services issue if everything is new… LOL What a game/OS that makes me think about an OS update to solve an issue with a single game. I mean: it is simply a game/simulator - it should not take so much time of our lifes just to do troubleshooting. I am realy upset with MS.

2 Likes

One thing that makes me wonder ist that the Digital Ownership entry in the MS store shows “install”. As if the ownership is not active…? I tried to click “install” but nothing happens. Anyway - I think the issue only affects MS Store versions of MSFS. This store is somehow instable. Would have been better to buy the game from Steam maybe…

I’m sure it’s Microsoft store issue. I have 3 pending downloads for update and it’s taking hours for small files at 15kb speed… I have game services in the cue also and it’s not progressing.

Solution till it is fixed, go back to OS backup of Wednesday or Tuesday, immediately after start Windows go fast and furious to MS Store app and select download and updates option in … button in right upper corner and watch as an eagle to there till Gaming Services appear suddenly updating itself and you press like a thunderbolt the cancel option (X button), then disable all automatic updates of Store, to me that really stopped the MS Store app of updating was the last of this page https://www.thewindowsclub.com/disable-automatic-microsoft-store-updates, after doing all the previous ways, always after reboot Store auto update Gaming Services, despite all my orders even screaming verbally to it, never paid attention to me in an arrogant way.

You can update manually after, but always be ready to kill without compassion the Gaming Service update process that appear after, and the problem it is solved, or leave it as it is but remember then, then fast and furious first of all to MS Store in any start, reboot etc…, till all is solved.

Unfortunately I have no OS backup from before the Gaming Service update anymore. I now thought that I accept to go through a reinstallation of MSFS…bad idea…the install button in the store does nothing. I click it, it diappears and after some seconds it reappears as “install” button. So now i even cannot install the game i paid 60 bucks for…thanks MS

1 Like

Is a good idea to have a backup program like Easeus Todo Backup or Acronis and make one big backup file of all OS, and then perform manually or automatically normally small incremental backups of the only new and different of each day in your PC that counts as full backups but not doing a full backup. Hope all a good weekend and to solve quick this.

And do not forget to vote this thread for try to make it solved earlier.

1 In windows seacrh bar type

powershell

2 Right click on it and select run as administrator
image

3 Copy the command below and paste into powershell (right click to paste into powershell)

Remove-Item -Path “HKLM:\SYSTEM\CurrentControlSet\Services\GamingServices” -Recurse

Press Enter

4 Copy the command below and paste into powershell (right click to paste into powershell)

Remove-Item -Path “HKLM:\SYSTEM\CurrentControlSet\Services\GamingServicesNet” -Recurse

Press Enter

5 Copy the command below and paste into powershell (right click to paste into powershell)

Get-AppxPackage gamingservices -allusers | remove-appxpackage -allusers

Press Enter

Restert PC

6 In windows seacrh bar type

powershell

7 Right click on it and select run as administrator
8 Copy the command below and paste into powershell (right click to paste into powershell)

start ms-windows-store://pdp/?productid=9MWPM2CQNLHN

Press Enter

Click get (install gaming services)
Also update all apps via microsoft store app.

Run msfs as administrator.
image

I’ve done it but NOTHING solves it.

I have the same issue since SU6 (everything was working normally previously).

I tried the the advice here, using the Powershell (I have no compulsory or pending optional Windows updates):

https://support.xbox.com/en-US/help/errors/error-code-0x80073D26

It did successfully remove Gaming Services, such that I could then restart my PC and reinstall Gaming Services.

However, when attempting to start MSFS it takes me right back to trying to install Gaming Services in the Microsoft Store again (I’ve tried Terminating and Resetting the Microsoft Store app, but to no avail).

In short, I’m no closer to a solution…

3 Likes

I’ve noticed that even when Gaming Services appears to have installed OK when I use the Registry Editor I only see GamingServices… I don’t see GamingServicesNet. Perhaps this is a clue to the problem?

Well i have done a clean install of W10 and everything is back to normal for me. I guess there is something corrupt after the last SU6 update that prevents some of us from using MSFS.(may be coincidence but my W10 was previously on windows insider before W11 was released and i flighted the updates and went back to the latest W10 version.)

1 Like

In my case MSFS worked fine after the SU6 at first. I think that something with the GamingService update went wrong. After nothing else helped I also decided to do a clean install of my whole machine. This cannot be the common solution of course and I only did this because I anyways considered upgrading to windows 11 and also upgrading my OS SSD to more storage space. MSFS works fine again now…but please MS and Asobo: customers are not willing to do fresh OS installs only to get MSFS/Gaming Services to work again. Lets see how long my MSFS now runs until the next Gaming Services Update…

3 Likes