MSFS doesn't start anymore

Hello everyone,

it’s hard to see if this problem has already been discussed elsewhere and I’m really loosing the interest in spending my life time checking this forum when another issue has occured in this worst software I’ve ever seen.

So: Maybe someone can help me. Last week when I played the sim the last time it - once again - crashed to desktop. I thought, well, it’s not the first this crappy software is making problems. I’m used to troubles since last August.

But now: I can’t start the sim anymore! Not even in the administrator mode. It simply doesn’t work anymore.

Does someone have an idea what to do? (What I’m definitely not going to do is re-installing the sim. The first installtion took about 15 hours.)

I can’t be of any help but you’re not the only one. After about three seconds of loading it just crashes out. Every update brings its own problems.

I have had 1 ctd in 9 months. i run an msi gaming laptop 16gb ram gtx2060 and have noted performance increases. There are many tips about cleaning community folder, running win update, shutting unnessary processes. making backup of official folder, too numerous to mention here. Do you know anyone who could look at your system for you.?

My system runs actually flawless. Community folder content has been removed, all updates are installed, driver booster is running in the background etc. I don’t think it’s a matter of my system.

cant help you then sorry

1 Like

Thank you very much nonetheless.

what is driver booster ?

Did you update to the latest version today?

If so, like me, this sim is broken now.

I cant fly without a CTD.

Its over for me Im back to DCS!

1 Like

ok Yes I updated and have no problems.

No, I didn’t even reach to point to update the sim.

The program simply doesn’t start anymore.

Wouldn’t be surprised if they managed to break it once more.

1 Like

they didnt break it for me. Maybe you are just unlucky. there are thousands of reasons why. Im am very lucky guy 1 ctd in 9 months and my performance just keeps getting better.

Just take five minutes of your time and browse this forum. Just enter “ctd”, “not launching” or “issue”. Asobo broke so many things in the last months, just think of flaps earlier this year or the ATC.

well they didnt break anything for me, so what can I do about that?

That’s hardly possible. They broke several things in the last months, maybe you didn’t notice that. As mentioned before: Just think about the flaps issue when they “updated” the flight model and suddenly everyone was unable to land properly. You find this issue here in the forum; later they deliverd a hotfix, because they broke it. And what about the ATC? You didn’t have this problem since the last “update”?? I can’t imagine. If so, you’re among a group of very few users.

yes the flaps issue was just a few tweaks, that I solved using notepad , they admitted the mistake and fixed it later. I really cant complain when I dont have any problems,It is possible. I have an Msi gaming laptop 1terra ssd and 2 terra d drive 16gb ram rtx 2060, what can I do about that, Listen when I run into any pc problems I do a google and work from there. I keep my machine lean and clean. One CTD that was caused by a mod. Im just a very lucky guy

1 Like

That’s the point. As I said, just browse the forum, you’ll find many people experiencing problems all the time, mostly after updates. The icing problem has also been not there from the beginning. What I as a customer can expect from the producer is to provide a running system. If so many people are experiencing issues the problem is not on the customer’s side.

I found a lot of people also in other forums having the same launching problem today.

Anyway, I got the program launched finally. (I launced it from the store, which is also unusual). So the update has started, but I wouldn’t be surprised if new posts can be found in the “bugs & issues” sector soon.

im here to help people, so i hope you have a lot of fun in the future. my girlfriend also bought me an xbox series X for my birthday, im lucky to have her

Also in my case (Microsoft Store Installation) after each update since months MSFS wont start again. So I do…. As Follow…uninstall MSFS after having saved the package folder. reinstall MSFS very quick Start MSFS exit at the update prompt. Copy back the packages folder……et voila. Let the game update.

Just to precise a little: you can uninstall and do a fresh Instalation very rapidely just cut and move to desktop the Onestore folder . Uninstall MSFS. Reinstall from the Store. Start MSFS instead off redowloading exit MSFS. Cut back from desktop the Onestore folder in the installation. Restart MSFS now it will only download the new data in the Onestore folder. Hope it helps

you are a lucky guy…i have a powerful system and no problems since october…download this update and the sim wont launch…i guess luck runs out…


Generally we have a rash of these issues every update. The common denominator is usually those with questionable bandwidth.

The sim requires a connection to the servers and Xbox for authentication. When that fails so does the sim. On update day, there is a spike of users connecting all at once. If your connection is poor, (server ping, not provider speed rating), you will have issues.