MSFS flight sim Won't Start

I too have been bitten by the CTD bug. This comes after a new installed (Update 9) and a new computer and continues through Update 10. Whenever I can force MSFS to attempt to restart in Safe Mode it prompts me for disks. Finding none the installation doesn’t continue. When attempting a normal start it opens the start screen and after a few seconds, it closes with no warning or additional information. I do not have any 3rd party add-ons installed.

Historically, this subject spurs debate. I would appreciate comments that lead toward a resolution. Thanks!

– Frank

Theres a thread here regarding the same issue, this will be more then likely moved there.

I have found a cause and resolution for my issue. In my case, it had nothing to do with the graphics card, but another piece of software running in the background.
This thread can be marked resolved.
Thanks,
Frank

may be you can mentioned which one, so it can help other users. There is a list with conflicting applications within the FAQ, but may be you found a new one :slight_smile:

The Razer Cortex software attempts to optimize background apps prior to launching the sim. Disabling Cortex allows MSFS to load and run. I’d plan to report the issue to Razer before reporting them by name, but since you asked…

Thanks,
Frank

1 Like

BTW: Where is the FAQ with a list of offensive apps?

thanks for report back.

And yes, the Razer software and these optimize setting is, so far I remember, already mentioned in some posts :slight_smile:

EDIT: one example of a list in FAQ is:

Its not in each case that these tools cause trouble, but just sometime. I think the most known is the “Capture One” software.

1 Like

I too cannot bring up my sim. Constant CTDs. I last flew two days ago. Today I tried to start it up and get a CTD, so on the next start I select the Safe mode and again CTD.

I install the latest NVIDIA drivers and still CTDs.

I restarted my PC ands still CTDs. I cannot start the game. Are there server issues which are preventing us from brining up the sim?

1 Like

Did you read the above?
Because a lot of people don’t do it.
If you read the above and it doesn’t help you,good luck.
I know how frustrating it can be.

Scott

1 Like

I stopped Razer Synapse Service and that seems to have fixed my problem. I have successfully brought up the sim twice after disabling that service.

Same problem here, but closing Synapse isn’t helping. I’ve been down for three days. Did it start for all of us on Tuesday/Wednesday?

About 20 seconds after starting, I get a window that’s max size, black inside, and after about five seconds it closes.

I’ve:

  • Turned off Windows Audio during MSFS Startup
  • Killed Razer Synapse and all associated things
  • Killed ICUE
  • Killed Google Drive
  • Killed Viveport
  • Killed Windows Power Toys
  • Killed Slack & Discord

The last time I had issues like this it was due to Windows Audio and it was also keeping NMS from starting. This time, NMS starts right up, so it’s only MSFS that won’t start.

Anyone else?

So sorry to hear that you are still having problems after killing all the services you mentioned.

Stopping the Razer Synapse worked for me. I later went to the Razer app and it stated there was a Razer update available.

I think besides Synapse there is also a Control program for it. Anyway, I did the update and now the sim is working fine even with Synapse turned on.

So I really think there was something wrong with the Razer software. Bring up the Razer Central panel which is in that lower right up arrow (I forget the name of that now) and right click the Razer icon and have it Check for Updates.

If updates available, do the updates and let’s hope that gets you up and running! I know how frustrating it is when we can’t use the sim!!

Uninstall iCue software, it used to cripple the sim here back in the olden times. Try the sim again, if it still doesnt start and you updated the Razer stuff, then uninstall the Razer stuff, and try again. The iCue stuff has been verified by many people in the past to cause these issues, and things smoothed out back then when I removed icue and razer.

sounds like a login issue… may be.

I have Icue installed, and no issues. But I disabled the Corsair services because I dont need useless rgb bling bling, in special if this consume half GiG RAM … the keyboead profiles still work also without that junk.

If you assume a issue with audio , you can easy re-check that with stopping the windows audio service for a test-case.

I opened a ticket with Razer, advising them of this issue. I also made them aware of this forum and suggested that they run independent tests to identify and resolve the issue.

In my case, the problem was Razer’s Cortex “optimization” software. Hopefully, a future update from Razer will resolve all issues.

I know how frustrating MSFS can be when it doesn’t work as expected. Hang in there.