MSFS won't load? New MB/CPU/Mem

System was working fine with Beta 10. Then I decided to upgrade my system. After upgrading MB/CPU/Mem but kept drives etc, MSFS splash screen appears, says its syncing data, launching game, black screen then back to the desktop?

Went into the UEFI and opted for system default settings, same same!

Looked at event viewer but just seen errors with MSFS but nothing rang any bells?

Opted out of the beta!.

Did all of the things mentioned in other posts like stopping app, repairing, reset & wsrest.

Figured I needed to uninstall and reinstall msfs. But nothing changed!

Any ideas?

Asus Hero; 12900K; 32GB DDR5 6000

Rick S.

Make sure your Microsoft Account is showing your new system, that Windows is registered to the new sysyem build. Log out of Microsoft Account, Microsoft Store and xbox app. Log in again.

Thanks but nothing there worked ccrbc?

All other programs work from what I have tested.

I have uninstalled and reinstalled msfs multiple times.

Tried loading beta 10 again and got this on launch:

“Something went wrong launching your game.
Error Code: (0x8007042b)”

you have may be to re-install gameing-services…

( also )

EDIT: in BETA area exist also topics related to that, example where missing windows update caused that

1 Like

Your PC time is incorrect …

1 Like

Tried all suggestions MichalMMA, no change?

Thanks for trying.

1 Like

Nope, used the sync link and still the same BP.

Thanks anyhow!

Any other idea out there be fore reinstalling the OS???

Thought of just giving up on MSFS but I have way too much invested to quit like this.

I hate XBOX!!!

Rick S.

All Settings>Apps>Apps and Features>Advanced Options>Repair.

Click Microsoft Store & select Advanced options, then Repair.
Do this for XBox and Microsoft Flight Simulator also.

Nope ccrbc, same same!

FYI, I even tried all of these suggestions:

Rick S.

Did you simply replace the hardware with the same installation of Windows and all your software including MSFS.
If that is the case I would suggest it would be a more sensible approach to create a fresh install of Windows and thereafter make sure all drivers for your new hardware have been loaded. Ensure windows is up to date finally reinstall software.

Doing a fresh install would likely fix the problem Blitzer, but that is what I am trying to avoid.

Finding all the the software and key codes, reinstalling and upgrading could be a week long + nightmare and I would likely loose some programs, utilities, fixes and mods that I don’t use often and would sorely miss at some point.

I did reload and update all of the drivers that came with the MB and have searched out others as I have encountered any problems; none to date except msfs.

I have updated hardware many times in the past and have never run into this problem with a single title.

My suspicion is that the XBOX app is somehow at the bottom of the problem and why is it even part of a PC program? Rant over!

Rick S.

You might want to double check service manager and make sure Gaming Services and X-Box live Auth Manger are all running.

Have you also tried logging out of all Microsoft accounts, maybe even reinstalling related software and then logging back in to those accounts?

There are 2 Gaming Services Running, Local Service and Local System. Both Running on Automatic; I have stopped them and restarted them with no change.

There is also a GameSDK Service showing Automatic but not Running; started it and ran MSFS, same result?

UPDATE: Worked long enough to load and update; would not load after reboot again!!!

Finally found the culprit!!! NOT!!!

Between the time I took my old machine down and booted up the new one there was an update to RazerTartarus V2 keypad that loaded a program call Razer Cortex System and Game Booster. I don’t remember ever loading these but one of them boost’s or modify’s the system cache file.

As soon as I killed those from loading and rebooted, MSFS was good to go, except I had already uninstalled and reinstalled the sim. Yes, it has been updating for hours now!

Hopefully I can engage my data on a separate drive at some point.
Rick S.

1 Like

I do believe I have found the culprit now thanks to MichaMMA and Hester40MT.

An old copy of Project Lasso I haven’t used in over a year was loading in the background!

1 Like