Something Went Wrong (0x8007042b)

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Brief description of the issue:

After Latest update, MSFS will not open and states that "

something went wrong launching your game"

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I’m getting the same error. This is probably the third…maybe fourth or fifth time (I’ve lost count) it has done this via the update process. Usually ends up in a reinstall.

It’s getting very old.


can’t keep doing this TBH, They always seem to break something every update


The update before this latest came out borked my VR to the point it wasn’t fun at all anymore.

see here, user with same error code and where its caused from gameservices…

note: there is also a official FAQ about how to reinstall

PS: do we realy need duplicates ?

What I do is make sure my mission/activities folder is backed up (bush trips).

Then I do a reinstall.

After all the updating is done I copy the missions/activity folder back into its proper location.

Next I restart the “game services” in task manager, which will reload the logbook with the proper hours.

I just finished reinstalling FS 2020 (again). All is good. :slight_smile:

Yeah and not a single reasonable reply from anyone. XP12 here I come! Asobo absolutely sucks at helping!!!


as mentioned:

Yes we do. Because there is never a practical response from Asobo or microsoft.

1 Like

you do what ? :slight_smile:

The issue is a ms-store & gameing-services thing ( I linked within the post the existing solutiuon ) and not in special a MSFS problem. Thus not sure why you expect within a MSFS Community a response. If I have an issue with Steam ( what never happend, in contrast what we can read about that ms-store :wink: ), I call the Steam support and not expect that anyone from Stream-Support answer here in forum.

The main important point is: we know what users can do in such a case.