MSFS2020 will not start or freezes 'not responding' during in game update screen after 1.18.13.0 update on PC

I have emptied my community folder.
Having downloaded and installed an update through the microsoft store, the first time I started the program it went as far as the ‘searching for updates’ and then locked up. I restarted and now all I get is a black screen when I start it and in Task Manager it is showing as Not responding and its using about 4 -12% CPU. No other activity.
Any ideas anyone?

Just a guess, but it could be corrupt files during the download. Mine is very slow and only trickling download, servers are probably overloaded.

is there a way to just reinstall the new update or would I need to download and reinstall the whole thing do you think?

1 Like

Have a similar issue on my end as well… I did a fresh install of the game and upon launching for the first time, it loads a black screen with a spinning gear on bottom right and then it crashes to the desktop.

well after many attempts at restarting I noticed there was an update for gaming services. Don’t know if its fluke but out of all the attempts since installing that I have gotten as far as the installation manager screen a couple of times but always locks up. Just now even got as far as it starting to download the 40.29GB update in sim but 106.77kb in it froze up again. This is incredibly irritating.

2 Likes

Yea, I’ve been checking for any pending updates and nothing is popping up. Will reattempt update at the end of the week to see if the overload of the servers is causing this…

well tried all sorts today and still can’t get anywhere. I’ve unplugged things, changed drivers, repeatedly restarted the program. Once I got lucky and it got as far as downloading about 4mb before it froze and was ‘not responding’ status again.
Wishing this was like P3D where you can at least reinstall the latest client. I have slow internet speed and don’t fancy spending the next 36 hours reinstalling it again only to have same issues which seems to be the experience of people who have reinstalled.

1 Like

Having a similar issue here on PC with premium deluxe version.

Was working fine before the update, now I get to the main menu and press any menu item and the game freezes. Task manager just shows “not responding”, never had this issue before this update.

I was using community liveries, so removed all of them, same issue.

I had the game running on two SSD’s using Windows storage spaces and moved to dedicated SSD, same issue.

Deleted the game and downloaded the whole thing again, after update, first launch, game not responding. 127GB wasted.

Disabled “game mode”, disabled “GPU scheduling”, restart…same issue.

Can’t even play the game on PC anymore…■■■ Osobo.

The only thing I can think of which is different, is I downloaded the game on my Xbox Series X and played it on launch day. Whether that has had any impact, I don’t know, but though I should mention it.

All windows updates installed. All windows store updates installed (game services), same issue.

Windows 10 (21H1) / RTX 2080 Super - Steam version of the game

Very annoyed.

4 Likes

I’ve raised a ticket now so will update here if I get anywhere.

3 Likes

I am having thr same problem on 3 seperate computers. All 3 computers have RTX20xx GPU’s and Intel CPU’s from 8700k - 9700k - 9900k. 32Gig RAM…

1 Like

hi friends amd i have very nice conectin but why this

Mine is kind of normal now. Could load the game and launch a flight yesterday and it worked really well, FPS is much improved. Maybe the patch they released helped, don’t know.

I had tried on another machine, my laptop which is a Razer Blade 17 (2020) with RTX 2070 and Intel CPU. Maybe RTX cards are causing issues ?

Still experiencing connection issues during flights, says “you’re not connected to the internet” which interups my session and I have to click “try connecting again”. Servers are overloaded I’d say, which is kinda funny when you think Microsoft is the provider, that just shouldn’t be happening in this day and age.

Anyway, hope it’s fixed for everyone else too and you can enjoy the skies again.

Thanks much! Same exact issue I have. Annoying, last December also had issues with that sim update

Spoke too soon. Tried on my laptop today, same issue…froze on loading…no responding :frowning:

Same on my gaming PC.

Even the xbox version is broken now, I can’t change from “group only” to “live players”, it just changes back to “group only”. Basically I can’t play on either platform now…

Good news on my end. Apparently I didn’t update the “right” component in my package. Was able to download the update via Windows store, through the regular MSFS software, not the “Premium Edition” one. Will look at it this evening to see how it is.

well since the hotfix I have at least been able to reinstall it and start the program without it freezing. Haven’t flown yet because it is now taking hours to set up the manual cache. so far over 3 hours to set up 68gb cache and no idea of progress apart from it’s heavily using my GPU at times and the circle is turning bottom right. At least it feels like its alive lol. Don’t remember it taking this long last time.
What a joy this new update has been so far lol.

I’ve had MSFS since last August and I’ve been playing since the early 1990’s. I have installed the game on a Samsung 500 GB SSD external drive, because my gaming laptop doesn’t have the memory. I have had the game on the SSD drive for several months before I started having this problem. I’ve haven’t had any problems with the game until WU 5 and the following hotfixes. After, I updated the game to the latest version I get several errors. The game all of the sudden acts like it has lost the ability to load anything from the SSD drive. I have re formatted the drive and scanned it for errors. I know the computer hasn’t lost connection to the SSD drive. I have checked if the computer can see it. I’ve checked the task manager and the executable .exe file for MSFS stops responding. I have to force MSFS to shut down. Other times the game will freeze, shut down the game, and kick me out to the desktop. This error happens at random times. I’ve tried different aircraft, airports, and different times of the day. I’ve had this error during the loading of the game, flying, at the main screen, and during different stages to set up a flight.

I’ve been having this issue ever since SU5, so almost a month now. Cannot load into a flight at all. Task man says not responding once i click fly now and it loads to about halfway. Did you find a fix for this? All of the recommendations from MS have not helped at all and I’ve tried all of the fixes that I’ve seen so far.

1 Like

This is the reply I received from tech support at microsoft flight simulator.

Thank you for contacting Microsoft Flight Simulator Support today. Is the drive formatted in exFAT or NTFS? There has been conflicts with exFAT formats since the latest update that can cause crashes. If at all possible, I would advise moving MSFS2020 to an internal drive so you aren’t dealing with a data transfer bottleneck from the external drive. If you cannot do this, then reformat the external drive in NTFS format and reinstall MSFS2020.

I’m having the same problem. I really hope there is a fix soon. It has been too long to not be able to get into the simulator.