My 2070 SUPER 4K settings and suggestions - episode 2

Shouldn’t this:
C:\Users\your_login_name\AppData\Local\Packages\Microsoft.FlightSimulator_#############\LocalCache\UserOpt.cfg
be rather this:
C:\Users\your_login_name\AppData\Local\Packages\Microsoft.FlightSimulator_#############\LocalCache\UserCfg.opt
?
In my case with 1.10.7 even after applying “Sharpen 0” in UserCfg.opt and the recommended settings in NVC, the trees look overly sharpened.

Super interesting post right here!

My ring:
i7 7700
GTX1070
16Gb RAM
Ulatrawide 3440x1440

Settings in Flight simulator are a mix of medium and high, just with the exception of Ultra in clouds (possibly, the best of the game). Nvidia desktop settings untouched leaves me somewhere between 30-33 FPS in low populated/high altitude. Between 25-30 in NYC.

I just tried the sharpening function in Nvidia control panel and lowering the internal resolution to 90% after reading the post and I don’t know…anything beyond 0.1 in sharpening introduces a lot of artifacts, specially in distant objects or reflections.

I don’t know how you guys manage to get clean image with Nvidia Sharpening on. Digital Foundry also recommended it in their video but there must be something on my end which doesn’t allow it to show any advantages.

Besides that, great recommendation!

1 Like

Thank you all for pointing the typo in my post! I have now made the corrections and this looks like this:

Store Version:

C:\Users\your_login_name\AppData\Local\Packages\Microsoft.FlightSimulator_#############\LocalCache\UserCfg.opt

Steam Version:

C:\Users\your_login_name\AppData\Roaming\Microsoft Flight Simulator\UserCfg.opt

Please note if you’re using GE Force Experience automatic settings, this most likely be the cause for the UserCfg.opt setting to reverting to 1 too. You’d have to disable GE Force from automatically updating the settings then. Please let me know this so that I can update the post accordingly.

Also please make sure to change the correct Sharpen entry, there are 2 of them: One in the {Graphics section, the other in the {GraphicsVR section (which is the entire set of settings when in VR mode).

PS: I don’t use GE Force Experience.

Thank you for this guide. Managed to get my 980ti at 4k running 30fps which is more than playable now :+1:

2 Likes

I set “Sharpen 0” as it should be in the “{Graphics …}” section. When I set it to 0 it sticks, so GeForce is not intervening.

No matter which setting I set in the NVC I still get the pixealated trees in 1.10.7. Another “improvement” by Asobo :frowning:
Why, instead of fixing the bugs, they mess with image quality?

Default setting: Sharpen 1, NCP sharpening off (below)

Sharpen 0, NCP sharpening off (below) - this seems like the only setting wihout pixellation, but the overal pictrue apperance is a bit dull.

Sharpen 0, NCP sharpening 0.05, film grain 0.17 (below)

Sharpen 0, NCP sharpening 0.1, film grain 0.17 (below)

And to demonstarte that NCP setting actually works, the exaggerated setting
Sharpen 0, NCP sharpening 0.9, film grain 0.17 (below)

This is a different problem and as far as I understand, it is related to alpha testing optimizations usually.

To put this in perspective, here is an interesting articles about modern game graphics:

And a more complete dissection can be found here:

It is a link to the paragraph showing the same kind of artifacts but I recommend you read the entire page and the other articles!

Here is a paper detailing this kind of problem and offering other solutions:

Thank you for the materials, starts really interesting:
“Hashed alpha testing avoids alpha-mapped geometry disappearing in the distance and reduces correlations in multisample alphato-coverage”
Piece of cake :wink:
I’m going to radically improve my computer graphics knowledge today evening, trying to undestand at least something from these articles, while waiting for the “USB CTD” hot fix.

However, I wonder why Asobo decided to repair something that wasn’t broken, while there are some other issues around screaming to be fixed. The effect of pixelated trees was not present before 1.10.7.
What looks best to my eyes on the pictures above is the version with in sim Sharpen 0, NCP sharpening off, the 2nd picture from the top.

1 Like

They didn’t break anything in my opinion, they might just have forgotten to look back in their commit history, or, it might just not been validated by the art director and only changed in v1.10.7 from a shader code perspective only. Here is what I’m observing (which might not be the truth at all, just observation from the outside):

Looking at the evolution of the rendering engine since at least Aug. 18 (can’t official talk about anything prior this date), I believe (and I Zendesk this a while back) the sharpen post-processing effect was wrongly applied to the render buffer (with 70% TAA, the simulator renders to a smaller buffer size than the screen resolution), instead of being applied to the back buffer (the buffer the same size as your monitor ready to be displayed).

At some point in time (from memory 1.8.3) they nerf the sharpening effect because it was not pronounced enough. This was expected because if you sharpen an image 2000x1000 then enlarge it to 3800x2600, obviously you’re loosing some of the sharpening effect. However in nerfing the effect you make edges more apparent and this creates jaggies and blocky buildings for example.

It appears v1.10.7 is now correctly applying the effect to the back buffer. However if the only thing they’ve done is moving the invocation from the render buffer to the back buffer, they might have forgotten 2 versions ago they nerf the effect and it must be adjusted back to initial strength now.

You saved my day! I don’t use GeForce Experience, I always only install the driver but someone suggested as a fix to set it to ‘Let the 3D application decide’. This didn’t help and with this setting UserCfg.opt was reset everytime I started MSFS. Even more odd: after making that file read only and checking that Sharpen was still at 0 (which it was) everything still look extremely sharp!

After reading your post I set nVidia to Use the advanced 3D image settings again but left everything at default. This time…

… Sharpen stayed at 0 even with the file NOT set to read only (big plus!)

… the sharpen effect was actually off!!! Awesome! So I finally got this working! The sim looks a bit fuzzy now and I will play with the nVidia sharpen settings later on but even fuzzy the sim looks a LOT better! Finally the trees and buildings don’t stick out anymore and everything looks nice and realistic! (I wish you could sharpen the cockpit only and leave the scenery as it is because it looks a lot more realistic to me this way)!

So thanks for the information about that nVidia setting which also applies when not using Experience!

1 Like

Just want to give OP a thumb up for all the works and follow up!

2 Likes

What resolution is your screen.Yes one drawback with it off everything appears fuzzy here on 2k and I am a having a hard time finding the best value for the Nvidia sharpening.
You will noticed the sim appears clearer.You can increase your rendering scale up to what your GPU can tolerate.

1080p

I tested various nVidia sharpening settings and currently have it set to 1.00 sharpening (otherwise I hardly see a difference… and it’s mainly the ground textures that look a bit sharper with this setting) and film grain also at 1.00…! Anything lower and the film grain will introduce the pixels I am trying to get rid off!

So yes, Sharpen at 0 without any changes in nVidia makes everything look fuzzy but I really like that a LOT more than the ugly oversharpened look! And with nVidia at 1.00 and 1.00 things look a bit sharper here and there without that ugly pixelated noise. This will do for now until they screw up something else with the next update. :wink:

BTW It’s a shame you can’t change nVidia setting on the fly: restarting MSFS to test settings is a real PITA.

EDIT
LOL Scrap that 1.00 and 1.00… I didn’t test that on the ground yet and it looks awful LOL I think I will go for the posted settings of 0.33 and 0.17 for now. :wink:

Nvidia sharpen off in game sharpen off


Nvidia sharpen on 0.10 strength in game off
present time I will live with it off

Please note my post is first and foremost for 4K with the 2070S for which I explain the rationale using the Nvidia CPL Sharpen filter and disabling the FS2020 Sharpen post-processing effect.

The main reason for this is because in order to gain fps and to balance visuals the 2070S in 4K runs much better with TAA 70%. However at 70% rendering size it gets inherently blurry. The purpose of the Nvidia CPL Sharpen setting when taken not in isolation but globally with all other settings I’ve recommended is to restore just what’s necessary of the sharpness lost with TAA 70%.

1 Like

Clear. I am even back to no sharpening at all. Feels the best right now.

Cool thread! Thanks for the work, saved me a lot of time to find me the best settings with my rig.
Am running this on a i8700k with a ROG Strix 2070 (no super) on 4k, and with the settings mentioned over here, I got an excellent performance.
BUT

I wanted to stretch my settings towards ultra a little more, therefor I thought to start with a fps limit of 20fps (which is perfectly ok with me) in the Nvidia cp.

My GPU is now running on a 55% (instead of 100% and appr. 35fps when I do not have this limit), and is only 54degrees celsius, with 6gb (of a total of 8) of its memory being used.
So I would say, I can add some ultras in the screen… however…

I do see (only in cockpit view) randomly flickering black rectangles in my screen, only in ‘the outside’ (so not on my cockpit itself, but in the sky / ground textures).
When I go to the full outside view I do not see them, only inside my plane.

Does anybody know what this phenomenon is called/how to solve it (yeah, yeah, to release the fps limiter ;))?

I do not have this with other (sim) games, nor when I release the limit on the fps. So I am a bit suprised, cause my GPU is not stretched anymore now, and should have time enough/resources enough to avoid this.

Thanks in advance!
Great topic!

I’m glad this guide is helping people with diverse CPU/GPU configurations and I thank you for sharing this!

As for the graphics visual glitch, do you mean without the limiter it is fine, but with the NVidia limiter you get flickering? Are these flickering white dots over black surfaces so much so you can infer polygonal shapes from the series of dots? If so this would be a seam between ground polygons showing up and I’ve seen a couple few lately over Long Island at night. Otherwise this might be dependent on the driver version (know bug solved in a later driver update), otherwise it is just a bug showing up in this particular case.

Given you can push to 35 fps, you might want to consider settling in between in limiting fps to 30 in the simulator settings instead of 20 in NVidia CPL.

Thanks for yr reply!

Attached a screenshot with the black rectangles. I am not experiencing this in the outside view (outside the plane), only when I am in the cockpit, and then only in the part where the scenery is, not on the plane itself or the cockpit.

I tried on 30fps and enountered less black dots, so indeed I am considering to go to 30fps (while the ultra settings are less important as the current settings are stunning anyway).

With regards to the rectangles, I am just curious what it can be. Its not REALLY blocking, but it isn’t normal either.

Cheers!

These resemble what you’d get with defective VRam cells, or this is just a bug in FS2020 shader code. Are you using the exact same FS2020 settings I’ve posted, verbatim?

Jep. Had exactly the same properties as you have, except for the last part, the change of the configuration file. Strange thing is that all of a sudden during a flight, it dissappeared every now and then.
Even during landing, where almost all of my vram is used (7.5gb). No issue at all.

As said earlier, I used your settings as a starting point, and with 20fps I had plenty of room left to upscale some settings. Therefor I put the Anisotropic filtering to 16x and the Supersampling to 8x8. Just to put my memory even more to its limit.
No issue at all at 20fps now - and full Vram, and theb GPU is not running at 100% (am impressed of this 2070). Therefor I doubt that it is a Vram issue - even more, that I only have in 1 particular view, and not in other games, desktop enviornment, or the cockpit part.

BTW - I experienced these issues earlier as well, after the #update 3 some 4 weeks ago. So lets not spend too much time on it anymore, even more that I have the settings even better now, and dont see it anymore… Strange issue it is.

So thank you very much for your time, I really appreciate it, but let’s not spoil this topic with this (individual issue) anymore I think - cause its not your settings, they are good!

Cheers!

1 Like