My 2070 SUPER VR settings and suggestions (Index - SteamVR) 🟢

Hi, Just sharing my experience. Had everything running great in VR with CptLucky8 suggestions, then made the mistake of trying nVidia driver 461.09 with Steam linux 1.14 and EVERYthing went to H**L. Horrible stuttering in VR and screen mode… Basically unplayable. I have been reading all the complaints on this forum about how bad things could be and was grateful I had never had such terrible experiences, but 461.09 showed how bad it could be. Also, I don’t know if related, after I updated Nvidiia driver, rebooted and started FS2020 it made me reinstall the last update. Thought that was the problem, but after doing a clean install of 457.30, everything back to normal.
Thanks all

1 Like

Hi @CptLucky8 i @CptLucky
Could you please provide any more info on this setting? Following your guide and using the linux driver for the index i can now average 47fps on my 3070 10thgen i7 with everything on high/ultra and the Index HMD set to 120hz. It plays so great now its amazing. Airliners a a litter stuttery but I usually only fly light aircraft anyway.
I am finding that the scale of the cockpit is well off using this driver but I cant find this exact config file in the location you mentioned. I did find one with a similar name that had a bunch of resolution settings and refresh rate but i could not see a line for the ipd offset.
Thank again for all your amazing info on this forum.

1 Like

This is because you have to add it!

Aha I wondered as much, but was too scared to just do it Incase it did something irreversible. Will try tonight. Thanks

1 Like

A quick note to all:

I’m updating the OP from time to time not only when I’m making new suggestions, but also in keeping a wish list of bugs and features you can vote on. If you don’t happen to revisit the OP from time to time, here is the current list.

If you find these important to you, please vote!

2 Likes

There is a new beta of SteamVR v1.16.1:

This includes a new per-app setting that allows overriding the automatic throttling behavior to lock the application to a specified fixed framerate. Most importantly, this allows you to go beyond the automatic limit which stops at 1/3rd rate. I find I needed to drop down to 1/6th framerate @ 120Hz (i.e. running at 20 fps) in order to make a steady framerate due to being cpu bound.

If you previously disabled Motion Smoothing, you may want to give it another go with this build. It works much better once you’ve stabilized your framerate, and the previous limit of three frames of extrapolation has bee extended to six frames to cover this new range of fixed throttling. Running the sim at 20 fps motion smoothed to 120Hz works amazingly well. Of course the prop is still a problem, but there are mods to remove those.

To access the new throttling setting, click on Per-Application Video Settings in the Video section of SteamVR’s settings (accessible via the desktop or in-headset via the dashboard).

At the bottom you’ll see a new Throttling Behavior checkbox, toggle it to Fixed, then you’ll get a slider that allows you to select the framerate to lock the application to (note: these values are integer divisors of your headset’s current frequency).

I find it useful to bring up SteamVR’s Advanced Frame Timing graph (under the Developer sub-menu on the desktop widget) when adjusting this to find the right value.

You will notice that as you move the slider, the cyan line in the CPU section jumps to the new throttling setting (reported in extra frames rather than fps). You’ll need to have the app running while making changes in order to see this.

This is what you are ultimately shooting for:

Note: The blip at the end is due to taking a screenshot. Also, if the FS2020 window doesn’t have focus, the performance is all over the chart, so after you make your change, be sure to click back on the Flight Simulator window and give it a few seconds to settle.

For reference, here’s what the Auto settings looked like for me to begin with:

The main thing to note here is all the red in the top CPU section. You can see that SteamVR was trying to throttle the app at 1/3rd framerate (2 extra frames), but the red bars indicate that it was still falling behind.

On the bottom GPU section, looking at the white line, we see most frames were being shown five times, occasionally jumping to six. In-headset this winds up being pretty jittery.

Here, I’ve switched to Fixed throttling and dropped the sim framerate to 24 fps:

Now, we’re getting close. The Throttle and Predict lines are nice and straight, but we’ve still got a lot of red bars. Looking at the bottom GPU section, we still see that most frames are being shown five times, jumping to six. The cyan “Ready For Use” line (which corresponds to how long the frame took to render) now has this odd stairstep pattern which appears to correspond to the stretches of red bars above. This is the app getting further than further behind each frame until it finally wraps back around and starts over.

One more click down to 20 fps and finally things look good (this is the same image as above):

No more red bars, and all the lines are nice and straight. You may notice that the white line is now a steady six. This is “worse” than before. We were doing mostly five bouncing the six, but the problem was that the app simply couldn’t keep that up at a steady rate, so dropping down to six is actually better because it creates a smoother experience.

Once you are at this point, you can then play with upping your gpu settings, since we are now giving the application more time to finish each frame.

9 Likes

Can confirm that SteamVR beta 1.16.1 fixed my frametime issues, pretty much all of them. Motion smoothing now works correctly, in all Hz settings.

Now I run my Index at 80Hz with render scale 110%, everything else high (reflections, volumetric clouds, ambient occlusion, etc), and can maintain 40 fps in NYC (9900K/3090 setup) with motion smoothing on and locked 40 fps setting. Massive improvement in image fidelity compared to before having to settle with reduced render scale and other settings to try to maintain stable 60 fps in 120Hz mode. No more unusual frametime spikes.

1 Like

This is excellent news! thank you for sharing this at the perfect time I was about to try something in VR with G2 + WMR, thus ruining my evening in being forced to plug my Index back :joy:

This is good news and this addition is telling me our efforts to communicate about this issue as much as possible, along with great graphs and explanations like yours are actually helping indeed (I took the liberty to send links to your specific posts with these graphs and a few others of mine to some people at NVidia and WMR in case this would help them assessing the issues). Because if not provided as a direct answer to the issues, this will certainly help them monitoring the problems using telemetry of some sort.

1 Like

There is another very important piece of information in the SteamVR 1.16.1 beta release notes:

SteamVR now passes all OpenXR 1.0 conformance tests on Windows for Vulkan, OpenGL, D3D11, and D3D12

I’m testing right now but I can’t push as far as you do with the 2070S. This is not definitive but I’m currently trying for example TAA80 SS200 24/120Hz Reproj. OFF with the A320 around Dubai and this is quite good actually!

However for anything with reproj. I have to lower the SteamVR SS. Exploring this right now!

Update: here are a few combos I’ve tried with great results over Dubai with A320 with the 9700K+2070S:

TAA 80 SS 200 24fps/120Hz
TAA 80 SS 100 26.7fps/80 Reproj.
TAA 100 SS 100 24fps/120Hz +50ms Reproj. (my fav for now)

However I must say the SteamVR motion smoothing is really less good than WMR implementation, let alone the perf:

  • I can run the G2 at slightly more render resolution and more post-process resolution, with motion smoothing (3 frames only) with little to no artifact.

  • I can only run the Index at lower res and lower post. proc. res, using 5 to 6 frames motion smoothing with more artifacts.

The main difference in the WMR implementation is the use of the depth buffer IIRC. This is effectively making a difference especially when close up features are over farther away ground for example. But sure enough, this new SteamVR is really promising and I no longer need using 1.14 even without reproj, and I can finally compensate the wrong FS2020 IPD thanks to IPD override in SteamVR and get a normally sized A320 for example!

I don’t usually read the version updates for the Beta but saw it had switched to .16, so decided to check them out, and got pretty excited when I saw the updates. I haven’t messed with it too much, but found that with my Index at 90Hz, and the FPS locked at 30, everything seemed pretty smooth in game with my 9600K / 1080 and 32 gigs of 2800, even with the render resolution at 100. Rest of my settings are a mix of med/low with textures on high. I was just using the graphs with fpsVR - frametime for the GPU was 28-30 and the CPU was around 13. I also noticed that motion smoothing works better now as well, but only tried that briefly. I probably won’t mess with it too much more on my 1080 as I should be getting my 3080 tomorrow and will have some time this weekend to get things more dialed in. Definitely happy to see these improvements to SteamVR though! They must be watching the sim forums!

1 Like

I did a couple of test flights and this SteamVR beta update appears to be an absolute game-changer–at least for me.

I locked the FPS at 40 and after some initial fluctuations it absolutely sat pegged at 40 the entire flight, even through rapid turns and fast nape-of-the-earth flying. No stutters. No red bars or spikes in the frame timer. Super smooth and vastly more enjoyable than anything I’ve seen previously, despite hours of fiddling and tweaking.

Motion smoothing is still a bit of a mess for me, so I left it off, but I am otherwise encouraged and excited by what I am seeing here. Appears I even have headroom now to increase the settings and improve the visuals.

Hopefully not a fluke that reverses itself next time I climb in the cockpit.

2 Likes

Can’t wait to try the Steam update.
Until then…am I doing something wrong, in that while flying in VR mode, if I attempt to try different Steam settings, ie refresh rate, turning motion smoothing on or off, when I return to game, I hear the engine sound ( so it’s still running), but the headset screen goes black. If I return to Steam settings , go back to my original settings, the picture comes back. Do I need to change any Steam settings ( in game Graphics setting can be changed with no problem) when not in VR mode?
Thanks

Usually when I change SteamVR settings like motion repro or the new frame rate limiter, it is working immediatelty. However for the HMD Hz or the SS value, it usually takes changing the value in SteamVR, then exiting VR mode, wait a few secs for stabilization/cleanup, then enter VR mode. I didn’t find a way to add the FS2020 entry in the SteamVR title list otherwise I would exit VR first then change settings after.

I’ve been trying out a little more combinations but no matter what, reprojection is not as good as WMR, especially because the later can push more pixels with less artifacts with a higher HMD panel res.

Nevertheless I’ve found a few interesting combos best for airliners* with the Index on my test hardware:

TAA 100 SS 90 | 144Hz 28.8fps | Reproj.
TAA 100 SS 90 | 80 Hz 20.0fps | Reproj.

Now what I’m wondering is how would this latest SteamVR 1.16.1 run with the latest NVidia drivers. I don’t have time to test it for now but this is making me curious.

*that is trying to keep TAA 100 for EFIS legibility.

can you add more information on this? I have it running since I built my computer and never noticed any problems related to it. but in other hand, I have never tried anything on my computer without having it installed, so I might have never seen my computer working the way that it was supposed to.

My specs are:
I7-8700K OCd
RTX 2080 TI OCd
DDR4 64Gb - 3200Mhz

Thanks.

The first issue is that it has a “settings optimizer” with a FS2020 profile. I believe it is active by default the first time you install it and it will therefore interfere when you’re trying to adjust your own settings.

In addition, some have reported GFE was taking some valuable resources on their system, therefore there is no need to install it (for nothing if you don’t use any of its functions).

But more importantly, NVidia is now including a SDK (I mention this in my post(s)) which seems to be interfering and causing stutters. I believe it installs with GFE only and is also most likely the tech needed to the auto-optimizer. Therefore in not installing GFE you’re not installing this SDK as well.

thanks.
Also…you are such a great source of information, hope I am not taking advantage.
I am using linux_v1.14.16 and see there is a new Steam client that you are liking, but Steam says “Your Steam client is already up-to-date.”
can’t find how to update to 1.16.1.
Thanks,
Steve

thank you for your kind words! right click SteamVR in your library > Properties > Beta > select in the list “Latest Beta” (or similar).

1 Like

Quick update: I’ve tried 461.09 with SteamVR 1.16.1 as I wanted to check whether it would matter, and I didn’t took precise measures but with motion smoothing it was not so bad at all to the point I could barely notice NVidia driver typical stuttering. To cross check, I’ve tried again the G2 with WMR OpenXR and 461.09 right after and it was really stuttering too much. This is becoming quite hard following up with all the changes!