Navigation: loading custom waypoints from .pln files is broken on some systems

Are you using Developer Mode or made changes in it?

I can reproduce the issue with or without Developer Mode. I have not made any changes in Developer Mode that affect the sim when Developer Mode is disabled. Not even the FPS counter.

Brief description of the issue:

Custom waypoints are no longer correctly loaded from .pln files. They all end up at the north pole, I think. This bug affects both flight plans created using the World Map, as well as flight plans created using 3rd-party tools like Little Navmap. This is not only a cosmetical issue in the World Map window, the G1000NXi also wants to go to the north pole when you start a flight with custom waypoints.
Good luck with the next community flight. SCNR.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

go to the World Map
plan a flight between any two airports or airfields
add a custom waypoint
save the route as a .pln file (More / Save to this PC / select “.pln file” / enter name and confirm)
load the .pln file you just saved (More / Load from this PC / select the .pln file and confirm)
the route will go from the departure aerodrome to the north pole and back to the destination aerodrome

EDIT #3: this is related to whether Navigraph is installed or not. Navigraph confirmed that they can reproduce the issue, their assessment is that it’s a sim bug that can only be fixed by Asobo.


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

No

Provide extra information to complete the original description of the issue:

Can’t reproduce using Little Nav Map export of .PLN file. File is included in this post. Note two custom Waypoints passing over the town of Dinalupihan and Olongapo City.

If relevant, provide additional screenshots/video:

VFR Ninoy Aquino Intl (RPLL) to Iba (RPUI).pln (2.9 KB)

For reference, the issue on the LNM Github: Issues exporting to Flight Simulator with SU10 beta · Discussion #930 · albar965/littlenavmap · GitHub

This is what happens when I load your flight plan on my system (I downloaded it and used it “as is”, I did not load it in LNM and re-export it):

Thank you for confirming that the problem is not related to wrong data in the flight plan. The issue happens when loading a flight plan, and apparently only on “some” systems (“some” being PR speak for any amount shy of 100%).

I have a hunch. The decimal symbol on my Windows system is a comma, since I’m in continental Europe. So is the developer of LNM, and so is the guy who posted about the problem on Github.

What’s the decimal symbol on YOUR system?

Windows localization is set to US English, so decimal is a “period.”

1 Like

I can see a possibility of the beginning of the emergence of a pattern. Let’s see if more people chime in when Europe wakes up.

Have you tried uninstalling Navigraph and did you by any change delete the content.xml folder?
That might be the cause of this problem

1 Like

I had a similar problem until the next update of LNM Navigraph data

Without Navigraph, I cannot reproduce the issue any longer.
With Navigraph, even with the latest cycle, I continue to get sent to the north pole.

Next up: find out whether it’s something that can be fixed on Navigraph’s side, or if we have to decide between Navigraph and custom waypoints until the issue is fixed by Asobo.

(Of course something like this happens as soon as I switch to a yearly Navigraph subscription. Now I can’t even pause my subscription until the issue is resolved. If I have to decide between Navigraph and custom waypoints until SU11, I choose custom waypoints, as they’re more relevant to the kind of flying I do.)

I asked on the Navigraph forum and the Navigraph people were very quick to look into the issue. Here are the money quotes from the response:

In both version [SU9 and SU10], I have installed the same AIRAC cycle 2209 - so it looks more a bug in the SU10 beta somewhere. Normally, when you load a PLN file in the sim - it´s independent which AIRAC cycle you have installed because all the user-waypoints comes directly from the PLN file and these waypoints shouldn´t be checked against the cycle.

Again, I can´t explain why this doesn´t happened when our package is not installed - possible that we must compile our package against the SU10 tools, which was not the case here because we don´t support any beta - but it really looks that there is an issue in the SU10 beta with such waypoints.

As soon as SU10 is out and we can compile it against these version, we will try to make another test. But I´m pretty, pretty sure, that this has nothing to do with our data. It´s working as expected in the current version with our data and the navdata schema wasn´t changed between SU9 and SU10. So the only open point is the data compilation which was done with SU9 and not with SU10.

And, a bit later:

Now after a few additional tests - I´m now 100% sure, that this is a sim bug in SU10 beta.

Store your planned flight with custom waypoints NOT in the PLN format, store in in the FLT format. The sim creates both versions (FLT and PLN). Now, when you load the FLT file, all is good - do you open the PLN file you see the issue.

So, it´s definitively an issue with PLN files, in combination with custom waypoints. That has nothing todo with us - can only be fixed by MS/Asobo - sorry for the bad news.

1 Like

Thank you @aurel42de

Indeed, it looks like an issue in the SU10 beta version. When you load the PLN file in the current sim version 1.26 - it looks normal. When you load the same file in SU10 beta - the custom waypoints are somewhere but not in place.

Another test, why I´m pretty sure that this has nothing to do with our data:
Save the planned route with the custom waypoints in the default FLT file format - the sim creates both formats automatically (FLT & PLN). Now, when you load the FLT file - all looks good - when you load the PLN file, you see the issue.

Sorry, not sure what and how we should fix this
Richard

2 Likes

So I am on stock Navblue but on SU10 Beta. I can load that LNM-generated PLN file and it appears just fine.

@NAVData does this only affect Navigraph users or has anyone tested with stock Navdata?

I’m not clear on the details, but if so, can you detail this on the MSFS Developer site, and I’ll ask the CMs here if they can cross reference this thread to the Dev Team?

Jumping in here…

The issue does not affect stock Navdata users, that’s why it worked for you, when you tried to reproduce it.

It will affect users of Navigraph navdata, it could affect users of other 3rd-party products (like Aerosoft’s navdata product, maybe even other, non-navdata products – worst case scenario: airport add-ons that extend/replace the stock navdata with local procedures), but we can’t know because it’s unclear what exactly triggers the wrong behaviour.

The fact that you can work around the issue by setting up a flight with custom waypoints on the World Map, saving it as a .flt file (instead of a .pln file) even with Navigraph installed, and that file loads correctly with all custom waypoints intact, seems to indicate that the navdata isn’t causing the bug (in that case, we’d expect that you can’t circumvent the issue just by using a different file format). It might be that the presence of 3rd-party navdata somehow triggers a bug in the Asobo code for parsing .pln files.

1 Like

This sort of makes it tough on how to get it fixed, because if it works with stock Navblue, the only folks who can dig into the problem is Navigraph.

… but something MUST BE changed between the current version and the SU10 because as I wrote, the same PLN file works normally in the current version with our data installed. So, there are only two possibilities:

  1. the data format is changed - according the latest SDK 0.19.3, no change
  2. something is changed in the sim behind the scene, what we don´t know

Again, load this PLN-file in the current version, with our data installed and you will see this:

Cheers,
Richard

Thanks @NAVData - is there way you can raise this on the MSFS Developer site, and I will ask the CMs here to cross-reference both to the Dev Team?

Yep, will do @CasualClick … no prob

Cheers,
Richard

6 Likes

If you can just drop the link to the post on the Developer forum here please, I will get it tagged and escalated up. Thank you!

4 Likes

Should I mark your post as “solution” (because the issue will be tracked by other means) or leave the thread as is (because the issue isn’t solved)?

@CasualClick done - I have reported this in the developer forum and have asked about the “why”?

Here the direct link to the developer forum:

Cheers,
Richard

4 Likes

I’d leave this open for now until we get a tag status change to either feedback-logged or bug-logged.

4 Likes