Need help, Airworthy Designs TNCM Addon

Hi

A strange issue that i hope either MS or Asobo can shed some light on. I had purchased the TNCM addon some months ago and it worked fine until two days ago when i was advised by Simmarket an update to v1.4 was available. I download it , restarted the PC and went to fly… Boom ! Ctd as soon as the bar progressed halfway on loading the flight.

I tried again, with the same issue. I rolled back to the previous version , now that CTD’s exaclty the same??? I then removed the addon, and loaded the default TNCM and that works fine.

I contacted Simmarket, who said nothing to do with us, go to the dev, i tried the dev, nothing to do with us , it’s an Asobo/MSFS issue???

They are both stating it’s due to the recent update, and basically tough!
I have tried just about everything… Ran with admin rights, and without, installed with only the addon in the community folder, disabled Anti virus etc, ensured daily Win10 Home is upto date, as is the Xbox app, And MS store. Bing data off, or on… still ctd.

I think it’s pretty disgraceful after sales assistance from both of the companies mentioned. And i don’t think for 1 second it is an issue with the addon due to the last World update as all of my other payware addons are working as is the sim, without any other issue. (I have around 50 payware addons) Which i can keep seperated as i use the Addon linker which save on load times, and keeps my files on another drive.

But even installing only the TNCM addon normally into the community folder results in the same CTD, virtually proving there is an issue with compatability somewhere…

Any idea’s?

Buyer Beware!!!

There are no posts or reports that I can see that anyone else is experiencing the issue.
It tends to seem there could be something going on at your end.
I have seen a few posts in the last few days where folks with 32GB ram had to go to from a system managed to a custom page file size to stop CTD’s
Might be worth a try.

1 Like

I have TNCM, but via the ingame marketplace, but if you buy it from the developer’s site, is there not a way of doing a clean install of the updated airport, just in case something in the updated files has become corrupted?

1 Like

Yeah i had done the page file fix a couple of weeks ago. It a strange one, as it worked fine until i installed the update via Simmarket. Once installed it crashed right away, i rolled back to the previous version, and that to ctd’s now. Only the default Asobo version will run without issue.

Crazy thing is all my other payware addons run fine… the sim runs fine now since the last update

Hi

Thanks for your reply, i did re download the updated file v1.4 (I see the market place version is still v1 on here) just in case it was corrupted. The only thing i can think is its some compatabilty issue with another addon? Mind you. that cannot be right either, as just TNCM only in the community folder and it crashes.

@N95JPL , the guy who does the modded C152, when he released his latest version appeared to be suggesting that a file structure for mods has been changed by Asobo and I wonder if the TNCM devs haven’t built this into their update?

" IMPORTANT: Due to a file structure change, please DELETE the original “MSFS_C152” folder and then copy the new version in, do NOT overwrite the old version!"

Maybe not the cause of your issue, but it might be worth checking out.

1 Like

Try this solution. It’s for a different addon but should work and doesn’t hurt to try. Replace LFOU in the solution below with the addon airport you are having problem with, which in your case is TNCM:

"This can happen with any add-on scenery, whether purchased from the Marketplace or downloaded from the interweb (e.g. flightsim.to) and added to your community folder.

And you can fix it yourself. It’s quite straight forward.

What’s happening is that sometimes scenery developers are leaving behind some of the default folder names as they are initially created in the template for a scenery project. Then later, when you have more than one of these scenery addons installed with default names there is a name clash on the folder itself, or more likely one of it’s contained files, that can cause your CTD.

If you look inside the LFOU addon folder, then the MaterialLibs folder you will find a folder called ‘mymaterials’. Here is the cause of the potential name clash.

C:\Users\USERNAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Official\OneStore\azurpoly-airport-lfou-cholet\MaterialLibs\mymaterials

If you look at the same sub-folder in most other scenery addons you will see that this folder name has been changed to something unique for that airport.

To fix this - simply change the name of that folder to LFOUmaterials. I always use the ICAO code for the airport followed by ‘materials’. This is unlikely to result in a name clash since the ICAO codes are unique to an airport. (I know - teaching grandma to ■■■■ eggs - sorry ).

C:\Users\USERNAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Official\OneStore\azurpoly-airport-lfou-cholet\MaterialLibs\LFOUmaterials

Then, at the root folder for the addon scenery you will find a layout.json file. It’s a text file. You need to find and replace each instance of ‘mymaterials’ with ‘LFOUmaterials’ or whatever you called it.

C:\Users\USERNAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Official\OneStore\azurpoly-airport-lfou-cholet\layout.json

I also recommend two tools to help you with this. You need a good text editor for the find and replace operation. There are many good free text editors. I use ‘VSCode’. I also recommend using ‘Agent Ransack’ to search for any files with the file/folder name your changing. With this tool you’ll have confidence that you changed all the files/folder names that needed changing."

Source: Paul Wareing from https://orbxsystems.com/forum/topic/203357-tacoma-narrows-ctd/?do=findComment&comment=1743926

4 Likes

WOW- THANK YOU!!! I’ve been fighting this with another addon for a few days. Frustrating. Solved a checkerboard texture issue I had.

Sir, your a genius… the initial step of renaming the materials file to TNCMmaterials has cured the CTD issue. and TNCM v1.4 now runs with no CTD

I now have the checkerboard textures on the beach to sort out, i take it the actions needed are the second part of your message, i just hope i can do this as it is a bit beyond my understanding of working with coding and files, i will certainly give it a try.

Thanks again, after absolutely no back up from Simmmarket or Airworthy Designs (they surely must be aware of this) It’s a credit to the community the amount of help that is available from fellow simmers.

Microsoft-Asobo, Please make people aware of this issue… it can save days of frrustration !!

This is simply untrue. They should take care of their naming. Having an asset named mymaterials isn’t good practice. They should fix that with an update.

3 Likes

I agree. in my mind i purchased their addon, it is their responsability to ensure it works properly, and just shows corners are being cut that can cause reall issues for the customer.

I could quite easily have just blamed MSFS2020, and the usual it’s crashing all the time, yes it’s crashing, but due to a 3rd parties addon!

Yes - updating your layout.json file will fix the checkerboard. I went through the 2 I had last night and both are solved for me.

1 Like

Thanks @sttovo, in the process of working through them just now.

1 Like

That’s grossly inaccurate :rofl:

The real genius is Paul Wareing. Please say thanks to him in that ORBX forum thread I linked earlier if you can/want :slight_smile:

1 Like

:smile: I certainly will, but thanks for your help sharing that info.

Right, as i said got it running but i am still missing all the parking lines, and taxiway markings etc, also the beach is still checkerboard. i ran agent Ransack and it confirmed all the enties have been changed to the tncmmaterialslib blah blah. so a bit stumped now.

Ok so to confirm, did you update your layout.json file?

Edit - this is the easiest way: GitHub - HughesMDflyer4/MSFSLayoutGenerator: A drag-and-drop application for updating layout.json files in Microsoft Flight Simulator (2020) packages.

Download the exe, then drag your addon layout.json file over top the exe and it will update your layout.json

The QA process for the Marketplace should have a simple file search for these default names and packages should not be approved for the Marketplace that use them.

That’s in the assumption the add-on was purchased in the marketplace. You can get add-ons from anywhere.

It was not purchased from the Market place, it was purchased from Simmarket, as i stated in the first post.