Need to use Task Manager to Quit or Shutdown MSFS

Those who experience this, are you running any mods in the community folder or from the marketplace?

Would be good to see if there’s some common factor.

same issue here

I’ve been having this problem also.
My suspected mods are

  1. Volanta
  2. OpenXR Toolkit
  3. Google Map Replacement

I have disabled (and uninstalled) each of these one at a time and have not found a consistent pattern. The problem seems to come and go no matter what add-ons I have activated. The only time the problem disappears is when I have all three uninstalled.
I also suspect it is related to VR.

1 Like

For me this was happening prior to SU8 with vanilla MSFS, Windows 11

1 Like

I don’t use any of these nor am O using VR. Go figure.

Please tag your post with #pc and/or #xbox. PC

Are you on Xbox, Steam or Microsoft Store version? Steam

Are you using Developer Mode or made changes in it? No Developer mode

Brief description of the issue: After SU8 Iv’e been experiencing intermittent problems with shutting the sim down. Every so often it will hang when trying to exit to desktop. I go into task manager and MSFS is not responding. I have a 10900K - 64 Gigs of Ballistix - Nvidia 3090 and a Samsung 970 Evo Plus 2Tb. I am running the Steam version and have not used developer mode at all. I have tried with the Community folder full and empty - same results. I was just wondering if anyone was experiencing this also. Thanks everyone and stay well.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

I have seen this a couple times more recently. Never really saw it before. I do have a couple programs running in the background connected to the sim that I was guessing might be contributing. Little Navmap, V1F instrument panel app, Volanta. Perhaps they are not releasing the sim?

I just started using Volanta around the same time this happened, but perhaps that is just coincidence.

I also have the same issue , the work around is select exit , then wait 20 sec before selecting OK …
It will close perfectly

Regards

1 Like

Since sim update 8 I have the sameproblem:When choosing quit to desktop msfs doesn’t respond anymore, when I have clicked on OK.
PC-Version from Microsoft (not Steam). I then have to end it with the task manager.

Hello,

to me I discovered this, after flights and if I want close sim pls don’t go to Profile, Logbook and also don’t move flight sticks/joysticks/throttle. If I do not that things prior close sim, all is ok with exit.

Did you experience this prior to SU8?

If you’re positive this issue isn’t due to addons then use task manager to create a dump file when the problem occurs and submit it to Zendesk.

In my case the problem started a week or so before SU8. About the time I installed Volanta. That’s why I suspected a connection.

This didn’t work for me, unfortunately.

Yes this was already with SU7 for me.

Especially when having used dev mode but now also without at times.

Never looked for a pattern in this behaviour, not bothering me much.

I don’t use dev mode and I did not have this problem prior to sim update 8.

1 Like

I’m having the same problem and I never did before. Have to end task in TM. Started recently for me so with SU8 or after.

Fortunately the workaround suggested above (clicking OK to exit msfs not before a wait about 20 -30 seconds) does work for me. Allthough it is a bug that has to be solved.

This is happening to me but after SU8…voted

Yes, MS store version, since SU8