New Issues Since Patch

I experience the same with CJ4. Autopilot is messed up. It only works for following waypoints but everything else is not. Alttitude hold, FLC not working at all. I dont know why asobo keeps messing up AP. I hope Asobo concetrates on fixing the game first rather than improving or adding new sceneries to the game.

I can’t even launch a flight without crashing, or zoom into the globe map to select an airport without crashing to desktop. Worked perfectly fine before.

This times 100! They should really reorganize their process and just put a halt on design upgrades and focus on fixing everything first. That of course would depend on how many programmers they have as upgrades to visuals and such are typically done by 3D modelers. But even the new TAA, while making scenery look sharper, it ruined the clouds with serious graininess and screen door effects.

First Post!
After the last patch (11/24) today, the sim keeps crashing, (not the planes) so far just flying the Cessna Citation jet. Both with and without autopilot 4 times so far, usually between 5 and 15 minutes into the flight. no symptoms before it just stops, Very disappointed and frustrated!

1 Like

Totally agree with you.
Developers should focus on real enhancements in the game.
Happy with 1.10.11 patch, dissapointed with 1.11.24.

10 Hrs stuck at 126/172…

I would just like the A32NX to work again.

I too had CTD when pressing ESC and requesting “Back to Main Menu”.
Removed FS Academy IFR, and now, no more CTD. Let’s know if that helped.
I hope FS Academy or Asorbo can fix this.

[repeating my post here, as this seems to be the larger thread on this issue]
Oddly, for a couple days, no problems at all. Today I now get a lock up (not a CTD) when I start a flight from the world map after I click fly and the plane appears on the taxiway. I can hear the engines and see the cockpit, but it is frozen. However, I can fly with no problem the landing challenges. Not sure what is going on, will continue to try to isolate it. I’ve emptied my community folder. My system is:

i9-10980XE OC to 4.7 GHz
RTX 3090
64 GB ram

Yes, that is something I tried too. I clicked on Launch and also Play and nothing happens !!!
The only thing I can think of is wait for the next update, but I’m lost for now.

Thank you for the feedback !

Those of you having crashes or freezing… how much 3rd party content are you using? I’ve never yet had a single crash or freeze up but I’m running stock MSFS except for a single add-on, the Saint Martin Airport add-on by a group whose name I forget. I’m wondering if those experiencing crashes are mostly those that have a lot of mods and add-ons installed.

I have the same problem with C172! The throttle is often unresponsive or hangs with full throttle!

I had exactly the same problems you are describing, and was as upset as you, as I only use de A320, which was working fine enough before the update, and this was completely game-breaking.

Yesterday, the last Developement Update drom A32NX proyect, fixed the problem for me. You could give it a try.

PS) Don´t be so vocal about faulty updates. Asobo-huggers will fall on you telling the sim is fine, and the only problem is your faulty machine and your incapacity to make it work properly (even if the only change was the update, it will always be your fault).

1 Like

I’m not having the oscillating anymore since the patch but as for the rest I totally agree engines won’t shut down, issues with ils, AP being screwy etc etc.
Tried a flight yesterday and when trying to do a approach the plane wouldn’t follow the way point, wouldn’t descend as programmed and ils just refused to work at all. Why is it that EVERY SINGLE update they destroy the sim and don’t fix a single thing 1 step forward 1000 steps back


Honestly, I disagree. For me, the A320 has worked by far the best compared to the 747 and 787. I haven’t completed a flight in either one of those airliners since launch, but I’ve racked up a ton of hours in the A320 because it flies the best. However, this isn’t the case anymore…

All sorted in version 1.2 as seen elsewhere.
Anyone looking to update please check your store has uploaded the newest version and redownload to solve the back to menu CTD.

1 Like

YeYe sorry been busy flying.

The A320nx mod has been updated and flies like a dream now.

HOWEVER, you must STILL DISABLE SEC1 to keep the wings from rocking. With it turned off she flies and lands like a champ.