New update in the microsoft store, sim deletes itself

I just got an update in the microsoft store (1.16GB) downloaded it, started the game and what happened … the simulator deleted itself, I should now download the whole game again … someone had that today same problem? :sleepy:


Same for me

1 Like

WHAT!? Was this a mandatory update? I was just about to go fly but but if this is what is going to happen I won’t. :grimacing::grimacing::grimacing:

1 Like

I got an update in MS Store of version and if I start the game I get the message a game update is available and then land in the store again.

Now I can’t user the sim. :roll_eyes:

1 Like

Same here! Downloading 100+ gigs now!

1 Like

Make sure you point the download to your original MSFS installation folder it defaults to the C drive and if you have it installed to another drive it thinks the game doesn’t exist and wants you to download the entire sim again.


Actually on sim startup I did just have a similar thing happen but my installation is on a separate drive and noticed the sim looked like it had reset itself! I wonder if all those who installed to the default path (C drive) have just had their entire sim deleted from a strange update bug!?

1 Like

My sim installation is also on a separate drive. I can start the App but then it requires a new mandatory update. And from the store I only get

I updated windows, nvidia drivers and rebooted computer. Then pointed update to correct directory and nothing was downloaded. Reboot was probably the one that helped.

1 Like

My sim is on the original directory the sim wanted from day one. I didn’t put it anywhere new or on a different drive. I have no mods. But now I’m afraid to even start it up. Will it destroy mine like it is doing to others??? :weary:

1 Like

Hmmmm strange… I take it you tried the usual to kick start the store and get it to check for updates?

Run the XBOX App and while that is running click on “get updates” in the MS Store.

1 Like

Same here all of the files in the official and community folder got deleted. Mine was installed on a different drive D:. My default is C: Need to download all of it again. Got the same message game update available.

Strange, never had a software that gets romoved by it self before when it should update.

1 Like

On start up tonight (was fine this morning), i got told there was a mandatory store update. Went to the staore and the update seemed to fail due to being disconnetced from the internet (which I wasn’t). Restarted the sim and it wanted to fully redownload to the default location, but my sim is installed to a separate drive. So I told it to look there and it didn’t download anything, and restarted normally.

1 Like

What I found really strange was that I was browsing the MSFS LocalCache folder around an hour ago as I was about to tweak a few settings in the config file and all of a sudden the entire contents of that folder disappeared! I thought it was a Windows glitch so I went back out of the folder and back in again and sure enough the folder was empty! Restarted Windows and still the folder was empty.

I then fired up the sim and as expected it wanted me to download the entire sim again until I pointed it to my G drive where the bulk of my sim is located. Once the installer found my files all loaded up fine apart from all graphics / data and some other settings had been reset.

As others have said, really strange how a piece of software can just delete itself like that! I thought I’d been hacked lol.

It was kind of the same for me, It downloaded and then it restared many times then i decided to restart windows and then it started up with an update of 115gb or something. Then looked into the installation folder and all all of the important files was removed. I’m not going to install it again before we get an official answere to why this happened. I don’t want this big download to get remove again.

For me, all of a sudden the sim started again, I had to point the setup screen to my installation folder and now all is ok. Maybe a little Halloween joke. :laughing:

Same for me - all settings reset - which looks like a wipe of that default folder. Makes me so glad I installed MSFS elsewhere when I first installed it!

1 Like

Was your sim installed in the default folder or on another drive?

Same here. The updater ignored my original installation folder on drive D: and tried to redownload to its default path on the C: drive. I had to abort the update, restart the sim and select my current content path, else it would have messed with my entire configuration.

A nasty, scary bug, people!!

1 Like

Maybe SU6 beta has something to do with this. They mentioned we needed to reinstall it when the official release got released. I only had a small update when it got released. I just want to help, hopefully i didn’t do anything wrong here now. But i’m pretty sure that is the problem. How many of us here is SU6 beta testers. I am.