No lights on aircraft ground traffic

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

no

Brief description of the issue:

no lights on ground aircraft at any airports. Using AI on-line traffic. PC

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Both the nav lights, landing lights and strobe lights turns off right at the moment ai touches down on runway. Nav lights should never turn off and strobes and landing lights should be on as long the aircraft is on the runway.

1 Like

Just another example of something a sim from 2004 already got right but Asobo failed to deliver for whatever reason. Sadly the whole AI traffic belongs in this category. At least they got the repetitive altitude callouts fixed, something neither in FSX or P3D ever got fixed. Step by step I guess :rofl:

1 Like

Right on man!

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes.

Provide extra information to complete the original description of the issue:

AI traffic has no lights now even in the air.

If relevant, provide additional screenshots/video:


there are at least 4 AI aircraft in this pic…

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes.

Provide extra information to complete the original description of the issue:

AI aircraft have no lights (neither Nav or Strobe) in the air either.

If relevant, provide additional screenshots/video:

I’m simply not seeing that. I just tried the MSFS online live traffic at EGLL and all the moving aircraft had their lights on, both in the air and on the ground. Then I tried AIG injected traffic, and likewise, they all had their lights on.

My experience applies on Xbox, I don’t know about PC.

Many ( I can’t say all because I haven’t paid attention to all of them ) AI and - I noticed earlier - multiplayer aircraft seem to turn all their lights off as soon as they’re in contact with the ground. I noticed a MP a/c spawn in & only had taxi lights until they took off, which makes life slightly more confusing.

We’ve noticed this behavior whilst testing FS Traffic. It appears that lights do work on ground with the light splashes from taxi, landing, beacon and nav lights all being visible. What is broken is the light halo’s/flares. As soon as an aircraft lifts off the ground they suddenly appear and then disappear again when the aircraft touches down.


The behavior of the lights themselves is far from ideal, with most lights switching off every time the AI aircraft goes into holding state.

Still happening in SU10, so frustrating.

I am experiencing the opposite. I have AI aircraft landing with lights, but the aircraft is missing. Maybe all the aircraft gone missing in the triagle, are now coming home.