No Update to available in MS-Store

After starting the Sim, it tells me that a “mandatory update” has to be downloaded through the Microsoft Store. But the MS-Store says that everything is up to date. What now?! I am confused.

I’ve had that happen sometimes… had to click on something – I think it was on the left hand side, and it jumped into life started the download.

Sorry, cannot remember exactly where, but the Update did not start by itself, intil clicked on that left had area.

After update, I don’t think that clickable area is present anymore. :face_with_monocle:

Same here…sucks.

1 Like

Ok fixed it……signed out of ms store. Downloaded Xbox app. Reboot. Signed into ms store account. Updated anything that need updates. Clicked on get update on top right. Up popped a flight sim update. Downloaded the mandatory update and it is loading now.
I tried everything over and over again previously. The only difference is I re-downloaded the Xbox app-even though I’m on a pc. I guess that did it- what a relief.
It is a ms store issue- not asobo or flight sim.
Good luck.


What an incredible nonsense Microsoft does here!
Jhkayakr1, you were right. Thanks a lot.
Originally I have no interest in Xbox. I don’t play games, I simply do not need them.
But after loading the Xbox App to my PC, the Flight Simulator Update worked all right.
What a messy system



You have to be very careful what you click on in the store, you can end up downloading the whole Sim again.
what country are you in?
( ■■■■, sorry this must be an old update )

This is the update from 1.18.14 to 15.
Well, after installing the Xbox App I opened the MS Store, went to “More infos” in the right hand upper corner and clicked on “Downloads and Updates”.
There I was offered the MSFS and opening this choice all went well.

I am from Germany.


Thank you for the tip. Very messy. Nobody thinks that you have to update your XBOX App on PC first. Very bad.
Steve from Switzerland.

1 Like

The ‘sign out’ from Store, ‘sign back in’, now hit ‘get updates’ dance seems to be working for me. No reboot needed.

Downloading update is very fast now! No more 5 to 7 MB’s ! Full speed 90 to 100 MB’s! :ok_hand:

Every single time the same sheit!
Is this lazy programming or just because it’s Windows?

Thanks for showing the way, I already forgot Xbrox …


I have MSFS via Windows Store and have the update - worked like a charm.

There’s a longstanding issue where many people don’t see the update in the Windows Store for hours or days after it’s released, unless they perform various steps to try to force it to show new updates. You may not be aware of this. :slight_smile:


No sight of it.

Hi same Problem for me. Only worked with the xbox app trick. Downloaded xbox app. Signed out in microsoft store. Signed back in and update appeared.

This is what i done now it works for me.

Worked for me as well… buggy ■■■■■■■■.

This worked! Thanks!

For me even the xbox-trick hasn’t worked. No update but the sim wouldn’t start either. I just get to the “mandatory update available” - message. Never had problems updating the sim before. What is going on at the MS-store? FRUSTRATING!!
Thanks to all members who share their workarounds here.

1 Like

I have just installed the XBox app, and withou a reboot I was able to update the program to the version withour requiring to reboot